发布时间 :2004-03-29 00:00:00
修订时间 :2008-09-05 16:35:17

[原文]Unknown vulnerability in rpc.mountd in SGI IRIX 6.5 through 6.5.22 allows remote attackers to cause a denial of service (process death) via unknown attack vectors.

[CNNVD]SGI rpc.mountd未明远程拒绝服务攻击漏洞(CNNVD-200403-115)

        SGI IRIX包含的rpc.mountd存在未明拒绝服务问题,远程攻击者可以利用这个漏洞使合法用户不能访问NFS服务。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:6.5.21SGI IRIX 6.5.21
cpe:/o:sgi:irix:6.5.18fSGI IRIX 6.5.18f
cpe:/o:sgi:irix:6.5.22SGI IRIX 6.5.22
cpe:/o:sgi:irix:6.5.6SGI IRIX 6.5.6
cpe:/o:sgi:irix:6.5.15SGI IRIX 6.5.15
cpe:/o:sgi:irix:6.5.13SGI IRIX 6.5.13
cpe:/o:sgi:irix:6.5.18mSGI IRIX 6.5.18m
cpe:/o:sgi:irix:6.5.14SGI IRIX 6.5.14
cpe:/o:sgi:irix:6.5.19fSGI IRIX 6.5.19f
cpe:/o:sgi:irix:6.5.18SGI IRIX 6.5.18
cpe:/o:sgi:irix:6.5.17mSGI IRIX 6.5.17m
cpe:/o:sgi:irix:6.5.11SGI IRIX 6.5.11
cpe:/o:sgi:irix:6.5.3SGI IRIX 6.5.3
cpe:/o:sgi:irix:6.5.19mSGI IRIX 6.5.19m
cpe:/o:sgi:irix:6.5.16SGI IRIX 6.5.16
cpe:/o:sgi:irix:6.5.9SGI IRIX 6.5.9
cpe:/o:sgi:irix:6.5.21fSGI IRIX 6.5.21f
cpe:/o:sgi:irix:6.5.12SGI IRIX 6.5.12
cpe:/o:sgi:irix:6.5.8SGI IRIX 6.5.8
cpe:/o:sgi:irix:6.5.20mSGI IRIX 6.5.20m
cpe:/o:sgi:irix:6.5.19SGI IRIX 6.5.19
cpe:/o:sgi:irix:6.5SGI IRIX 6.5
cpe:/o:sgi:irix:6.5.7SGI IRIX 6.5.7
cpe:/o:sgi:irix:6.5.5SGI IRIX 6.5.5
cpe:/o:sgi:irix:6.5.4SGI IRIX 6.5.4
cpe:/o:sgi:irix:6.5.10SGI IRIX 6.5.10
cpe:/o:sgi:irix:6.5.1SGI IRIX 6.5.1
cpe:/o:sgi:irix:6.5.2SGI IRIX 6.5.2
cpe:/o:sgi:irix:6.5.21mSGI IRIX 6.5.21m
cpe:/o:sgi:irix:6.5.20SGI IRIX 6.5.20
cpe:/o:sgi:irix:6.5.20fSGI IRIX 6.5.20f
cpe:/o:sgi:irix:6.5.17fSGI IRIX 6.5.17f

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  rpcmountd-dos(13808)
(UNKNOWN)  SGI  20031102-02-P
(UNKNOWN)  SGI  20031102-01-P

- 漏洞信息

SGI rpc.mountd未明远程拒绝服务攻击漏洞
中危 未知
2004-03-29 00:00:00 2005-10-20 00:00:00
        SGI IRIX包含的rpc.mountd存在未明拒绝服务问题,远程攻击者可以利用这个漏洞使合法用户不能访问NFS服务。

- 公告与补丁

        20031102-01-P:rpc.mountd Vulnerabilities on SGI IRIX
        SGI IRIX 6.5.18 m:
        SGI Patch patch5387.tar
        SGI IRIX 6.5.18 f:
        SGI Patch patch5387.tar
        SGI IRIX 6.5.19 m:
        SGI Patch patch5389.tar
        SGI IRIX 6.5.19 f:
        SGI Patch patch5388.tar
        SGI IRIX 6.5.20 m:
        SGI Patch patch5387.tar
        SGI IRIX 6.5.20 f:
        SGI Patch patch5387.tar
        SGI IRIX 6.5.21 m:
        SGI Patch patch5387.tar
        SGI IRIX 6.5.21 f:
        SGI Patch patch5387.tar
        SGI IRIX 6.5.22:
        SGI Patch patch5387.tar

- 漏洞信息

IRIX rpc.mountd Unspecified Remote DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

IRIX contains a flaw that may allow a remote denial of service. The issue is triggered when rpc.mountd can be forced to die remotely, and will result in loss of availability for the Network File System (NFS) service. No further details have been provided.

- 时间线

2003-11-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 6.5.23 or higher, as it has been reported to fix this vulnerability. In addition, Silicon Graphics, Inc. has released patches for some older versions.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SGI rpc.mountd Unspecified Denial of Service Vulnerability
Unknown 9084
Yes No
2003-11-21 12:00:00 2009-07-12 12:56:00
This issue was announced in an SGI advisory.

- 受影响的程序版本

SGI IRIX 6.5.22
SGI IRIX 6.5.21 m
SGI IRIX 6.5.21 f
SGI IRIX 6.5.21
SGI IRIX 6.5.20 m
SGI IRIX 6.5.20 f
SGI IRIX 6.5.20
SGI IRIX 6.5.19 m
SGI IRIX 6.5.19 f
SGI IRIX 6.5.19
SGI IRIX 6.5.18 m
SGI IRIX 6.5.18 f
SGI IRIX 6.5.18
SGI IRIX 6.5.17 m
SGI IRIX 6.5.17 f
SGI IRIX 6.5.16
SGI IRIX 6.5.15
SGI IRIX 6.5.14
SGI IRIX 6.5.13
SGI IRIX 6.5.12
SGI IRIX 6.5.11
SGI IRIX 6.5.10
SGI IRIX 6.5.9
SGI IRIX 6.5.8
SGI IRIX 6.5.7
SGI IRIX 6.5.6
SGI IRIX 6.5.5
SGI IRIX 6.5.4
SGI IRIX 6.5.3
SGI IRIX 6.5.2
SGI IRIX 6.5.1

- 漏洞讨论

SGI has announced the existence of an unspecified denial of service vulnerability in rpc.mountd. The precise technical details are unknown, however it is believed that this condition could potentially be exploited to deny access to NFS services.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

SGI has released an updated security advisory (20031102-02-P) including patches to address this issue. This advisory includes updated patches 5426-5429 to address a mismatch between exportfs and rpc.mountd that was introduced in the previous patches. Please see the revised advisory for further information.

SGI IRIX 6.5.18 m

SGI IRIX 6.5.18 f

SGI IRIX 6.5.19 m

SGI IRIX 6.5.19 f

SGI IRIX 6.5.20 m

SGI IRIX 6.5.20 f

SGI IRIX 6.5.21 m

SGI IRIX 6.5.21 f

SGI IRIX 6.5.22

- 相关参考