CVE-2003-0791
CVSS7.5
发布时间 :2003-10-07 00:00:00
修订时间 :2008-09-10 15:20:29
NMCO    

[原文]The Script.prototype.freeze/thaw functionality in Mozilla 1.4 and earlier allows attackers to execute native methods by modifying the string used as input to the script.thaw JavaScript function, which is then deserialized and executed.


[CNNVD]Mozilla Browser Script.prototype.freeze/thaw任意代码执行漏洞(CNNVD-200310-023)

        
        Mozilla是一款流行的WEB浏览器。
        Mozilla在处理JavaScript Script.prototype.freeze/thaw函数时存在问题,远程攻击者可以利用这个漏洞构建恶意WEB页面,诱使用户访问,可以当前用户上下文权限执行任意代码。
        Mozilla在处理JavaScript Script.prototype.freeze/thaw函数时,对其输入的字符串缺少正确检查和过滤,攻击者构建恶意页面,诱使Mozilla用户访问,可导致任意代码在客户端系统中执行。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:mozilla:0.9.2Mozilla Mozilla Browser 0.9.2
cpe:/a:mozilla:mozilla:1.0.2Mozilla Mozilla Browser 1.0.2
cpe:/o:sco:openserver:5.0.7
cpe:/a:mozilla:mozilla:1.0:rc1
cpe:/a:mozilla:mozilla:1.2:alphaMozilla Mozilla Browser 1.2 Alpha
cpe:/a:mozilla:mozilla:1.0Mozilla Mozilla 1.0
cpe:/a:mozilla:mozilla:1.1Mozilla Mozilla 1.1
cpe:/a:mozilla:mozilla:0.9.5Mozilla Mozilla Browser 0.9.5
cpe:/a:mozilla:mozilla:1.1:betaMozilla Mozilla Browser 1.1 Beta
cpe:/a:mozilla:mozilla:0.9.7Mozilla Mozilla 0.9.7
cpe:/a:mozilla:mozilla:0.9.3Mozilla Mozilla Browser 0.9.3
cpe:/a:mozilla:mozilla:0.9.2.1Mozilla Mozilla Browser 0.9.2.1
cpe:/a:mozilla:mozilla:1.4:alphaMozilla Mozilla 1.4a
cpe:/a:mozilla:mozilla:0.8Mozilla Mozilla Browser 0.8
cpe:/a:mozilla:mozilla:0.9.6Mozilla Mozilla Browser 0.9.6
cpe:/a:mozilla:mozilla:1.3Mozilla Mozilla 1.3
cpe:/a:mozilla:mozilla:1.1:alphaMozilla Mozilla Browser 1.1 Alpha
cpe:/a:mozilla:mozilla:1.2Mozilla Mozilla 1.2
cpe:/a:mozilla:mozilla:1.3.1Mozilla Mozilla Browser 1.3.1
cpe:/a:mozilla:mozilla:0.9.4Mozilla Mozilla Browser 0.9.4
cpe:/a:mozilla:mozilla:0.9.48Mozilla Mozilla Browser 0.9.48
cpe:/a:mozilla:mozilla:0.9.35Mozilla Mozilla Browser 0.9.35
cpe:/a:mozilla:mozilla:0.9.4.1Mozilla Mozilla Browser 0.9.4.1
cpe:/a:mozilla:mozilla:1.0:rc2
cpe:/a:mozilla:mozilla:1.4Mozilla Mozilla 1.4
cpe:/a:mozilla:mozilla:0.9.8Mozilla Mozilla Browser 0.9.8
cpe:/a:mozilla:mozilla:0.9.9Mozilla Mozilla 0.9.9
cpe:/a:mozilla:mozilla:1.2:betaMozilla Mozilla Browser 1.2 Beta
cpe:/a:mozilla:mozilla:1.2.1Mozilla Mozilla Browser 1.2.1
cpe:/a:mozilla:mozilla:1.4:betaMozilla Mozilla Browser 1.4b
cpe:/a:mozilla:mozilla:1.0.1Mozilla Mozilla Browser 1.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0791
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0791
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-023
(官方数据源) CNNVD

- 其它链接及资源

https://bugzilla.mozilla.org/show_bug.cgi?id=221526
(VENDOR_ADVISORY)  MISC  https://bugzilla.mozilla.org/show_bug.cgi?id=221526
http://www.securityfocus.com/bid/9322
(VENDOR_ADVISORY)  BID  9322
http://www.securityfocus.com/advisories/6979
(VENDOR_ADVISORY)  SCO  SCOSA-2004.8
http://www.osvdb.org/8390
(VENDOR_ADVISORY)  OSVDB  8390
http://secunia.com/advisories/11103/
(VENDOR_ADVISORY)  SECUNIA  11103
http://www.mandriva.com/security/advisories?name=MDKSA-2004:021
(UNKNOWN)  MANDRAKE  MDKSA-2004:021

- 漏洞信息

Mozilla Browser Script.prototype.freeze/thaw任意代码执行漏洞
高危 设计错误
2003-10-07 00:00:00 2005-10-20 00:00:00
远程  
        
        Mozilla是一款流行的WEB浏览器。
        Mozilla在处理JavaScript Script.prototype.freeze/thaw函数时存在问题,远程攻击者可以利用这个漏洞构建恶意WEB页面,诱使用户访问,可以当前用户上下文权限执行任意代码。
        Mozilla在处理JavaScript Script.prototype.freeze/thaw函数时,对其输入的字符串缺少正确检查和过滤,攻击者构建恶意页面,诱使Mozilla用户访问,可导致任意代码在客户端系统中执行。
        

- 公告与补丁

        厂商补丁:
        Mozilla
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.mozilla.org/

- 漏洞信息

8390
Mozilla Browser Script.prototype.freeze/thaw Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Mozilla Web Browser contains a flaw that may allow a malicious user to execute arbitrary code. The issue is caused by a flaw in JavaScript Script.freeze/thaw functionality, and could allow a very knowledgeable attacker to execute arbitrary code on the client system, resulting in a loss of integrity.

- 时间线

2003-10-07 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站