CVE-2003-0787
CVSS7.5
发布时间 :2003-11-17 00:00:00
修订时间 :2008-09-10 15:20:26
NMCO    

[原文]The PAM conversation function in OpenSSH 3.7.1 and 3.7.1p1 interprets an array of structures as an array of pointers, which allows attackers to modify the stack and possibly gain privileges.


[CNNVD]OpenSSH PAM多个安全漏洞(CNNVD-200311-055)

        
        OpenSSH是一种开放源码的SSH协议的实现,初始版本用于OpenBSD平台,现在已经被移植到多种Unix/Linux类操作系统下。
        OpenSSH 3.7p1和3.7.1p1存在多个相关PAM代码的漏洞,远程攻击者可以利用这些漏洞进行攻击,可能未授权访问系统。
        这些问题存在于非标准配置,不使用权限限制的情况下。目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openbsd:openssh:3.7.1p1OpenBSD OpenSSH 3.7.1 p1
cpe:/a:openbsd:openssh:3.7.1OpenBSD OpenSSH 3.7.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0787
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0787
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-055
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/209807
(UNKNOWN)  CERT-VN  VU#209807
http://www.openssh.com/txt/sshpam.adv
(UNKNOWN)  CONFIRM  http://www.openssh.com/txt/sshpam.adv
http://lists.grok.org.uk/pipermail/full-disclosure/2003-September/010812.html
(UNKNOWN)  FULLDISC  20030924 [OpenPKG-SA-2003.042] OpenPKG Security Advisory (openssh)
http://www.securityfocus.com/bid/8677
(UNKNOWN)  BID  8677
http://www.securityfocus.com/archive/1/338617
(UNKNOWN)  BUGTRAQ  20030923 Multiple PAM vulnerabilities in portable OpenSSH
http://www.securityfocus.com/archive/1/338616
(UNKNOWN)  BUGTRAQ  20030923 Portable OpenSSH 3.7.1p2 released

- 漏洞信息

OpenSSH PAM多个安全漏洞
高危 未知
2003-11-17 00:00:00 2006-03-28 00:00:00
远程  
        
        OpenSSH是一种开放源码的SSH协议的实现,初始版本用于OpenBSD平台,现在已经被移植到多种Unix/Linux类操作系统下。
        OpenSSH 3.7p1和3.7.1p1存在多个相关PAM代码的漏洞,远程攻击者可以利用这些漏洞进行攻击,可能未授权访问系统。
        这些问题存在于非标准配置,不使用权限限制的情况下。目前没有详细漏洞细节提供。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 可以通过在sshd_config中设置"UsePam no"选项关闭PAM支持。
        厂商补丁:
        OpenSSH
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载升级程序到OpenSSH 3.7.1p2版本:
        
        http://www.openssh.com/portable.html

- 漏洞信息

6072
OpenSSH PAM Conversation Function Stack Modification
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

OpenSSH contains a flaw that may allow a malicious user to execute arbitrary code on the stack, possibly including escalating their privileges. The issue is triggered due to the mis-parsing of an array of structures in the PAM code in portable OpenSSH. It is possible that the flaw may allow stack modification or privilege escalation.

- 时间线

2003-09-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.7.1p2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by applying the vendor-supplied patch or by disabling support for PAM in the sshd_config file.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站