CVE-2003-0736
CVSS6.8
发布时间 :2003-10-20 00:00:00
修订时间 :2016-10-17 22:37:01
NMCOE    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in phpWebSite 0.9.x and earlier allow remote attackers to execute arbitrary web script via (1) the day parameter in the calendar module, (2) the fatcat_id parameter in the fatcat module, (3) the PAGE_id parameter in the pagemaster module, (4) the PDA_limit parameter in the search, and (5) possibly other parameters in the calendar, fatcat, and pagemaster modules.


[CNNVD]phpWebSite多个跨站脚本漏洞(CNNVD-200310-040)

        phpWebSite 0.9.x及其早期版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)calendar模块的day参数,(2)fatcat模块的fatcat_id参数,(3)pagemaster 模块的PAGE_id参数,(4)search的PDA_limit参数,和(5)可能其他calendar,fatcat,和pagemaster模块中的参数执行任意web脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0736
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0736
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-040
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106062021711496&w=2
(UNKNOWN)  BUGTRAQ  20030810 phpWebSite SQL Injection & DoS & XSS Vulnerabilities
http://marc.info/?l=bugtraq&m=106252188522715&w=2
(UNKNOWN)  BUGTRAQ  20030902 GLSA: phpwebsite (200309-03)
http://www.kb.cert.org/vuls/id/664422
(UNKNOWN)  CERT-VN  VU#664422

- 漏洞信息

phpWebSite多个跨站脚本漏洞
中危 跨站脚本
2003-10-20 00:00:00 2005-10-20 00:00:00
远程  
        phpWebSite 0.9.x及其早期版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)calendar模块的day参数,(2)fatcat模块的fatcat_id参数,(3)pagemaster 模块的PAGE_id参数,(4)search的PDA_limit参数,和(5)可能其他calendar,fatcat,和pagemaster模块中的参数执行任意web脚本。

- 公告与补丁

        

- 漏洞信息 (23014)

phpWebSite 0.7.3/0.8.2/0.8.3/0.9.2 calendar Module day Parameter XSS (EDBID:23014)
php webapps
2003-08-11 Verified
0 Lorenzo Hernandez Garcia-Hierro
N/A [点击下载]
source: http://www.securityfocus.com/bid/8393/info

PHP Website is a web site content management system that allows for easy maintainance and administration of interactive community-driven websites.

Cross-site vulnerabilities have been reported in the Calendar, PageMaster, Search and Fatcat modules that allow an attacker to create a link containing malicious script code that may be rendered in a user's browser when the link is followed.

This would occur in the security context of the site running PHP Website.

http://www.example.com/[PATH]/index.php?module=calendar&calendar[view]
=day&month=2&year=2003&day=1+%00">[XSS ATTACK CODE]		

- 漏洞信息 (23015)

phpWebSite 0.7.3/0.8.2/0.8.3/0.9.2 fatcat Module fatcat_id Parameter XSS (EDBID:23015)
php webapps
2003-08-11 Verified
0 Lorenzo Hernandez Garcia-Hierro
N/A [点击下载]
source: http://www.securityfocus.com/bid/8393/info
 
PHP Website is a web site content management system that allows for easy maintainance and administration of interactive community-driven websites.
 
Cross-site vulnerabilities have been reported in the Calendar, PageMaster, Search and Fatcat modules that allow an attacker to create a link containing malicious script code that may be rendered in a user's browser when the link is followed.
 
This would occur in the security context of the site running PHP Website.

http://www.example.com/[PATH]/index.php?module=fatcat&fatcat[user]
=viewCategory&fatcat_id=1%00+">[XSS ATTACK CODE]		

- 漏洞信息 (23016)

phpWebSite 0.7.3/0.8.2/0.8.3/0.9.2 pagemaster Module PAGE_id Parameter XSS (EDBID:23016)
php webapps
2003-08-11 Verified
0 Lorenzo Hernandez Garcia-Hierro
N/A [点击下载]
source: http://www.securityfocus.com/bid/8393/info
 
PHP Website is a web site content management system that allows for easy maintainance and administration of interactive community-driven websites.
 
Cross-site vulnerabilities have been reported in the Calendar, PageMaster, Search and Fatcat modules that allow an attacker to create a link containing malicious script code that may be rendered in a user's browser when the link is followed.
 
This would occur in the security context of the site running PHP Website.

http://www.example.com/[PATH]/index.php?
module=pagemaster&PAGE_user_op=view_page&PAGE_id=10">[XSS ATTACK CODE]
&MMN_position=[X:X]		

- 漏洞信息 (23017)

phpWebSite 0.7.3/0.8.2/0.8.3/0.9.2 earch Module PDA_limit Parameter XSS (EDBID:23017)
php webapps
2003-08-11 Verified
0 Lorenzo Hernandez Garcia-Hierro
N/A [点击下载]
source: http://www.securityfocus.com/bid/8393/info
  
PHP Website is a web site content management system that allows for easy maintainance and administration of interactive community-driven websites.
  
Cross-site vulnerabilities have been reported in the Calendar, PageMaster, Search and Fatcat modules that allow an attacker to create a link containing malicious script code that may be rendered in a user's browser when the link is followed.
  
This would occur in the security context of the site running PHP Website.


http://www.example.com/[PATH]/index.php?
module=search&SEA_search_op=continue&PDA_limit=10">[XSS ATTACK CODE]		

- 漏洞信息

3842
phpWebSite calendar Module day Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpWebSite contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "day" variable upon submission to the calendar module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-08-10 Unknow
2003-08-10 Unknow

- 解决方案

Upgrade to version 0.8.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站