CVE-2003-0703
CVSS7.2
发布时间 :2003-09-17 00:00:00
修订时间 :2008-09-05 16:35:01
NMCOS    

[原文]KisMAC before 0.05d trusts user-supplied variables to load arbitrary kernels or kernel modules, which allows local users to gain privileges via the $DRIVER_KEXT environment variable as used in (1) viha_driver.sh, (2) macjack_load.sh, or (3) airojack_load.sh, or (4) via "similar techniques" using exchangeKernel.sh.


[CNNVD]KisMAC多个本地权限提升漏洞(CNNVD-200309-007)

        
        KisMAC是一款流行的无线网络识别和分析工具。
        如果KisMAC使用了"SUID Shell Scripts are enabled"选项,可导致本地攻击者通过多种途径获得root用户权限。
        漏洞情况如下:
        1、可以更改用户控制文件的属主,由于可以更改$DRIVER_KEXT的值,就可以利用load_driver函数中的chown命令更改攻击者指定的文件/目录属主。攻击者可以建立一个属主为攻击者uid的setuid可执行问,然后通过chown()获得root用户权限,这个漏洞可以利用viha_driver.sh / macjack_load.sh / airojack_load.sh脚本进行攻击。
        2、装载任意内核模块。通过viha_driver.sh / macjack_load.sh / airojack_load.sh脚本,控制$DRIVER_KEXT中的值,可装载任意内核模块到内存中,导致提升权限。
        3、通过exchangeKernel.sh脚本可以使攻击者覆盖原来的内核安装恶意内核。
        4、setuid_enable.sh / setuid_disable.sh脚本存在类似第一个问题相关的漏洞,另外setuid_enable.sh脚本会在chown()文件为root后对用户控制文件增加setuid位。
        5、通过类似第一个漏洞相关技术,利用viha_prep.sh / viha_unprep.sh脚本,攻击者可以以root用户权限执行指定的文件。
        默认情况下"SUID Shell Scripts are enabled"选项不开启。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0703
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0703
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200309-007
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/13007
(VENDOR_ADVISORY)  XF  kismac-driverkext-load-modules(13007)
http://www.atstake.com/research/advisories/2003/a082203-1.txt
(VENDOR_ADVISORY)  ATSTAKE  A082203-1
http://xforce.iss.net/xforce/xfdb/13008
(UNKNOWN)  XF  kismac-exchangekernel-kernel-overwrite(13008)
http://www.securityfocus.com/bid/8497
(VENDOR_ADVISORY)  BID  8497

- 漏洞信息

KisMAC多个本地权限提升漏洞
高危 访问验证错误
2003-09-17 00:00:00 2005-10-20 00:00:00
本地  
        
        KisMAC是一款流行的无线网络识别和分析工具。
        如果KisMAC使用了"SUID Shell Scripts are enabled"选项,可导致本地攻击者通过多种途径获得root用户权限。
        漏洞情况如下:
        1、可以更改用户控制文件的属主,由于可以更改$DRIVER_KEXT的值,就可以利用load_driver函数中的chown命令更改攻击者指定的文件/目录属主。攻击者可以建立一个属主为攻击者uid的setuid可执行问,然后通过chown()获得root用户权限,这个漏洞可以利用viha_driver.sh / macjack_load.sh / airojack_load.sh脚本进行攻击。
        2、装载任意内核模块。通过viha_driver.sh / macjack_load.sh / airojack_load.sh脚本,控制$DRIVER_KEXT中的值,可装载任意内核模块到内存中,导致提升权限。
        3、通过exchangeKernel.sh脚本可以使攻击者覆盖原来的内核安装恶意内核。
        4、setuid_enable.sh / setuid_disable.sh脚本存在类似第一个问题相关的漏洞,另外setuid_enable.sh脚本会在chown()文件为root后对用户控制文件增加setuid位。
        5、通过类似第一个漏洞相关技术,利用viha_prep.sh / viha_unprep.sh脚本,攻击者可以以root用户权限执行指定的文件。
        默认情况下"SUID Shell Scripts are enabled"选项不开启。
        

- 公告与补丁

        厂商补丁:
        KisMAC
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载升级到0.05d4版本:
        
        http://www.binaervarianz.de/projekte/programmieren/kismac/download.php

- 漏洞信息

11848
KisMAC viha_driver.sh Arbitrary Kernel Module Loading
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

KisMAC contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when an attacker changes the value of the $DRIVER_KEXT variable in the 'viha_driver.sh' script allowing arbitrary kernel modules to be loaded into memory. This flaw may lead to a loss of integrity.

- 时间线

2003-08-22 Unknow
2003-08-25 Unknow

- 解决方案

Upgrade to version 0.05d4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

KisMAC Multiple Local Privilege Escalation Vulnerabilities
Access Validation Error 8497
No Yes
2003-08-26 12:00:00 2009-07-11 11:56:00
Discovery of this vulnerability has been credited to Dave G. <daveg@atstake.com>.

- 受影响的程序版本

KisMAC KisMAC 0.5 d
KisMAC KisMAC 0.2 a
KisMAC KisMAC 0.1 c
KisMAC KisMAC 0.1 b
KisMAC KisMAC 0.1 a
KisMAC KisMAC 0.5 d4

- 不受影响的程序版本

KisMAC KisMAC 0.5 d4

- 漏洞讨论

KisMAC has been reported prone to multiple local privilege escalation vulnerabilities.

The vulnerabilities present themselves because the affected shell scripts may be influenced into using an attacker controlled directory rather than a system directory, if an attacker hardlinks to any of the affected shell scripts.

It has been reported that these vulnerabilities maybe exploited by a local user to: execute arbitrary binaries with elevated privileges, change ownership of privileged files, load arbitrary kernel modules, change ownership of attacker specified files and install an arbitrary kernel.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has released an update to address this vulnerability:


KisMAC KisMAC 0.5 d

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站