CVE-2003-0697
CVSS7.2
发布时间 :2003-10-06 00:00:00
修订时间 :2008-09-10 15:20:12
NMCO    

[原文]Format string vulnerability in lpd in the bos.rte.printers fileset for AIX 4.3 through 5.2, with debug enabled, allows local users to cause a denial of service (crash) or gain root privileges.


[CNNVD]IBM AIX GetIPNodeByName API套接口管理漏洞(CNNVD-200310-003)

        
        IBM AIX是一款商业性质UNIX操作系统。
        IBM AIX在处理套接口时存在问题,远程攻击者可以利用这个漏洞使有此漏洞系统上的应用程序崩溃。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:ibm:aix:5.1IBM AIX 5.1
cpe:/o:ibm:aix:4.3IBM AIX 4.3
cpe:/o:ibm:aix:5.2IBM AIX 5.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0697
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0697
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-003
(官方数据源) CNNVD

- 其它链接及资源

http://www-1.ibm.com/support/search.wss?rs=0&q=IY45344&apar=only
(VENDOR_ADVISORY)  AIXAPAR  IY45344
http://www-1.ibm.com/services/continuity/recover1.nsf/mss/MSS-OAR-E01-2003.1605.1
(UNKNOWN)  CONFIRM  http://www-1.ibm.com/services/continuity/recover1.nsf/mss/MSS-OAR-E01-2003.1605.1
http://www-1.ibm.com/support/search.wss?rs=0&q=IY46256&apar=only
(UNKNOWN)  AIXAPAR  IY46256
http://www-1.ibm.com/support/search.wss?rs=0&q=IY45250&apar=only
(UNKNOWN)  AIXAPAR  IY45250

- 漏洞信息

IBM AIX GetIPNodeByName API套接口管理漏洞
高危 未知
2003-10-06 00:00:00 2005-10-20 00:00:00
本地  
        
        IBM AIX是一款商业性质UNIX操作系统。
        IBM AIX在处理套接口时存在问题,远程攻击者可以利用这个漏洞使有此漏洞系统上的应用程序崩溃。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        IBM
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www-1.ibm.com/servers/aix/

- 漏洞信息

2167
IBM AIX lpd Local Privilege Escalation
Local Access Required Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

A local overflow exists in IBM AIX. The lpd program when running with debug enabled fails to validate input resulting in a possible format string exploit. With a specially crafted request, an attacker can cause execution of code resulting in a loss of confidentiality and/or integrity.

- 时间线

2003-09-19 Unknow
Unknow Unknow

- 解决方案

Upgrade AIX using the APAR numbers AIX 4.3: IY45250, AIX 5.1: IY46256 and AIX 5.2: IY45344 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站