CVE-2003-0685
CVSS7.5
发布时间 :2003-08-27 00:00:00
修订时间 :2016-10-17 22:36:32
NMCOS    

[原文]Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.


[CNNVD]Netris客户端缓冲区溢出漏洞(CNNVD-200308-144)

        Netris 0.52及其早期版本和可能其他版本存在缓冲区溢出漏洞。远程恶意Netris服务器可以借助超长服务器响应执行netris客户端的任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:netris:netris:0.5
cpe:/a:netris:netris:0.4
cpe:/a:netris:netris:0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0685
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0685
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-144
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106071059430211&w=2
(UNKNOWN)  BUGTRAQ  20030812 Netris client Buffer Overflow Vulnerability.
http://www.debian.org/security/2003/dsa-372
(VENDOR_ADVISORY)  DEBIAN  DSA-372

- 漏洞信息

Netris客户端缓冲区溢出漏洞
高危 缓冲区溢出
2003-08-27 00:00:00 2005-10-20 00:00:00
远程  
        Netris 0.52及其早期版本和可能其他版本存在缓冲区溢出漏洞。远程恶意Netris服务器可以借助超长服务器响应执行netris客户端的任意代码。

- 公告与补丁

        Debian has released an advisory (DSA 372-1) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.
        This vulnerability has been addressed in Netris 0.52.
        Netris Netris 0.3
        
        Netris Netris 0.4
        
        Netris Netris 0.5
        

- 漏洞信息

6685
Netris Client Server Response Buffer Overflow
Remote / Network Access Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown

- 漏洞描述

A remote overflow exists in the Netris client. The product fails to check buffer boundaries when connecting to a Netris server resulting in a buffer overflow. With a specially crafted response, a malicious server can cause a buffer overflow resulting in a loss of integrity and/or availability.

- 时间线

2003-08-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.52 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Netris Client-Side Buffer Overrun Vulnerability
Boundary Condition Error 8400
Yes No
2003-08-12 12:00:00 2009-07-11 10:56:00
The discovery of this vulnerability has been credited to Shaun Moore <shaunige@yahoo.co.uk>.

- 受影响的程序版本

Netris Netris 0.5
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha
- Debian Linux 3.0
Netris Netris 0.4
Netris Netris 0.3
Netris Netris 0.52

- 不受影响的程序版本

Netris Netris 0.52

- 漏洞讨论

A client-side buffer overrun vulnerability has been reported for Netris. The issue is said to occur due to insufficient bounds checking when copying a server greeting into an internal memory buffer. Successful exploitation of this issue could potentially allow for the execution of arbitrary code with the privileges of the user invoking Netris.

- 漏洞利用

The following proof of concept code has been provided, which demonstrates the exploitation of this issue to trigger a denial of service.

A second exploit has been released which exploits this issue to execute arbitrary code.

- 解决方案

Debian has released an advisory (DSA 372-1) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.

This vulnerability has been addressed in Netris 0.52.


Netris Netris 0.3

Netris Netris 0.4

Netris Netris 0.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站