CVE-2003-0679
CVSS2.1
发布时间 :2003-08-27 00:00:00
修订时间 :2008-09-10 15:20:06
NMCOS    

[原文]Unknown vulnerability in the libcpr library for the Checkpoint/Restart (cpr) system on SGI IRIX 6.5.21f and earlier allows local users to truncate or overwrite certain files.


[CNNVD]SGI IRIX Checkpoint/Restart libcpr文件破坏漏洞(CNNVD-200308-111)

        
        IRIX是一款由SGI公司开发和维护的商业性质UNIX操作系统。
        IRIX中包含的Checkpoint/Restart libcpr库存在问题,本地攻击者可以利用这个漏洞破坏本地文件。
        checkpoint/restart (cpr)系统包含一个安全漏洞可导致普通用户截断或覆盖部分系统文件。攻击者需要本地帐户来利用这个漏洞。
        漏洞存在于libcpr库的32位和64位版本,因此调用此库的应用程序都存在此漏洞。
        

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0679
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0679
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-111
(官方数据源) CNNVD

- 其它链接及资源

ftp://patches.sgi.com/support/free/security/advisories/20030802-01-P
(UNKNOWN)  SGI  20030802-01-P

- 漏洞信息

SGI IRIX Checkpoint/Restart libcpr文件破坏漏洞
低危 未知
2003-08-27 00:00:00 2005-10-20 00:00:00
本地  
        
        IRIX是一款由SGI公司开发和维护的商业性质UNIX操作系统。
        IRIX中包含的Checkpoint/Restart libcpr库存在问题,本地攻击者可以利用这个漏洞破坏本地文件。
        checkpoint/restart (cpr)系统包含一个安全漏洞可导致普通用户截断或覆盖部分系统文件。攻击者需要本地帐户来利用这个漏洞。
        漏洞存在于libcpr库的32位和64位版本,因此调用此库的应用程序都存在此漏洞。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用如下方法删除checkpoint / restart安装:
        versions remove eoe.sw64.lib
        versions remove eoe.sw.cpr
        厂商补丁:
        SGI
        ---
        SGI已经为此发布了一个安全公告(20030802-01-P)以及相应补丁:
        20030802-01-P:Checkpoint/Restart Vulnerability on IRIX
        链接:ftp://patches.sgi.com/support/free/security/advisories/20030802-01-P
        补丁下载:
        SGI建议用户升级到IRIX 6.5.22版本或安装适当补丁。
        补丁情况如下:
         系统版本 是否受影响 补丁号 备注
         ---------- ----------- ------- -------------
         IRIX 3.x 未知 备注 1
         IRIX 4.x 未知 备注 1
         IRIX 5.x 未知 备注 1
         IRIX 6.0.x 未知 备注 1
         IRIX 6.1 未知 备注 1
         IRIX 6.2 未知 备注 1
         IRIX 6.3 未知 备注 1
         IRIX 6.4 未知 备注 1
         IRIX 6.5 是 备注 2 & 3
         IRIX 6.5.1 是 备注 2 & 3
         IRIX 6.5.2 是 备注 2 & 3
         IRIX 6.5.3 是 备注 2 & 3
         IRIX 6.5.4 是 备注 2 & 3
         IRIX 6.5.5 是 备注 2 & 3
         IRIX 6.5.6 是 备注 2 & 3
         IRIX 6.5.7 是 备注 2 & 3
         IRIX 6.5.8 是 备注 2 & 3
         IRIX 6.5.9 是 备注 2 & 3
         IRIX 6.5.10 是 备注 2 & 3
         IRIX 6.5.11 是 备注 2 & 3
         IRIX 6.5.12 是 备注 2 & 3
         IRIX 6.5.13 是 备注 2 & 3
         IRIX 6.5.14 是 备注 2 & 3
         IRIX 6.5.15 是 备注 2 & 3
         IRIX 6.5.16 是 备注 2 & 3
         IRIX 6.5.17m 是 5264 备注 2 & 4
         IRIX 6.5.17f 是 5265 备注 2 & 4
         IRIX 6.5.18m 是 5266 备注 2 & 4
         IRIX 6.5.18f 是 5267 备注 2 & 4
         IRIX 6.5.19m 是 5266 备注 2 & 4
         IRIX 6.5.19f 是 5267 备注 2 & 4
         IRIX 6.5.20m 是 5268 备注 2 & 4
         IRIX 6.5.20f 是 5268 备注 2 & 4
         IRIX 6.5.21m 是

- 漏洞信息

2424
IRIX checkpoint/restart Arbitrary File Overwrite
Local Access Required Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability

- 漏洞描述

Irix contains a flaw that may allow a local attacker to truncate or overwrite arbitrary files. The issue is due to a flaw in the checkpoint/restart (cpr) library "libcpr". No further details have been provided.

- 时间线

2003-08-15 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, SGI has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SGI IRIX Checkpoint/Restart libcpr File Corruption Vulnerability
Unknown 8433
No Yes
2003-08-14 12:00:00 2009-07-11 10:56:00
This issue was announced by the vendor.

- 受影响的程序版本

SGI IRIX 6.5.21 m
SGI IRIX 6.5.21 f
SGI IRIX 6.5.20 m
SGI IRIX 6.5.20 f
SGI IRIX 6.5.19 m
SGI IRIX 6.5.19 f
SGI IRIX 6.5.18 m
SGI IRIX 6.5.18 f
SGI IRIX 6.5.17 m
SGI IRIX 6.5.17 f
SGI IRIX 6.5.16
SGI IRIX 6.5.15
SGI IRIX 6.5.14
SGI IRIX 6.5.13
SGI IRIX 6.5.12
SGI IRIX 6.5.11
SGI IRIX 6.5.10
SGI IRIX 6.5.9
SGI IRIX 6.5.8
SGI IRIX 6.5.7
SGI IRIX 6.5.6
SGI IRIX 6.5.5
SGI IRIX 6.5.4
SGI IRIX 6.5.3
SGI IRIX 6.5.2
SGI IRIX 6.5.1
SGI IRIX 6.5
SGI IRIX 6.5.22

- 不受影响的程序版本

SGI IRIX 6.5.22

- 漏洞讨论

SGI has reported a vulnerability in the Checkpoint/Restart libcpr library that could be exploited by a local attacker to corrupt files.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

SGI has addressed this issue in SGI IRIX 6.5.22. Patches 5264-5269 also address this issue in IRIX 6.5.17m and later. Please see the attached advisory for details on obtaining patches. IRIX systems prior to 6.5.17m should be upgraded to a more recent version.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站