CVE-2003-0658
CVSS5.0
发布时间 :2003-10-20 00:00:00
修订时间 :2008-09-10 15:20:03
NMCOS    

[原文]Docview before 1.1-18 in Caldera OpenLinux 3.1.1, SCO Linux 4.0, OpenServer 5.0.7, configures the Apache web server in a way that allows remote attackers to read arbitrary publicly readable files via a certain URL, possibly related to rewrite rules.


[CNNVD]DocView远程文件泄露漏洞(CNNVD-200310-039)

        
        Docview是一款提供OpenServer管理指南,可以HTML格式浏览的工具。
        Docview结合Apache使用时存在问题,匿名远程攻击者可以利用这个漏洞以WEB进程权限查看任意系统文件内容。
        由于Apache服务器的错误配置,任何匿名远程用户可以构造特殊的URL查看服务器上任意文件内容。目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sco:unixware:7.1.3
cpe:/a:caldera:openserver:5.0.7
cpe:/a:caldera:openlinux_workstation:3.1.1
cpe:/a:caldera:openlinux_server:3.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0658
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0658
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-039
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

DocView远程文件泄露漏洞
中危 输入验证
2003-10-20 00:00:00 2005-10-20 00:00:00
远程  
        
        Docview是一款提供OpenServer管理指南,可以HTML格式浏览的工具。
        Docview结合Apache使用时存在问题,匿名远程攻击者可以利用这个漏洞以WEB进程权限查看任意系统文件内容。
        由于Apache服务器的错误配置,任何匿名远程用户可以构造特殊的URL查看服务器上任意文件内容。目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        SCO
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        OpenServer 5.0.7
        ftp://ftp.caldera.com/pub/updates/OpenServer/CSSA-2003-SCO.16/
        OpenLinux 3.1.1 Server
        ftp://ftp.sco.com/pub/updates/OpenLinux/3.1.1/Server/CSSA-2003-023.0/RPMS
        UnixWare 7.1.3
        ftp://ftp.sco.com/pub/updates/UnixWare/CSSA-2003-SCO.18/

- 漏洞信息

7633
SCO Unix Docview Arbitrary File Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-08-23 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

DocView File Disclosure Vulnerability
Input Validation Error 8498
Yes No
2003-08-26 12:00:00 2009-07-11 11:56:00
This vulnerability has been announced in a vendor security advisory.

- 受影响的程序版本

SCO Unixware 7.1.3
Caldera OpenServer 5.0.7
Caldera OpenLinux Workstation 3.1.1
Caldera OpenLinux Server 3.1.1

- 漏洞讨论

docview has been reported prone to a remotely exploitable file disclosure vulnerability. It has been reported that remote attackers may exploit this condition, by invoking a malicious URL request against the affected docview utility, to disclose the contents of any publicly readable file.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

SCO have released an advisory (CSSA-2003-SCO.16) to address this issue for OpenServer systems. Please see the referenced advisory for further detail regarding applying relevant fixes.

SCO have released an advisory (CSSA-2003-SCO.18) to address this issue for UnixWare systems. Please see the referenced advisory for further detail regarding applying relevant fixes.

SCO have released an advisory (CSSA-2003-021.0) to address this issue for OpenLinux systems. Please see the referenced advisory for further detail regarding applying relevant fixes.


Caldera OpenLinux Server 3.1.1

Caldera OpenLinux Workstation 3.1.1

Caldera OpenServer 5.0.7

SCO Unixware 7.1.3

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站