CVE-2003-0654
CVSS7.5
发布时间 :2003-08-27 00:00:00
修订时间 :2008-09-10 15:20:03
NMCOS    

[原文]Buffer overflow in autorespond may allow remote attackers to execute arbitrary code as the autorespond user via qmail.


[CNNVD]Autorespond远程缓冲区溢出漏洞(CNNVD-200308-124)

        
        autorespond是一款结合QMAIL系统的自动应答程序。
        autorespond存在缓冲区溢出问题漏洞,远程攻击者可以对配置Qmail转发消息到autorespond的系统进行攻击,可能以进程权限在系统上执行任意指令。
        由于autorespond对有问题的输入长度有一定的限制,因此目前应该还可以可利用程序出现。具体漏洞细节没有提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0654
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0654
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-124
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-373
(UNKNOWN)  DEBIAN  DSA-373

- 漏洞信息

Autorespond远程缓冲区溢出漏洞
高危 边界条件错误
2003-08-27 00:00:00 2005-10-20 00:00:00
远程  
        
        autorespond是一款结合QMAIL系统的自动应答程序。
        autorespond存在缓冲区溢出问题漏洞,远程攻击者可以对配置Qmail转发消息到autorespond的系统进行攻击,可能以进程权限在系统上执行任意指令。
        由于autorespond对有问题的输入长度有一定的限制,因此目前应该还可以可利用程序出现。具体漏洞细节没有提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-373

- 漏洞信息

2440
qmailadmin autorespond Multiple Variable Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown Vendor Verified

- 漏洞描述

A remote overflow exists in the 'autorespond' utility included in the qmailadmin package. autorespond fails to perform boundary checks when copying environment variables set by the Mail Transfer Agent (MTA). With a specially crafted request, an attacker can cause a buffer overflow resulting in a loss of integrity and availability.

- 时间线

2003-08-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Autorespond Buffer Overrun Vulnerability
Boundary Condition Error 8436
Yes No
2003-08-16 12:00:00 2009-07-11 10:56:00
Discovery is credited to Christian Jaeger.

- 受影响的程序版本

autorespond autorespond 2.0.2
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha
- Debian Linux 3.0

- 漏洞讨论

autorespond is prone to a buffer overrun. This issue may potentially be exploited by remote attackers to execute arbitrary code in the context of the software, though this has not been confirmed.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released an advisory (DSA 373-1) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.


autorespond autorespond 2.0.2

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站