CVE-2003-0650
CVSS7.5
发布时间 :2003-08-27 00:00:00
修订时间 :2016-10-17 22:36:20
NMCOS    

[原文]Directory traversal vulnerability in GSAPAK.EXE for GameSpy Arcade, possibly versions before 1.3e, allows remote attackers to overwrite arbitrary files and execute arbitrary code via .. (dot dot) sequences in filenames in a .APK (Zip) file.


[CNNVD]Gamespy Arcade GSAPAK.EXE .APK提取文件破坏漏洞(CNNVD-200308-145)

        可能GameSpy Arcade 1.3e之前版本的GSAPAK.EXE存在目录遍历漏洞。远程攻击者可以借助.APK (Zip)文件文件名中的..(点 点)序列覆盖任意文件并执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0650
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0650
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-145
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2003-q3/0064.html
(UNKNOWN)  VULNWATCH  20030730 GameSpy Arcade Arbitrary File Writing Vulnerability
http://marc.info/?l=bugtraq&m=105958779017085&w=2
(UNKNOWN)  BUGTRAQ  20030730 GameSpy Arcade Arbitrary File Writing Vulnerability
http://www.gamespyarcade.com/features/versions.shtml
(UNKNOWN)  MISC  http://www.gamespyarcade.com/features/versions.shtml
http://www.securityfocus.com/bid/8309
(VENDOR_ADVISORY)  BID  8309

- 漏洞信息

Gamespy Arcade GSAPAK.EXE .APK提取文件破坏漏洞
高危 路径遍历
2003-08-27 00:00:00 2005-10-20 00:00:00
远程  
        可能GameSpy Arcade 1.3e之前版本的GSAPAK.EXE存在目录遍历漏洞。远程攻击者可以借助.APK (Zip)文件文件名中的..(点 点)序列覆盖任意文件并执行任意代码。

- 公告与补丁

        It has been reported that a patch to address this issue is currently being developed and is scheduled for release in the near future. However, this information has not been confirmed by Symantec.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

2355
GameSpy Arcade GSAPAK.EXE .APK Traversal Arbitrary File Write
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

GameSpy Arcade has a flaw that may allow a remote attacker to execute arbitrary code. The issue is due to the GSAPAK.EXE program not screening file paths stored in ZIP files. If an attacker created a custom .zip file containing a hostile application with a .APK, .arcade or .asn file extension with crafted extraction paths, a remote user could inadvertantly write these files anywhere on the system.

- 时间线

2003-07-30 2003-07-26
2003-07-30 Unknow

- 解决方案

Upgrade to version 1.3e or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gamespy Arcade GSAPAK.EXE .APK Extraction File Corruption Vulnerability
Design Error 8309
Yes No
2003-07-26 12:00:00 2009-07-11 10:56:00
The discovery of this vulnerability has been credited to Mike Kristovich <zzz@threezee.com>.

- 受影响的程序版本

GameSpy Arcade

- 漏洞讨论

A vulnerability has been discovered in Gamespy Arcade. The occurs within the GSAPAK.EXE component which is designed to handle files using the .APK extension. These files are simply a compressed ZIP archive, however GSAPAK.EXE fails to sufficiently verify the integrity of files included within the archive. As a result, an attacker may be capable of including a file, containing directory traversal sequences (../) within it's name, which when extracted would overwrite an arbitrary system file. This file corruption would occur within the privilege context of the user recieving the .APK file.

- 漏洞利用

This vulnerability can be exploited by placing a malicious executable, containing a file name including directory traversal sequences (../), within a ZIP archive. The archive must then be modified to contain a .APK file extension.

- 解决方案

It has been reported that a patch to address this issue is currently being developed and is scheduled for release in the near future. However, this information has not been confirmed by Symantec.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站