CVE-2003-0645
CVSS4.6
发布时间 :2003-08-27 00:00:00
修订时间 :2016-10-17 22:36:19
NMCOS    

[原文]man-db 2.3.12 and 2.3.18 to 2.4.1 uses certain user-controlled DEFINE directives from the ~/.manpath file, even when running setuid, which could allow local users to gain privileges.


[CNNVD]Man-db DEFINE任意命令执行漏洞(CNNVD-200308-191)

        
        man是多种系统下查看帮助手册的工具。man-db在Debian系统中提供标准man(1)命令。
        man-db不正确处理'~/.manpath'文件中的DEFINE指示,本地攻击者可以利用这个漏洞以man用户权限在系统上执行任意命令。
        在'~/.manpath'文件中,部分DEFINE指示包含要执行的命令,因此攻击者可以修改此命令指示,以man用户权限在系统上执行任意命令。默认情况下不以'man'属性安装,但是安装man-db时会提示是否要以'man'属性安装。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:andries_brouwer:man:2.4.1
cpe:/a:andries_brouwer:man:2.3.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0645
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0645
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-191
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106018504800341&w=2
(UNKNOWN)  BUGTRAQ  20030806 man-db[v2.4.1-]: open_cat_stream() privileged call exploit.
http://www.debian.org/security/2003/dsa-364
(VENDOR_ADVISORY)  DEBIAN  DSA-364
http://www.securityfocus.com/bid/8352
(UNKNOWN)  BID  8352
http://xforce.iss.net/xforce/xfdb/12848
(UNKNOWN)  XF  mandb-opencatstream-gain-privileges(12848)

- 漏洞信息

Man-db DEFINE任意命令执行漏洞
中危 设计错误
2003-08-27 00:00:00 2006-09-21 00:00:00
本地  
        
        man是多种系统下查看帮助手册的工具。man-db在Debian系统中提供标准man(1)命令。
        man-db不正确处理'~/.manpath'文件中的DEFINE指示,本地攻击者可以利用这个漏洞以man用户权限在系统上执行任意命令。
        在'~/.manpath'文件中,部分DEFINE指示包含要执行的命令,因此攻击者可以修改此命令指示,以man用户权限在系统上执行任意命令。默认情况下不以'man'属性安装,但是安装man-db时会提示是否要以'man'属性安装。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-364

- 漏洞信息

11796
man-db .manpath File DEFINE Directive Local Privilege Escalation
Local Access Required
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-08-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.3.20-18.woody.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Man-db DEFINE Arbitrary Command Execution Vulnerability
Design Error 8341
No Yes
2003-08-04 12:00:00 2009-07-11 10:56:00
Announced in a Debian advisory.

- 受影响的程序版本

man man 2.4.1
man man 2.3.20

- 漏洞讨论

man-db can allow a local user to execute commands with elevated privileges through the DEFINE directive. This would only occur if man-db were installed to run as setuid "man" which is not the default.

- 漏洞利用

There is no exploit code required.

- 解决方案

Debian has released advisory DSA 364-1 with fixes for this issue. See the
referenced advisory for links to fixed packages.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站