CVE-2003-0630
CVSS7.2
发布时间 :2003-10-20 00:00:00
修订时间 :2016-10-17 22:36:06
NMCOPS    

[原文]Multiple buffer overflows in the atari800.svgalib setuid program of the Atari 800 emulator (atari800) before 1.2.2 allow local users to gain privileges via long command line arguments, as demonstrated with the -osa_rom argument.


[CNNVD]Atari800模拟器本地多个缓冲区溢出漏洞(CNNVD-200310-045)

        
        atari800是一款Atari模拟器。atari800为了要直接访问图形硬件,需要以setuid root属性安装。
        atari800存在多个缓冲区溢出问题,本地攻击者可以利用这个漏洞以root用户权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:atari800:atari800:1.0.5
cpe:/o:atari800:atari800:1.0.6
cpe:/o:atari800:atari800:1.0.1
cpe:/o:atari800:atari800:1.0.2
cpe:/o:atari800:atari800:1.2
cpe:/o:atari800:atari800:1.2.1_pre0
cpe:/o:atari800:atari800:1.0.7
cpe:/o:atari800:atari800:1.0.3
cpe:/o:atari800:atari800:1.2.1
cpe:/o:atari800:atari800:1.0.4
cpe:/o:atari800:atari800:1.2.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0630
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0630
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-045
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106252128221901&w=2
(UNKNOWN)  BUGTRAQ  20030902 GLSA: atari800 (200309-07)
http://www.debian.org/security/2003/dsa-359
(VENDOR_ADVISORY)  DEBIAN  DSA-359

- 漏洞信息

Atari800模拟器本地多个缓冲区溢出漏洞
高危 边界条件错误
2003-10-20 00:00:00 2005-10-20 00:00:00
本地  
        
        atari800是一款Atari模拟器。atari800为了要直接访问图形硬件,需要以setuid root属性安装。
        atari800存在多个缓冲区溢出问题,本地攻击者可以利用这个漏洞以root用户权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-359

- 漏洞信息 (F33673)

p_atari800.c (PacketStormID:F33673)
2004-06-29 00:00:00
 
exploit,local,root
CVE-2003-0630
[点击下载]

Exploit for the atari800 atari emulator. This exploit is local, and may in some circumstances give local root.

- 漏洞信息

2354
Atari800 Multiple Unspecified Local Overflows
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-08-01 Unknow
2004-07-21 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Multiple Atari800 Emulator Local Buffer Overflow Vulnerabilities
Boundary Condition Error 8322
No Yes
2003-07-31 12:00:00 2009-07-11 10:56:00
Discovery of this vulnerability has been credited to Steve Kemp.

- 受影响的程序版本

Atari800 Development atari800 1.2.2
Atari800 Development atari800 1.2.1 pre0
Atari800 Development atari800 1.2.1
Atari800 Development atari800 1.2
Atari800 Development atari800 1.0.7
Atari800 Development atari800 1.0.6
Atari800 Development atari800 1.0.5
Atari800 Development atari800 1.0.4
Atari800 Development atari800 1.0.3
Atari800 Development atari800 1.0.2
Atari800 Development atari800 1.0.1

- 漏洞讨论

atari800 emulator has been reported prone to multiple local buffer overflow vulnerabilities.

The issues are likely due to insufficient bounds checking performed on user-supplied data before it is copied into reserved buffers in memory. A local attacker may corrupt arbitrary memory. It has been reported that an attacker may exploit this condition to gain local root access.

- 漏洞利用

Exploit code has been provided by pi3.

- 解决方案

Debian has released an advisory (DSA 359-1) that addresses these issues. Details on obtaining and applying fixes can be found in the referenced advisory.

Gentoo has released updates to address these issues. The updates may be applied with the following commands:

emerge sync
emerge atari800
emerge clean


Atari800 Development atari800 1.2.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站