CVE-2003-0617
CVSS4.6
发布时间 :2003-08-27 00:00:00
修订时间 :2016-10-17 22:35:53
NMCOS    

[原文]mindi 0.58 and earlier does not properly create temporary files, which allows local users to overwrite arbitrary files.


[CNNVD]mindi以不安全方式创建临时文件漏洞(CNNVD-200308-146)

        
        mindi一款用于建立boot/root磁盘的工具。
        mindi在建立临时文件时没有正确的进行安全检查,本地攻击者可以利用这个漏洞通过符号链接以运行mindi用户的权限破坏系统任意文件。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0617
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0617
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-146
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106252097421549&w=2
(UNKNOWN)  BUGTRAQ  20030902 GLSA: mindi (200309-05)
http://www.debian.org/security/2003/dsa-362
(VENDOR_ADVISORY)  DEBIAN  DSA-362

- 漏洞信息

mindi以不安全方式创建临时文件漏洞
中危 访问验证错误
2003-08-27 00:00:00 2005-10-20 00:00:00
本地  
        
        mindi一款用于建立boot/root磁盘的工具。
        mindi在建立临时文件时没有正确的进行安全检查,本地攻击者可以利用这个漏洞通过符号链接以运行mindi用户的权限破坏系统任意文件。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-362

- 漏洞信息

2356
mindi Symlink Arbitrary File Overwrite
Local Access Required Race Condition

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-08-02 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

mindi Temporary File Creation Vulnerabilities
Access Validation Error 8332
No Yes
2003-08-02 12:00:00 2009-07-11 10:56:00
Announced by Debian.

- 受影响的程序版本

Hugo Rabson Mindi 0.58 r5
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

Debian has reported that Mindi is affected by several temporary file creation vulnerabilities that could allow for corruption of local files and, possibly, elevation of privileges. Throughout it's operation, mindi creates numerous files in /tmp with predictable filenames. Because /tmp is world-writeable, symbolic link attacks are possible.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has issued fixes. See advisory DSA-362-1 in the references section.

Gentoo Linux has released a security advisory (200309-05) to address this issue. Users who are affected by this issue are advised to do the following:

emerge sync
emerge mindi
emerge clean


Hugo Rabson Mindi 0.58 r5

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站