CVE-2003-0614
CVSS4.3
发布时间 :2003-08-27 00:00:00
修订时间 :2016-10-17 22:35:50
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in search.php of Gallery 1.1 through 1.3.4 allows remote attackers to insert arbitrary web script via the searchstring parameter.


[CNNVD]Gallery搜索引擎跨站脚本漏洞(CNNVD-200308-116)

        Gallery 1.1版本到1.3.4版本的search.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助searchstring参数插入任意web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:gallery_project:gallery:1.2.3
cpe:/a:gallery_project:gallery:1.3.2
cpe:/a:gallery_project:gallery:1.2.4
cpe:/a:gallery_project:gallery:1.3.3
cpe:/a:gallery_project:gallery:1.3
cpe:/a:gallery_project:gallery:1.2.1
cpe:/a:gallery_project:gallery:1.2.2
cpe:/a:gallery_project:gallery:1.3.1
cpe:/a:gallery_project:gallery:1.1
cpe:/a:gallery_project:gallery:1.2.5
cpe:/a:gallery_project:gallery:1.3.4
cpe:/a:gallery_project:gallery:1.2
cpe:/a:gallery_project:gallery:1.2.1_p1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0614
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0614
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-116
(官方数据源) CNNVD

- 其它链接及资源

http://gallery.menalto.com/modules.php?op=modload&name=News&file=article&sid=82&mode=thread&order=0&thold=0
(UNKNOWN)  CONFIRM  http://gallery.menalto.com/modules.php?op=modload&name=News&file=article&sid=82&mode=thread&order=0&thold=0
http://marc.info/?l=bugtraq&m=106252092421469&w=2
(UNKNOWN)  BUGTRAQ  20030902 GLSA: gallery (200309-06)
http://www.debian.org/security/2003/dsa-355
(VENDOR_ADVISORY)  DEBIAN  DSA-355
http://www.securityfocus.com/archive/1/330676
(UNKNOWN)  BUGTRAQ  20030727 Gallery XSS security advisory (with fix and patch instructions)
http://www.securityfocus.com/archive/1/archive/1/348641/30/21790/threaded
(UNKNOWN)  BUGTRAQ  20040101 Re: Gallery v1.3.3 Cross Site Scripting Vulnerabillity

- 漏洞信息

Gallery搜索引擎跨站脚本漏洞
中危 跨站脚本
2003-08-27 00:00:00 2009-01-29 00:00:00
远程  
        Gallery 1.1版本到1.3.4版本的search.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助searchstring参数插入任意web脚本。

- 公告与补丁

        This issue has been addressed in Gallery 1.3.4p1.
        Debian has released an advisory and fixes for this issue.
        Gentoo Linux has released a security advisory (200309-06) to address this issue. Users who are affected by this issue are advised to do the following:
        emerge sync
        emerge gallery
        emerge clean
        Bharat Mediratta Gallery 1.1
        
        Bharat Mediratta Gallery 1.2
        
        Bharat Mediratta Gallery 1.2.1
        
        Bharat Mediratta Gallery 1.2.1 p1
        
        Bharat Mediratta Gallery 1.2.2
        
        Bharat Mediratta Gallery 1.2.3
        
        Bharat Mediratta Gallery 1.2.4
        
        Bharat Mediratta Gallery 1.2.5
        
        Bharat Mediratta Gallery 1.3
        
        Bharat Mediratta Gallery 1.3.1
        
        Bharat Mediratta Gallery 1.3.2
        
        Bharat Mediratta Gallery 1.3.3
        
        Bharat Mediratta Gallery 1.3.4
        

- 漏洞信息 (22961)

Gallery 1.2/1.3.x Search Engine Cross-Site Scripting Vulnerability (EDBID:22961)
php webapps
2003-07-27 Verified
0 Larry Nguyen
N/A [点击下载]
source: http://www.securityfocus.com/bid/8288/info

Gallery is prone to a cross-site scripting vulnerability. This issue is present in the search engine facility provided by the software. An attacker could exploit this issue by constructing a malicious link to the search engine that contains hostile HTML and script code. Attacker-supplied code could be rendered in the browser of a user who follows such a link.

http://www.example.com/<galleryfolder>/search.php?searchstring=<script>alert('XSS')</script>		

- 漏洞信息

2322
Gallery search.php searchstring Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

Gallery contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'searchstring' variable upon submission to the 'search.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-07-27 2003-07-27
2003-07-27 Unknow

- 解决方案

Upgrade to version 1.3.4-p1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gallery Search Engine Cross-Site Scripting Vulnerability
Input Validation Error 8288
Yes No
2003-07-27 12:00:00 2009-07-11 10:56:00
Discovery of this issue is credited to "Larry Nguyen" <larry@vnlinux.org>.

- 受影响的程序版本

Intego DiskGuard 1.2.5
Intego DiskGuard 1.2.1
Intego DiskGuard 1.2
Intego DiskGuard 1.1
Bharat Mediratta Gallery 1.3.4
Bharat Mediratta Gallery 1.3.3
Bharat Mediratta Gallery 1.3.2
Bharat Mediratta Gallery 1.3.1
Bharat Mediratta Gallery 1.3
Bharat Mediratta Gallery 1.2.5
+ Debian Linux 3.0
- Francisco Burzi PHP-Nuke 5.0
- PostNuke Development Team PostNuke 0.7
Bharat Mediratta Gallery 1.2.4
- Francisco Burzi PHP-Nuke 5.0
- PostNuke Development Team PostNuke 0.7
Bharat Mediratta Gallery 1.2.3
- Francisco Burzi PHP-Nuke 5.0
Bharat Mediratta Gallery 1.2.2
- Francisco Burzi PHP-Nuke 5.0
Bharat Mediratta Gallery 1.2.1 p1
- Francisco Burzi PHP-Nuke 5.0
Bharat Mediratta Gallery 1.2.1
- Francisco Burzi PHP-Nuke 5.0
Bharat Mediratta Gallery 1.2
- Francisco Burzi PHP-Nuke 5.0
Bharat Mediratta Gallery 1.1
Bharat Mediratta Gallery 1.3.4 p1

- 不受影响的程序版本

Bharat Mediratta Gallery 1.3.4 p1

- 漏洞讨论

Gallery is prone to a cross-site scripting vulnerability. This issue is present in the search engine facility provided by the software. An attacker could exploit this issue by constructing a malicious link to the search engine that contains hostile HTML and script code. Attacker-supplied code could be rendered in the browser of a user who follows such a link.

- 漏洞利用

The following proof of concept has been supplied:

http://www.example.com/&lt;galleryfolder&gt;/search.php?searchstring=&lt;script&gt;alert('XSS')&lt;/script&gt;

- 解决方案

This issue has been addressed in Gallery 1.3.4p1.

Debian has released an advisory and fixes for this issue.

Gentoo Linux has released a security advisory (200309-06) to address this issue. Users who are affected by this issue are advised to do the following:

emerge sync
emerge gallery
emerge clean


Bharat Mediratta Gallery 1.1

Intego DiskGuard 1.1

Intego DiskGuard 1.2

Bharat Mediratta Gallery 1.2

Intego DiskGuard 1.2.1

Bharat Mediratta Gallery 1.2.1

Bharat Mediratta Gallery 1.2.1 p1

Bharat Mediratta Gallery 1.2.2

Bharat Mediratta Gallery 1.2.3

Bharat Mediratta Gallery 1.2.4

Bharat Mediratta Gallery 1.2.5

Intego DiskGuard 1.2.5

Bharat Mediratta Gallery 1.3

Bharat Mediratta Gallery 1.3.1

Bharat Mediratta Gallery 1.3.2

Bharat Mediratta Gallery 1.3.3

Bharat Mediratta Gallery 1.3.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站