CVE-2003-0602
CVSS6.8
发布时间 :2003-08-27 00:00:00
修订时间 :2008-09-05 16:34:45
NMCOS    

[原文]Multiple cross-site scripting vulnerabilities (XSS) in Bugzilla 2.16.x before 2.16.3 and 2.17.x before 2.17.4 allow remote attackers to insert arbitrary HTML or web script via (1) multiple default German and Russian HTML templates or (2) ALT and NAME attributes in AREA tags as used by the GraphViz graph generation feature for local dependency graphs.


[CNNVD]Bugzilla Local Dependency Graph HTML注入漏洞(CNNVD-200308-182)

        Bugzilla 2.17.4之前的2.16.x版本和2.17.4之前的2.17.x版本存在多个跨站脚本(XSS)漏洞。远程攻击者可以借助(1)多个默认德语和俄语HTML模板或(2)本地从属图GraphViz图形生成功能中AREA标签的ALT和NAME属性插入任意HTML或web脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:bugzilla:2.16.1Mozilla Bugzilla 2.16.1
cpe:/a:mozilla:bugzilla:2.17.3Mozilla Bugzilla 2.17.3
cpe:/a:mozilla:bugzilla:2.17Mozilla Bugzilla 2.17
cpe:/a:mozilla:bugzilla:2.16.2Mozilla Bugzilla 2.16.2
cpe:/a:mozilla:bugzilla:2.17.1Mozilla Bugzilla 2.17.1
cpe:/a:mozilla:bugzilla:2.16Mozilla Bugzilla 2.16

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0602
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0602
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-182
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6868
(VENDOR_ADVISORY)  BID  6868
http://www.securityfocus.com/bid/6861
(VENDOR_ADVISORY)  BID  6861
http://www.bugzilla.org/security/2.16.2/
(UNKNOWN)  CONFIRM  http://www.bugzilla.org/security/2.16.2/
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000653
(UNKNOWN)  CONECTIVA  CLA-2003:653

- 漏洞信息

Bugzilla Local Dependency Graph HTML注入漏洞
中危 跨站脚本
2003-08-27 00:00:00 2005-10-20 00:00:00
远程  
        Bugzilla 2.17.4之前的2.16.x版本和2.17.4之前的2.17.x版本存在多个跨站脚本(XSS)漏洞。远程攻击者可以借助(1)多个默认德语和俄语HTML模板或(2)本地从属图GraphViz图形生成功能中AREA标签的ALT和NAME属性插入任意HTML或web脚本。

- 公告与补丁

        The vendor has addressed this issue in Bugzilla 2.16.3 and 2.17.4. Patches may be obtained at the following location:
        http://ftp.mozilla.org/pub/webtools/
        Full release upgrades and CVS upgrade instructions will be made available here:
        http://www.bugzilla.org/download.html

- 漏洞信息

6349
Bugzilla Local Dependancy Graph XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Bugzilla contains a flaw that allows a remote cross site scripting attack. This flaw exists because the GraphViz graph generation feature for local dependency graphs does not validate ALT and NAME attributes within AREA tags. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-02-10 Unknow
2003-02-10 Unknow

- 解决方案

Upgrade to version 2.16.3 (stable release) or 2.17.4 (development release) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Bugzilla Default HTML Template Cross-Site Scripting Vulnerabilities
Input Validation Error 6868
Yes No
2003-04-24 12:00:00 2009-07-11 08:06:00
This issue was announced by the vendor.

- 受影响的程序版本

Mozilla Bugzilla 2.17.3
Mozilla Bugzilla 2.17.1
Mozilla Bugzilla 2.17
Mozilla Bugzilla 2.16.2
+ Conectiva Linux 9.0
+ Conectiva Linux 9.0
Mozilla Bugzilla 2.16.1
Mozilla Bugzilla 2.16
- Mandriva Linux Mandrake 9.0
- Mandriva Linux Mandrake 9.0
Mozilla Bugzilla 2.17.4
Mozilla Bugzilla 2.16.3

- 不受影响的程序版本

Mozilla Bugzilla 2.17.4
Mozilla Bugzilla 2.16.3

- 漏洞讨论

Multiple cross-site scripting vulnerabilities exist in the default HTML templates for Bugzilla. User-supplied input is not sanitized of HTML and script code before being output by Bugzilla. Hostile script code and HTML could be passed through Bugzilla and interpreted in the browser of a web user who visits a site hosting Bugzilla.

- 漏洞利用

There is no exploit required.

- 解决方案

Conectiva has released an advisory (CLA-2003:653) and fixes to address this issue. See attached advisory for details on obtaining and applying fixes.

The vendor has addressed this issue in Bugzilla 2.16.3 and 2.17.4. Patches may be obtained at the following location:

http://ftp.mozilla.org/pub/webtools/

Full release upgrades and CVS upgrade instructions will be made available here:

http://www.bugzilla.org/download.html

Users should contact individual localization maintainers for details on whether their particular localization is affected and details on obtaining fixes.


Mozilla Bugzilla 2.16.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站