CVE-2003-0592
CVSS7.5
发布时间 :2004-04-15 00:00:00
修订时间 :2008-09-10 15:19:45
NMCO    

[原文]Konqueror in KDE 3.1.3 and earlier (kdelibs) allows remote attackers to bypass intended cookie access restrictions on a web application via "%2e%2e" (encoded dot dot) directory traversal sequences in a URL, which causes Konqueror to send the cookie outside the specified URL subsets, e.g. to a vulnerable application that runs on the same server as the target application.


[CNNVD]多个供应商的互联网浏览器的cookie路径参数权限绕过漏洞(CNNVD-200404-063)

        KDE 3.1.3及其早期版本中的Konqueror存在漏洞。远程攻击者可以通过URL中"%2e%2e"(编码的点点)的目录遍历序列来绕开web应用上预期的cookie访问权限,该漏洞导致Konqueror发送指定的URL子集以外的cookie,例如:与目标应用程序运行在同一服务器上的易受攻击的应用程序。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:kde:konqueror:2.2.2
cpe:/a:kde:konqueror_embedded:0.1
cpe:/a:kde:konqueror:3.1.1
cpe:/a:kde:konqueror:3.0.5
cpe:/a:kde:konqueror:3.0.1
cpe:/a:kde:konqueror:2.1.1
cpe:/a:kde:konqueror:3.0.3
cpe:/a:kde:konqueror:3.0
cpe:/a:kde:konqueror:3.1.2
cpe:/a:kde:konqueror:3.1
cpe:/a:kde:konqueror:3.0.2

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:823Konqueror Cookie Access Restrictions Bypass Vulnerability
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0592
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0592
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-063
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2004-074.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2004:074
http://www.debian.org/security/2004/dsa-459
(VENDOR_ADVISORY)  DEBIAN  DSA-459
http://lists.grok.org.uk/pipermail/full-disclosure/2004-March/018475.html
(UNKNOWN)  FULLDISC  20040310 Corsaire Security Advisory: Multiple vendor HTTP user agent cookie path traversal issue
http://archives.neohapsis.com/archives/vulnwatch/2004-q1/0056.html
(VENDOR_ADVISORY)  VULNWATCH  20040310 Corsaire Security Advisory: Multiple vendor HTTP user agent cookie path traversal issue
http://www.mandriva.com/security/advisories?name=MDKSA-2004:022
(UNKNOWN)  MANDRAKE  MDKSA-2004:022

- 漏洞信息

多个供应商的互联网浏览器的cookie路径参数权限绕过漏洞
高危 路径遍历
2004-04-15 00:00:00 2005-10-20 00:00:00
远程  
        KDE 3.1.3及其早期版本中的Konqueror存在漏洞。远程攻击者可以通过URL中"%2e%2e"(编码的点点)的目录遍历序列来绕开web应用上预期的cookie访问权限,该漏洞导致Konqueror发送指定的URL子集以外的cookie,例如:与目标应用程序运行在同一服务器上的易受攻击的应用程序。

- 公告与补丁

        RedHat has released advisories RHSA-2004:075-01 and RHSA-2004:074-06 to address this issue in various Red Hat Linux operating systems. Please see the referenced advisories for more information.
        Mandrake has released an advisory MDKSA-2004:022 to address this issue. Please see the referenced advisory for more information.
        Debian has released an advisory DSA 459-1 to address this issue. Please see the referenced advisory for more information.
        SGI ProPack Patch 10062 is available for kdelibs. Please see advisory 20040303-01-U for further details.
        RedHat kdelibs-devel-3.1-10.i386.rpm
        
        RedHat kdelibs-3.1-10.i386.rpm
        
        SGI ProPack 2.3
        
        SGI ProPack 2.4
        

- 漏洞信息

4188
KDE Konqueror Cookie Path Traversal
Input Manipulation

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-03-10 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站