CVE-2003-0535
CVSS7.2
发布时间 :2003-08-18 00:00:00
修订时间 :2008-09-10 15:19:32
NMCOS    

[原文]Buffer overflow in xbl 1.0k and earlier allows local users to gain privileges via a long -display command line option.


[CNNVD]XBlockOut XBL显示本地缓冲区溢出漏洞(CNNVD-200308-072)

        
        xbl是一个Linux系统下的游戏程序。
        XBL在处理命令行选项是缺少正确的缓冲区边界检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以'game'权限在系统上执行任意指令。
        xbl在处理-display命令行选项时存在缓冲区溢出问题,精心构建参数数据提交给xbl执行,可能以'game'权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:xblockout:xbl:1.1
cpe:/a:xblockout:xbl:1.0i
cpe:/a:xblockout:xbl:1.0k

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0535
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0535
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-072
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-345
(VENDOR_ADVISORY)  DEBIAN  DSA-345
http://lists.grok.org.uk/pipermail/full-disclosure/2003-July/006386.html
(UNKNOWN)  FULLDISC  20030708 Fwd: xbl vulnerabilty

- 漏洞信息

XBlockOut XBL显示本地缓冲区溢出漏洞
高危 边界条件错误
2003-08-18 00:00:00 2005-10-20 00:00:00
本地  
        
        xbl是一个Linux系统下的游戏程序。
        XBL在处理命令行选项是缺少正确的缓冲区边界检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以'game'权限在系统上执行任意指令。
        xbl在处理-display命令行选项时存在缓冲区溢出问题,精心构建参数数据提交给xbl执行,可能以'game'权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-345

- 漏洞信息

12032
XBlockOut xbl -display Parameter Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-07-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

XBlockOut XBL Display Local Buffer Overrun Vulnerability
Boundary Condition Error 8145
No Yes
2003-07-09 12:00:00 2009-07-11 10:56:00
This issue was announced in a Debian advisory.

- 受影响的程序版本

XBlockOut xbl 1.1
XBlockOut xbl 1.0 k
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
XBlockOut xbl 1.0 i
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
XBlockOut xbl 1.1.1

- 不受影响的程序版本

XBlockOut xbl 1.1.1

- 漏洞讨论

XBL is prone to a locally exploitable buffer overrun condition. This is due to insufficient bounds checking of command line options and could permit code to executed with elevated privileges. xbl is typically installed setgid 'games'.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released an advisory (DSA 345-1) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.

The vendor has addressed this issue in xbl 1.1.1.


XBlockOut xbl 1.0 i

XBlockOut xbl 1.0 k

XBlockOut xbl 1.1

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站