CVE-2003-0515
CVSS7.5
发布时间 :2003-08-18 00:00:00
修订时间 :2008-09-10 15:19:27
NMCOS    

[原文]SQL injection vulnerabilities in the (1) PostgreSQL or (2) MySQL authentication modules for teapop 0.3.5 and earlier allow attackers to execute arbitrary SQL and possibly gain privileges.


[CNNVD]Teapop SQL注入导致非授权数据库操作漏洞(CNNVD-200308-066)

        
        teapop是一款POP3服务器,支持通过PostgreSQL或者MySQL数据库验证用户。
        teapop在处理验证过程中没有过滤用户提交的字符串过滤就直接进行SQL查询处理,远程攻击者可以利用这个漏洞注入恶意SQL命令,可泄露数据库信息或破坏数据库。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:teapop:teapop:0.3.5
cpe:/a:teapop:teapop:0.3.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0515
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0515
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-066
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-347
(VENDOR_ADVISORY)  DEBIAN  DSA-347

- 漏洞信息

Teapop SQL注入导致非授权数据库操作漏洞
高危 输入验证
2003-08-18 00:00:00 2005-10-20 00:00:00
远程  
        
        teapop是一款POP3服务器,支持通过PostgreSQL或者MySQL数据库验证用户。
        teapop在处理验证过程中没有过滤用户提交的字符串过滤就直接进行SQL查询处理,远程攻击者可以利用这个漏洞注入恶意SQL命令,可泄露数据库信息或破坏数据库。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-347

- 漏洞信息

9508
teapop PostgreSQL Authentication Module SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-07-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Teapop SQL Injection Vulnerability
Input Validation Error 8146
Yes No
2003-07-09 12:00:00 2009-07-11 10:56:00
This issue was announced in a Debian advisory.

- 受影响的程序版本

teapop teapop 0.3.5
teapop teapop 0.3.4
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha
- Debian Linux 3.0

- 漏洞讨论

teapop is prone to an SQL injection vulnerability. This issue occurs in modules supplied with Teapop that allow authentication via a MySQL or PostgreSQL database. Exploitation could allow for SQL queries to be modified, potentially allowing for unauthorized access, information disclosure or other consequences.

- 漏洞利用

There is no exploit required.

- 解决方案

Debian has released an advisory (DSA 347-1) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.

Gentoo has released an advisory (200309-18) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes. The following commands can be carried out to download teapop version 0.3.7:

emerge sync
emerge teapop -p
emerge teapop
emerge clean


teapop teapop 0.3.4

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站