CVE-2003-0460
CVSS5.0
发布时间 :2003-08-27 00:00:00
修订时间 :2008-09-05 16:34:22
NMCOS    

[原文]The rotatelogs program on Apache before 1.3.28, for Windows and OS/2 systems, does not properly ignore certain control characters that are received over the pipe, which could allow remote attackers to cause a denial of service.


[CNNVD]Apache HTTP服务器多个安全漏洞(CNNVD-200308-179)

        
        Apache HTTP服务器是流行的开源WEB服务器程序,可使用在Unix和Windows操作系统下。
        Apache HTTP 1.3.28修补了多个漏洞,这些漏洞包括拒绝服务攻击、文件描述符泄露、日志记录失败等问题。
        目前没有提供详细漏洞细节。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0460
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0460
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-179
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/694428
(UNKNOWN)  CERT-VN  VU#694428
http://www.apache.org/dist/httpd/Announcement.html
(PATCH)  CONFIRM  http://www.apache.org/dist/httpd/Announcement.html

- 漏洞信息

Apache HTTP服务器多个安全漏洞
中危 未知
2003-08-27 00:00:00 2005-10-20 00:00:00
远程※本地  
        
        Apache HTTP服务器是流行的开源WEB服务器程序,可使用在Unix和Windows操作系统下。
        Apache HTTP 1.3.28修补了多个漏洞,这些漏洞包括拒绝服务攻击、文件描述符泄露、日志记录失败等问题。
        目前没有提供详细漏洞细节。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在CustomLog或ErrorLog中禁用rotatelog工具。
        厂商补丁:
        Apache Software Foundation
        --------------------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Apache Software Foundation Upgrade Apache httpd 1.3.28
        
        http://httpd.apache.org/download.cgi

- 漏洞信息

9715
Apache HTTP Server rotatelogs Control Characters Over Pipe DoS
Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-07-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3.28 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Oracle Multiple Vulnerabilities
Unknown 13139
Yes Yes
2005-04-12 12:00:00 2006-05-05 11:30:00
The vendor reported these issues.

- 受影响的程序版本

PeopleSoft OneWorld Xe/ERP8 Applications SP22
PeopleSoft EnterpriseOne Applications 8.93
PeopleSoft EnterpriseOne Applications 8.9 SP2
Oracle Oracle9i Standard Edition 9.2 .6
Oracle Oracle9i Standard Edition 9.2 .0.5
Oracle Oracle9i Standard Edition 9.0.4
Oracle Oracle9i Standard Edition 9.0.1 .5
Oracle Oracle9i Standard Edition 9.0.1 .4
Oracle Oracle9i Personal Edition 9.2 .6
Oracle Oracle9i Personal Edition 9.2 .0.5
Oracle Oracle9i Personal Edition 9.0.4
Oracle Oracle9i Personal Edition 9.0.1 .5
Oracle Oracle9i Personal Edition 9.0.1 .4
Oracle Oracle9i Enterprise Edition 9.2 .6.0
Oracle Oracle9i Enterprise Edition 9.2 .0.5
Oracle Oracle9i Enterprise Edition 9.0.4
Oracle Oracle9i Enterprise Edition 9.0.1 .5
Oracle Oracle9i Enterprise Edition 9.0.1 .4
Oracle Oracle9i Application Server 9.0.3 .1
Oracle Oracle9i Application Server 9.0.2 .3
Oracle Oracle9i Application Server 1.0.2 .2
Oracle Oracle8i Standard Edition 8.1.7 .4
Oracle Oracle8i Enterprise Edition 8.1.7 .4.0
Oracle Oracle10g Standard Edition 10.1 .0.4
Oracle Oracle10g Standard Edition 10.1 .0.3.1
Oracle Oracle10g Standard Edition 10.1 .0.3
Oracle Oracle10g Standard Edition 10.1 .0.2
Oracle Oracle10g Personal Edition 10.1 .0.4
Oracle Oracle10g Personal Edition 10.1 .0.3.1
Oracle Oracle10g Personal Edition 10.1 .0.3
Oracle Oracle10g Personal Edition 10.1 .0.2
Oracle Oracle10g Enterprise Edition 10.1 .0.4
Oracle Oracle10g Enterprise Edition 10.1 .0.3.1
Oracle Oracle10g Enterprise Edition 10.1 .0.3
Oracle Oracle10g Enterprise Edition 10.1 .0.2
Oracle Oracle10g Application Server 10.1.2
Oracle Oracle10g Application Server 10.1 .0.3.1
Oracle Oracle10g Application Server 9.0.4 .1
Oracle Oracle10g Application Server 9.0.4 .0
Oracle Enterprise Manager Grid Control 10g 10.1 .3
Oracle Enterprise Manager Grid Control 10g 10.1 .0.2
Oracle Enterprise Manager 9.0.4 .1
Oracle Enterprise Manager 9.0.4 .0
Oracle E-Business Suite 11i 11.5.10
Oracle E-Business Suite 11i 11.5.9
Oracle E-Business Suite 11i 11.5.8
Oracle E-Business Suite 11i 11.5.7
Oracle E-Business Suite 11i 11.5.6
Oracle E-Business Suite 11i 11.5.5
Oracle E-Business Suite 11i 11.5.4
Oracle E-Business Suite 11i 11.5.3
Oracle E-Business Suite 11i 11.5.2
Oracle E-Business Suite 11i 11.5.1
Oracle E-Business Suite 11i 11.5
Oracle E-Business Suite 11.0
Oracle Collaboration Suite Release 2 9.0.4 .2
Oracle Collaboration Suite Release 2 9.0.4 .1

- 漏洞讨论

Oracle Database Server, Oracle Application Server, Oracle Collaboration Suite, Oracle E-Business and Applications, Oracle Enterprise Manager Grid Control, and Oracle PeopleSoft Applications are reported prone to multiple vulnerabilities.

Oracle has released a Critical Patch Update to address these issues in various supported applications and platforms. Other non-supported versions may be affected, but Symantec has not confirmed this.

The issues identified by the vendor affect all security properties of the Oracle products and present local and remote threats. While various levels of authorization are required to leverage some issues, others do not require any authorization.

This BID will be divided and updated into separate BIDs when more information is available.

- 漏洞利用


Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

Oracle has released a Critical Patch Update (Critical Patch Update - April 2005) to address these issues. Information regarding obtaining and applying an appropriate patch can be found in the Oracle Critical Patch Update in references.

Pre-Installation Notes for Oracle Database Server can be found at the following location:

http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=301045.1

Pre-Installation Notes for Oracle Application Server can be found at the following location:

http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=301046.1

Pre-Installation Notes for Oracle Collaboration Suite can be found at the following location:

http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=301047.1

Pre-Installation Notes for Oracle E-Business and Applications can be found at the following location:

http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=301048.1

Pre-Installation Notes for Oracle Enterprise Manager Grid Control can be found at the following location:

http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=301049.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站