CVE-2003-0455
CVSS4.6
发布时间 :2003-08-07 00:00:00
修订时间 :2016-10-17 22:34:01
NMCOS    

[原文]The imagemagick libmagick library 5.5 and earlier creates temporary files insecurely, which allows local users to create or overwrite arbitrary files.


[CNNVD]ImageMagick以不安全方式建立临时文件漏洞(CNNVD-200308-020)

        
        Image Magick是一款图象处理软件。
        Image Magick建立临时文件时没有正确相关安全问题,本地攻击者可以利用这个漏洞通过符号链接攻击破坏系统任意文件。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0455
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0455
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200308-020
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=105786393628728&w=2
(UNKNOWN)  BUGTRAQ  20030710 [OpenPKG-SA-2003.034] OpenPKG Security Advisory (imagemagick)
http://www.debian.org/security/2003/dsa-331
(VENDOR_ADVISORY)  DEBIAN  DSA-331
http://www.redhat.com/support/errata/RHSA-2004-494.html
(UNKNOWN)  REDHAT  RHSA-2004:494

- 漏洞信息

ImageMagick以不安全方式建立临时文件漏洞
中危 未知
2003-08-07 00:00:00 2005-10-20 00:00:00
本地  
        
        Image Magick是一款图象处理软件。
        Image Magick建立临时文件时没有正确相关安全问题,本地攻击者可以利用这个漏洞通过符号链接攻击破坏系统任意文件。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-331

- 漏洞信息

6550
ImageMagick libmagick Library Symlink Arbitrary File Modification
Local Access Required Race Condition

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-06-27 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

ImageMagick Temporary File Creation Vulnerability
Unknown 8057
No Yes
2003-06-29 12:00:00 2009-07-11 10:56:00
This vulnerability was reported in a Debian advisory.

- 受影响的程序版本

RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
Red Hat Fedora Core2
Red Hat Fedora Core1
ImageMagick ImageMagick 5.5.6 .0-20030409
+ OpenPKG OpenPKG Current
ImageMagick ImageMagick 5.5.3 .2-1.2.0
+ OpenPKG OpenPKG 1.2
ImageMagick ImageMagick 5.4.8 .2-1.1.0
+ OpenPKG OpenPKG 1.1
ImageMagick ImageMagick 5.4.4 .5
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

ImageMagick has been reported prone to an insecure temporary file creation vulnerability. As a result, it may be possible for local attackers to corrupt files owned by the user who is invoking the ImageMagick application.

- 漏洞利用

There is no exploit required.

- 解决方案

Debian has released an advisory. Information about obtaining and applying fixes are available in the referenced advisory.

OpenPKG has released updates to correct this issue.

RedHat Fedora Legacy has released security advisory FLSA:152777 addressing this issue for RedHat Linux 7.3 and 9.0, and for Fedora Core 1 and 2. Please see the referenced advisory for further information.


Red Hat Fedora Core1

Red Hat Fedora Core2

ImageMagick ImageMagick 5.4.4 .5

ImageMagick ImageMagick 5.4.8 .2-1.1.0

ImageMagick ImageMagick 5.5.3 .2-1.2.0

ImageMagick ImageMagick 5.5.6 .0-20030409

RedHat Linux 7.3

RedHat Linux 7.3 i686

RedHat Linux 7.3 i386

RedHat Linux 9.0 i386

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站