发布时间 :2004-03-29 00:00:00
修订时间 :2008-09-05 16:34:19

[原文]Heap-based buffer overflow in GTKSee 0.5 and 0.5.1 allows remote attackers to execute arbitrary code via a PNG image of certain color depths.

[CNNVD]GTKSee PNG图象装载操作堆破坏漏洞(CNNVD-200403-116)


- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  gtksee-png-bo(12462)

- 漏洞信息

GTKSee PNG图象装载操作堆破坏漏洞
高危 边界条件错误
2004-03-29 00:00:00 2005-10-20 00:00:00

- 公告与补丁


- 漏洞信息

GTKSee PNG Image Remote Overflow
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A LOCAL overflow exists in GTKSee. GTKSee fails to handle PNG files of a certain color depth properly resulting in a heap overflow. With a specially crafted request, an attacker can cause arbitrary code to run on the system resulting in a loss of integrity.

- 时间线

2003-06-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version GTKSee 0.5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

GTKSee PNG Image Loading Heap Corruption Vulnerability
Boundary Condition Error 8061
No Yes
2003-06-29 12:00:00 2009-07-11 10:56:00
This vulnerability was reported by the vendor.

- 受影响的程序版本

GTKSee GTKSee 0.5.1
GTKSee GTKSee 0.5
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
GTKSee GTKSee 0.5.2

- 不受影响的程序版本

GTKSee GTKSee 0.5.2

- 漏洞讨论

A vulnerability has been reported for GTKSee that may result in the corruption of heap memory. The vulnerability occurs when GTKSee attempts to load PNG files with a certain colour depth.

Code execution is possible.

The precise technical details of this vulnerability are unknown. This BID will be updated as further information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

Gentoo has released advisory 200307-05 to address this issue. Users of affected systems are advised to perform the following procedures to update vulnerable systems:

emerge sync
emerge gtksee
emerge clean

Fixes available:

GTKSee GTKSee 0.5

GTKSee GTKSee 0.5.1

- 相关参考