CVE-2003-0441
CVSS7.2
发布时间 :2004-03-03 00:00:00
修订时间 :2008-09-05 16:34:19
NMCOS    

[原文]Multiple buffer overflows in Orville Write (orville-write) 2.53 and earlier allow local users to gain privileges.


[CNNVD]Orville-Write多个未明缓冲区溢出漏洞(CNNVD-200403-041)

        
        Orville Write是一款可以替代标准write(1)命令的程序。
        Orville Write在处理命令行选项时缺少正确的缓冲区边界检查,本地攻击者可以用这个漏洞进行缓冲区溢出攻击,可能以tty或root权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0441
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0441
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-041
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7988
(VENDOR_ADVISORY)  BID  7988
http://www.debian.org/security/2003/dsa-326
(VENDOR_ADVISORY)  DEBIAN  DSA-326
http://xforce.iss.net/xforce/xfdb/12381
(VENDOR_ADVISORY)  XF  orvillewrite-variables-bo(12381)

- 漏洞信息

Orville-Write多个未明缓冲区溢出漏洞
高危 边界条件错误
2004-03-03 00:00:00 2005-10-20 00:00:00
本地  
        
        Orville Write是一款可以替代标准write(1)命令的程序。
        Orville Write在处理命令行选项时缺少正确的缓冲区边界检查,本地攻击者可以用这个漏洞进行缓冲区溢出攻击,可能以tty或root权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-326

- 漏洞信息

6679
Orville Write orville-write amin.c Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A local overflow exists in Orville Write. The "amin" binary fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request to the environment variable, a malicious user can cause arbitrary code execution with elevated privileges, possibly root, if the program was installed setuid, or "tty" group privileges, if the program was installed setgid, resulting in a loss of integrity.

- 时间线

2002-11-26 Unknow
2002-11-26 Unknow

- 解决方案

Upgrade to version 2.54 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Orville-Write Multiple Unspecified Buffer Overrun Vulnerabilities
Boundary Condition Error 7988
No Yes
2003-06-19 12:00:00 2009-07-11 10:06:00
This vulnerability was announced by the vendor.

- 受影响的程序版本

Orville-Write Orville-Write 2.53
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Orville-Write Orville-Write 2.54

- 不受影响的程序版本

Orville-Write Orville-Write 2.54

- 漏洞讨论

Multiple unspecified buffer overrun vulnerabilities have been discovered in Orville-Write. The problems likely occur due to insufficient bounds checking when processing user-supplied command-line arguments or environment variables.

If the Orville-Write application has been installed setuid or setgid, this vulnerability could potentially be exploited to gain elevated privileges.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released a security advisory (DSA 326-1), which contains fixes to address this issue. Users are advised to upgrade as soon as possible.

The vendor has released Orville-Write 2.54 to address this issue.


Orville-Write Orville-Write 2.53

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站