CVE-2003-0433
CVSS7.5
发布时间 :2003-07-24 00:00:00
修订时间 :2008-09-05 16:34:18
NMCOS    

[原文]Multiple buffer overflows in gnocatan 0.6.1 and earlier allow attackers to execute arbitrary code.


[CNNVD]Gnocatan Server多个远程缓冲区溢出漏洞(CNNVD-200307-020)

        
        Gnocatan Server是一款游戏服务程序。
        Gnocatan Server存在多个缓冲区溢出问题,远程攻击者可以利用这个漏洞可能以游戏服务进程权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0433
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0433
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200307-020
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-315
(VENDOR_ADVISORY)  DEBIAN  DSA-315

- 漏洞信息

Gnocatan Server多个远程缓冲区溢出漏洞
高危 边界条件错误
2003-07-24 00:00:00 2005-11-29 00:00:00
远程  
        
        Gnocatan Server是一款游戏服务程序。
        Gnocatan Server存在多个缓冲区溢出问题,远程攻击者可以利用这个漏洞可能以游戏服务进程权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-315

- 漏洞信息

6684
gnocatan Multiple Unspecified Overflows
Location Unknown Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

An overflow exists in Gnocatan. Gnocatan fails to check boundary, resulting in a buffer overflow. With a specially crafted request, an attacker could overflow a buffer and execute arbitrary code on the system or cause a denial of service, resulting in a loss of integrity.

- 时间线

2003-06-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.7.1-r3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Multiple Gnocatan Server Buffer Overflow Vulnerabilities
Boundary Condition Error 7877
Yes No
2003-06-12 12:00:00 2009-07-11 10:06:00
Discovery of these issues is credited to Bas Wijnen.

- 受影响的程序版本

Gnocatan Gnocatan 0.6.1
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha
- Debian Linux 3.0

- 漏洞讨论

The Gnocatan game server is prone to multiple remotely exploitable buffer overflow vulnerabilities. These conditions could potentially be exploited to execute malicious code in the context of the server or to launch denial of service attacks.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released an advisory (DSA 315-1) that addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.

It is not known if the Gnocatan vendor has released a fixed version.

Gentoo Linux has released an advisory. Users who have installed app-games/gnocatan are advised to upgrade to gnocatan-0.7.1-r3 by issuing the following commands:

emerge sync
emerge gnocatan
emerge clean


Gnocatan Gnocatan 0.6.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站