CVE-2003-0404
CVSS4.3
发布时间 :2003-06-30 00:00:00
修订时间 :2016-10-17 22:33:32
NMCOES    

[原文]Multiple Cross Site Scripting (XSS) vulnerabilities in Vignette StoryServer 4 and 5, and Vignette V/5 and V/6, allow remote attackers to insert arbitrary HTML and script via text variables, as demonstrated using the errInfo parameter of the default login template.


[CNNVD]Vignette多个跨站脚本攻击(XSS)漏洞(CNNVD-200306-112)

        Vignette StoryServer 版本4和版本5,以及Vignette 版本V/5和版本V/6存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助text变量注入任意HTML和脚本,正如使用默认登录模板中的errInfo参数。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:vignette:vignette:5.0
cpe:/a:vignette:storyserver:4.1
cpe:/a:vignette:storyserver:5.0
cpe:/a:vignette:storyserver:4.0
cpe:/a:vignette:content_suite:7.0
cpe:/a:vignette:content_suite:6.0
cpe:/a:vignette:content_suite:5.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0404
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0404
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200306-112
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=105406028027360&w=2
(UNKNOWN)  BUGTRAQ  20030526 S21SEC-023 - Vignette multiple Cross Site Scripting vulnerabilities
http://www.iss.net/security_center/static/12071.php
(VENDOR_ADVISORY)  XF  vignette-multiple-xss(12071)
http://www.s21sec.com/es/avisos/s21sec-023-en.txt
(VENDOR_ADVISORY)  MISC  http://www.s21sec.com/es/avisos/s21sec-023-en.txt
http://www.securityfocus.com/bid/7687
(VENDOR_ADVISORY)  BID  7687

- 漏洞信息

Vignette多个跨站脚本攻击(XSS)漏洞
中危 输入验证
2003-06-30 00:00:00 2005-10-20 00:00:00
远程  
        Vignette StoryServer 版本4和版本5,以及Vignette 版本V/5和版本V/6存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助text变量注入任意HTML和脚本,正如使用默认登录模板中的errInfo参数。

- 公告与补丁

        The vendor has posted a response to this issue at the following location:
        http://support.vignette.com/VOLSS/KB/View/1,,5557,00.html
        It should be noted that only existing Vignette customers and partners are able to access the above link.
        The vendor has released a fix to address this issue. Vignette customers who are affected by this vulnerability have been advised to contact Vignette, using standard methods, as soon as possible to attain the required fixes.

- 漏洞信息 (22648)

Vignette 4/5 Cross-Site Scripting Vulnerabilities (EDBID:22648)
unix remote
2003-05-26 Verified
0 Ramon Pinuaga Cascales
N/A [点击下载]
source: http://www.securityfocus.com/bid/7687/info

Vignette software has been reported prone to multiple cross-site scripting vulnerabilities.

Reportedly the issue presents itself, because the Vignette software does not sufficiently sanitize HTML characters from user-supplied data.

It may be possible for an attacker to supply and execute HTML and script code on a web client in the context of the site hosting the Vignette software. This may allow for theft of cookie-based authentication credentials and other attacks.

This issue was reported for Vignette StoryServer version 4 to version 6; it has been speculated that all current versions are vulnerable. 

https://www.example.com/Page/1,10966,,00.html?var=<script>alert('s21sec')</script>

http://www.example.com/vgn/login?errInfo="%2b%20document.cookie%20%2b" 		

- 漏洞信息

4861
Vignette StoryServer Multiple Script All Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Vignette contain a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate any variable upon submission. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-05-26 2003-03-04
2003-05-26 Unknow

- 解决方案

Currently, there are no known workarounds to correct this issue. However, Vignette has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Multiple Vignette Cross-Site Scripting Vulnerabilities
Input Validation Error 7687
Yes No
2003-05-26 12:00:00 2009-07-11 10:06:00
Discovery of this vulnerability has been credited to Ramon Pinuaga Cascales <rpinuaga@s21sec.com>.

- 受影响的程序版本

Vignette Vignette V/5
Vignette V6 Content Suite
Vignette StoryServer 5.0
Vignette StoryServer 4.1
Vignette StoryServer 4.0
Vignette Content Suite V7
Vignette Content Suite V5

- 漏洞讨论

Vignette software has been reported prone to multiple cross-site scripting vulnerabilities.

Reportedly the issue presents itself, because the Vignette software does not sufficiently sanitize HTML characters from user-supplied data.

It may be possible for an attacker to supply and execute HTML and script code on a web client in the context of the site hosting the Vignette software. This may allow for theft of cookie-based authentication credentials and other attacks.

This issue was reported for Vignette StoryServer version 4 to version 6; it has been speculated that all current versions are vulnerable.

- 漏洞利用

The following proof of concepts have been supplied:

https://www.example.com/Page/1,10966,,00.html?var=&lt;script&gt;alert('s21sec')&lt;/script&gt;

http://www.example.com/vgn/login?errInfo="%2b%20document.cookie%20%2b"

- 解决方案

The vendor has posted a response to this issue at the following location:

http://support.vignette.com/VOLSS/KB/View/1,,5557,00.html

It should be noted that only existing Vignette customers and partners are able to access the above link.

The vendor has released a fix to address this issue. Vignette customers who are affected by this vulnerability have been advised to contact Vignette, using standard methods, as soon as possible to attain the required fixes.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站