CVE-2003-0357
CVSS7.5
发布时间 :2003-06-09 00:00:00
修订时间 :2008-09-10 15:18:43
NMCOS    

[原文]Multiple integer overflow vulnerabilities in Ethereal 0.9.11 and earlier allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) Mount and (2) PPP dissectors.


[CNNVD]Ethereal mount解析器整数溢出造成缓冲区破坏漏洞(CNNVD-200306-026)

        
        Ethereal是一款免费开放源代码的网络协议分析程序,可使用在Unix和Windows操作系统下。
        Ethereal包含的mount解析器存在整数溢出造成缓冲区破坏,远程攻击者可以利用这个漏洞构建恶意包提交给Ethereal监听的网络,可使Ethereal发生缓冲区溢出,可能以root用户权限在系统上执行任意指令。
        目前没有详细漏洞细节描述。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:73Integer Overflow Vulnerabilities in Ethereal 0.9.11
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0357
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0357
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200306-026
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/361700
(UNKNOWN)  CERT-VN  VU#361700
http://www.kb.cert.org/vuls/id/232164
(UNKNOWN)  CERT-VN  VU#232164
http://www.ethereal.com/appnotes/enpa-sa-00009.html
(VENDOR_ADVISORY)  CONFIRM  http://www.ethereal.com/appnotes/enpa-sa-00009.html
http://www.debian.org/security/2003/dsa-313
(VENDOR_ADVISORY)  DEBIAN  DSA-313
http://www.securityfocus.com/bid/7495
(UNKNOWN)  BID  7495
http://www.securityfocus.com/bid/7494
(UNKNOWN)  BID  7494
http://www.mandriva.com/security/advisories?name=MDKSA-2003:067
(UNKNOWN)  MANDRAKE  MDKSA-2003:067
http://rhn.redhat.com/errata/RHSA-2003-077.html
(UNKNOWN)  REDHAT  RHSA-2003:077

- 漏洞信息

Ethereal mount解析器整数溢出造成缓冲区破坏漏洞
高危 边界条件错误
2003-06-09 00:00:00 2005-10-20 00:00:00
远程  
        
        Ethereal是一款免费开放源代码的网络协议分析程序,可使用在Unix和Windows操作系统下。
        Ethereal包含的mount解析器存在整数溢出造成缓冲区破坏,远程攻击者可以利用这个漏洞构建恶意包提交给Ethereal监听的网络,可使Ethereal发生缓冲区溢出,可能以root用户权限在系统上执行任意指令。
        目前没有详细漏洞细节描述。
        

- 公告与补丁

        厂商补丁:
        Ethereal Group
        --------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Ethereal Group Upgrade ethereal-0.9.12.tar.gz
        
        http://www.ethereal.com/distribution/ethereal-0.9.12.tar.gz

- 漏洞信息

4342
Ethereal Mount Dissector Remote Integer Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-05-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Ethereal PPP Dissector Integer Overflow Vulnerability
Boundary Condition Error 7495
Yes No
2003-05-03 12:00:00 2009-07-11 09:07:00
Discovery of this vulnerability credited to Timo Sirainen.

- 受影响的程序版本

RedHat Linux Advanced Work Station 2.1
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 2.1
Red Hat Enterprise Linux AS 2.1
Ethereal Group Ethereal 0.9.11
Ethereal Group Ethereal 0.9.10
+ Conectiva Linux 9.0
Ethereal Group Ethereal 0.9.9
+ Mandriva Linux Mandrake 9.1 ppc
+ Mandriva Linux Mandrake 9.1
Ethereal Group Ethereal 0.9.8
+ RedHat Linux 9.0 i386
+ RedHat Linux 8.0 i386
+ RedHat Linux 8.0
+ RedHat Linux 7.3 i386
+ RedHat Linux 7.3
+ RedHat Linux 7.2 ia64
+ RedHat Linux 7.2 i386
+ RedHat Linux 7.2
+ Terra Soft Solutions Yellow Dog Linux 3.0
Ethereal Group Ethereal 0.9.7
Ethereal Group Ethereal 0.9.6
+ Conectiva Linux Enterprise Edition 1.0
Ethereal Group Ethereal 0.9.5
Ethereal Group Ethereal 0.9.4
+ Conectiva Linux 8.0
+ Conectiva Linux 7.0
+ Conectiva Linux 6.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Ethereal Group Ethereal 0.9.3
+ RedHat Linux 7.3 i386
+ RedHat Linux 7.3
+ RedHat Linux 7.2 i386
+ RedHat Linux 7.2 alpha
+ RedHat Linux 7.1 ia64
+ RedHat Linux 7.1 i386
+ RedHat Linux 7.1 alpha
+ RedHat Linux 7.0 sparc
+ RedHat Linux 7.0 i386
+ RedHat Linux 7.0 alpha
+ RedHat Linux 6.2 sparc
+ RedHat Linux 6.2 i386
+ RedHat Linux 6.2 alpha
Ethereal Group Ethereal 0.9.2
Ethereal Group Ethereal 0.9.1
- Compaq Tru64 5.0
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- HP HP-UX 11.0
- IBM AIX 5.1
- Linux kernel 2.4
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows ME
- Microsoft Windows NT Workstation 4.0
- NetBSD NetBSD 1.5
- OpenBSD OpenSSH 3.0
- SCO Unixware 7.0
- SGI IRIX 6.0
- Sun Solaris 8_sparc
Ethereal Group Ethereal 0.9
Ethereal Group Ethereal 0.8.18
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.2
Ethereal Group Ethereal 0.8
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
Ethereal Group Ethereal 0.9.12

- 不受影响的程序版本

Ethereal Group Ethereal 0.9.12

- 漏洞讨论

The PPP dissector of Ethereal is prone to an integer overflow vulnerability.

The precise technical details of this vulnerability are currently unknown. This BID will be updated as further information is available.

This vulnerability affects Ethereal 0.9.11 and earlier.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Red Hat has released a security advisory (RHSA-2003:077-13) containing fixes which address this and other issues with ethereal. See referenced advisory for further details on obtaining and applying fixes.

Debian has released an advisory (DSA 313-1) containing fixes to address this issue.

Ethereal 0.9.12 is not vulnerable to this issue. Users are advised to upgrade.

Red Hat has released upgraded RPMs which correct this vulnerability. Please see advisory RHSA-2003:203-01 (references section) for download links.

Updates are available for Yellow Dog Linux. These updates can be applied manually or by issuing the following command:

yum update ethereal


Ethereal Group Ethereal 0.8

Ethereal Group Ethereal 0.8.18

Ethereal Group Ethereal 0.9

Ethereal Group Ethereal 0.9.1

Ethereal Group Ethereal 0.9.10

Ethereal Group Ethereal 0.9.11

Ethereal Group Ethereal 0.9.2

Ethereal Group Ethereal 0.9.3

Ethereal Group Ethereal 0.9.4

Ethereal Group Ethereal 0.9.5

Ethereal Group Ethereal 0.9.6

Ethereal Group Ethereal 0.9.7

Ethereal Group Ethereal 0.9.8

Ethereal Group Ethereal 0.9.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站