CVE-2003-0327
CVSS5.0
发布时间 :2003-12-15 00:00:00
修订时间 :2016-10-17 22:32:31
NMCOS    

[原文]Sybase Adaptive Server Enterprise (ASE) 12.5 allows remote attackers to cause a denial of service (hang) via a remote password array with an invalid length, which triggers a heap-based buffer overflow.


[CNNVD]Sybase Adaptive Server的远程堆溢出漏洞(CNNVD-200312-026)

        Sybase Adaptive Server Enterprise (ASE)12.5版本存在漏洞。远程攻击者借助无效长度的远程口令阵列导致服务拒绝(挂起),该漏洞触发基于堆的缓冲区溢出。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0327
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0327
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-026
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=106936096103805&w=2
(UNKNOWN)  BUGTRAQ  20031120 R7-0016: Sybase ASE 12.5 Remote Password Array Denial of Service
http://www.rapid7.com/advisories/R7-0016.html
(VENDOR_ADVISORY)  MISC  http://www.rapid7.com/advisories/R7-0016.html
http://xforce.iss.net/xforce/xfdb/13800
(UNKNOWN)  XF  sybase-passwordarray-bo(13800)

- 漏洞信息

Sybase Adaptive Server的远程堆溢出漏洞
中危 缓冲区溢出
2003-12-15 00:00:00 2005-10-20 00:00:00
远程  
        Sybase Adaptive Server Enterprise (ASE)12.5版本存在漏洞。远程攻击者借助无效长度的远程口令阵列导致服务拒绝(挂起),该漏洞触发基于堆的缓冲区溢出。
        

- 公告与补丁

        It has been reported that the vendor has released an Electronic Software Distribution (ASE 12.5 ESD#2) to address this issue. Customers are advised to contact the vendor for further details.

- 漏洞信息

2851
Sybase ASE Password Array Heap Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

A remote heap overflow exists in Sybase ASE server 12.5. The data structure sent to the server to provide authentication details consists of sets of (data length, data) pairs. By providing a valid username and password, but incorrect field length values, a section of the heap can be overflowed. With a specially crafted request, an attacker can cause a denial of service requiring a restart of the whole ASE process under Windows, or a single server process under Linux. It is reported that this vulnerability could be used to execute arbitrary code, but no exploit code has been released.

- 时间线

2003-11-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version ASE 12.5 ESD#2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds other than general best practise of restricting the number of locations a client can login from.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Sybase Adaptive Server Remote Password Array Heap Overflow Vulnerability
Boundary Condition Error 9080
Yes No
2003-11-20 12:00:00 2009-07-12 12:56:00
Discovery of this vulnerability has been credited to Rapid7, Inc.

- 受影响的程序版本

Sybase Adaptive Server Enterprise 12.5 Win
- Microsoft Windows NT Server 4.0 SP6a
- Microsoft Windows NT Server 4.0 SP6
- Microsoft Windows NT Server 4.0 SP5
- Microsoft Windows NT Server 4.0 SP4
- Microsoft Windows NT Server 4.0 SP3
Sybase Adaptive Server Enterprise 12.5 Linux
Sybase Adaptive Server Enterprise 11.0.3 .3Linux

- 不受影响的程序版本

Sybase Adaptive Server Enterprise 11.0.3 .3Linux

- 漏洞讨论

Sybase adaptive server has been reported prone to heap overflow vulnerability. The issue has been reported to present itself when invalid password and servername buffer lengths in a remote password array are passed to the affected server. A heap overflow condition may be triggered, potentially causing heap memory management structures to be corrupted.

It has been reported that an attacker may exploit this condition to trigger a denial of service condition in the affected server.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

It has been reported that the vendor has released an Electronic Software Distribution (ASE 12.5 ESD#2) to address this issue. Customers are advised to contact the vendor for further details.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站