发布时间 :2003-06-16 00:00:00
修订时间 :2016-10-17 22:32:15

[原文]Cross-site scripting (XSS) vulnerability in articleview.php for eZ publish 2.2 allows remote attackers to insert arbitrary web script.

[CNNVD]eZ publish articleview.php跨站脚本攻击漏洞(CNNVD-200306-082)

        eZ publish 2.2版本articleview.php存在跨站脚本攻击(XSS)漏洞。远程攻击者插入任意web脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20030516 EzPublish Directory XSS Vulnerability

- 漏洞信息

eZ publish articleview.php跨站脚本攻击漏洞
中危 跨站脚本
2003-06-16 00:00:00 2005-10-20 00:00:00
        eZ publish 2.2版本articleview.php存在跨站脚本攻击(XSS)漏洞。远程攻击者插入任意web脚本。

- 公告与补丁


- 漏洞信息 (22607)

EZ Publish 2.2 Index.PHP IMG Tag Cross Site Scripting Vulnerability (EDBID:22607)
php webapps
2003-05-16 Verified
0 Ferruh Mavituna
N/A [点击下载]

A cross-site scripting vulnerability has been reported for eZ publish. Specifically, eZ publish does not sufficiently sanitize user-supplied input supplied to the 'index.php' script.

This may allow for theft of cookie-based authentication credentials and other attacks.<img%20src="javascript:alert(document.cookie)"> 		

- 漏洞信息

eZ Publish articleview.php XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ez Publish contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input to the articleview.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-05-16 Unknow
2003-05-16 Unknow

- 解决方案

Upgrade to version 3.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者