CVE-2003-0218
CVSS7.5
发布时间 :2003-05-12 00:00:00
修订时间 :2016-10-17 22:30:51
NMCO    

[原文]Buffer overflow in PostMethod() function for Monkey HTTP Daemon (monkeyd) 0.6.1 and earlier allows remote attackers to execute arbitrary code via a POST request with a large body.


[CNNVD]Monkey HTTP Daemon (monkeyd)PostMethod()函数缓冲区溢出漏洞(CNNVD-200305-026)

        Monkey HTTP Daemon (monkeyd) 0.6.1及其早期版本的PostMethod()函数存在缓冲区溢出漏洞。远程攻击者可以借助超大主体的POST请求执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:monkey-project:monkey_http_daemon:0.6.0Monkey Project Monkey HTTP Daemon 0.6.0
cpe:/a:monkey-project:monkey_http_daemon:0.6.1Monkey Project Monkey HTTP Daemon 0.6.1
cpe:/a:monkey-project:monkey_http_daemon:0.5.2Monkey Project Monkey HTTP Daemon 0.5.2
cpe:/a:monkey-project:monkey_http_daemon:0.1.1Monkey Project Monkey HTTP Daemon 0.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0218
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0218
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200305-026
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2003-q2/0029.html
(VENDOR_ADVISORY)  VULNWATCH  20030420 Monkey HTTPd Remote Buffer Overflow
http://marc.info/?l=bugtraq&m=105094204204166&w=2
(UNKNOWN)  BUGTRAQ  20030420 Monkey HTTPd Remote Buffer Overflow
http://marc.info/?l=bugtraq&m=105154473526898&w=2
(UNKNOWN)  BUGTRAQ  20030428 GLSA: monkeyd (200304-07.1)
http://monkeyd.sourceforge.net/Changelog.txt
(UNKNOWN)  CONFIRM  http://monkeyd.sourceforge.net/Changelog.txt
http://www.securityfocus.com/bid/7202
(VENDOR_ADVISORY)  BID  7202

- 漏洞信息

Monkey HTTP Daemon (monkeyd)PostMethod()函数缓冲区溢出漏洞
高危 缓冲区溢出
2003-05-12 00:00:00 2005-10-20 00:00:00
远程  
        Monkey HTTP Daemon (monkeyd) 0.6.1及其早期版本的PostMethod()函数存在缓冲区溢出漏洞。远程攻击者可以借助超大主体的POST请求执行任意代码。

- 公告与补丁

        

- 漏洞信息

7733
Monkey HTTP Daemon (monkeyd) PostMethod() Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-04-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站