CVE-2003-0189
CVSS5.0
发布时间 :2003-06-09 00:00:00
修订时间 :2016-10-17 22:30:26
NMCOS    

[原文]The authentication module for Apache 2.0.40 through 2.0.45 on Unix does not properly handle threads safely when using the crypt_r or crypt functions, which allows remote attackers to cause a denial of service (failed Basic authentication with valid usernames and passwords) when a threaded MPM is used.


[CNNVD]Apache基本验证模块远程拒绝服务攻击漏洞(CNNVD-200306-018)

        
        Apache HTTP服务器是流行的开源WEB服务器程序,可使用在Unix和Windows操作系统下。
        Apache 2.0版本的2.0.40到2.0.45的基本验证模块(basic authentication)存在设计缺陷,远程攻击者可以利用这个漏洞对Apache服务进行拒绝服务攻击。
        当使用crypt_r或crypt此漏洞由于不正确处理thread_safely,当使用一个线程化(threaded)的MPM(在部分平台下不是默认安装),允许远程攻击者利用漏洞对服务进行拒绝服务攻击,导致基本验证失败,不能对合法用户名和密码进行验证,需要管理员手工重新启动Apache。目前没有详细漏洞细节提供。
        根据报告,此漏洞不能用于未授权用户访问受保护资源。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:apache:http_server:2.0.42Apache Software Foundation Apache HTTP Server 2.0.42
cpe:/a:apache:http_server:2.0.43Apache Software Foundation Apache HTTP Server 2.0.43
cpe:/a:apache:http_server:2.0.44Apache Software Foundation Apache HTTP Server 2.0.44
cpe:/a:apache:http_server:2.0.45Apache Software Foundation Apache HTTP Server 2.0.45
cpe:/a:apache:http_server:2.0.40Apache Software Foundation Apache HTTP Server 2.0.40
cpe:/a:apache:http_server:2.0.41Apache Software Foundation Apache HTTP Server 2.0.41

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0189
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0189
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200306-018
(官方数据源) CNNVD

- 其它链接及资源

http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000661
(UNKNOWN)  CONECTIVA  CLA-2003:661
http://marc.info/?l=bugtraq&m=105418115512559&w=2
(UNKNOWN)  BUGTRAQ  20030528 [SECURITY] [ANNOUNCE] Apache 2.0.46 released
http://www.apache.org/dist/httpd/Announcement2.html
(VENDOR_ADVISORY)  CONFIRM  http://www.apache.org/dist/httpd/Announcement2.html
http://www.kb.cert.org/vuls/id/479268
(UNKNOWN)  CERT-VN  VU#479268
http://www.redhat.com/support/errata/RHSA-2003-186.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:186
http://www.securityfocus.com/bid/7725
(UNKNOWN)  BID  7725
http://xforce.iss.net/xforce/xfdb/12091
(UNKNOWN)  XF  apache-aprpasswordvalidate-dos(12091)

- 漏洞信息

Apache基本验证模块远程拒绝服务攻击漏洞
中危 设计错误
2003-06-09 00:00:00 2005-10-20 00:00:00
远程  
        
        Apache HTTP服务器是流行的开源WEB服务器程序,可使用在Unix和Windows操作系统下。
        Apache 2.0版本的2.0.40到2.0.45的基本验证模块(basic authentication)存在设计缺陷,远程攻击者可以利用这个漏洞对Apache服务进行拒绝服务攻击。
        当使用crypt_r或crypt此漏洞由于不正确处理thread_safely,当使用一个线程化(threaded)的MPM(在部分平台下不是默认安装),允许远程攻击者利用漏洞对服务进行拒绝服务攻击,导致基本验证失败,不能对合法用户名和密码进行验证,需要管理员手工重新启动Apache。目前没有详细漏洞细节提供。
        根据报告,此漏洞不能用于未授权用户访问受保护资源。
        

- 公告与补丁

        厂商补丁:
        Apache Software Foundation
        --------------------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载Apache 2.0.46版本:
        
        http://httpd.apache.org/download.cgi

- 漏洞信息

9714
Apache Authentication Module Threaded MPM DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-05-28 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Basic Authentication Module Valid User Login Denial Of Service Vulnerability
Design Error 7725
Yes No
2003-05-28 12:00:00 2009-07-11 10:06:00
Discovery of this issue is credited to John Hughes <john.hughes@entegrity.com>.

- 受影响的程序版本

RedHat mod_ssl-2.0.40-8.i386.rpm
+ RedHat Linux 8.0
RedHat mod_ssl-2.0.40-21.i386.rpm
+ RedHat Linux 9.0 i386
RedHat httpd-manual-2.0.40-8.i386.rpm
+ RedHat Linux 8.0
RedHat httpd-manual-2.0.40-21.i386.rpm
+ RedHat Linux 9.0 i386
RedHat httpd-devel-2.0.40-8.i386.rpm
+ RedHat Linux 8.0
RedHat httpd-devel-2.0.40-21.i386.rpm
+ RedHat Linux 9.0 i386
RedHat httpd-2.0.40-8.i386.rpm
+ RedHat Linux 8.0
RedHat httpd-2.0.40-21.i386.rpm
+ RedHat Linux 9.0 i386
HP HP-UX Apache-Based Web Server 1.0.1 .01
- HP HP-UX 11.22
- HP HP-UX 11.20
- HP HP-UX 11.11
- HP HP-UX 11.0
HP HP-UX Apache-Based Web Server 1.0 .05.01
HP HP-UX Apache-Based Web Server 1.0 .04.01
HP HP-UX Apache-Based Web Server 1.0 .03.01
HP HP-UX Apache-Based Web Server 1.0 .02.01
HP HP-UX Apache-Based Web Server 1.0 .01
- HP HP-UX 11.22
- HP HP-UX 11.20
- HP HP-UX 11.11
- HP HP-UX 11.0
Apache Software Foundation Apache 2.0.45
- Apple Mac OS X 10.2.6
- Apple Mac OS X 10.2.5
- Apple Mac OS X 10.2.4
- Apple Mac OS X 10.2.3
- Apple Mac OS X 10.2.2
- Apple Mac OS X 10.2.1
- Apple Mac OS X 10.2
- Apple Mac OS X 10.1.5
- Apple Mac OS X 10.1.4
- Apple Mac OS X 10.1.3
- Apple Mac OS X 10.1.2
- Apple Mac OS X 10.1.1
- Apple Mac OS X 10.1
- Apple Mac OS X 10.1
- Apple Mac OS X 10.0.4
- Apple Mac OS X 10.0.3
- Apple Mac OS X 10.0.2
- Apple Mac OS X 10.0.1
- Apple Mac OS X 10.0
+ Conectiva Linux 9.0
Apache Software Foundation Apache 2.0.44
Apache Software Foundation Apache 2.0.43
Apache Software Foundation Apache 2.0.42
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
Apache Software Foundation Apache 2.0.41
Apache Software Foundation Apache 2.0.40
+ RedHat Linux 9.0 i386
+ RedHat Linux 8.0
+ Terra Soft Solutions Yellow Dog Linux 3.0
HP HP-UX Apache-Based Web Server 1.0 .07.01
HP HP-UX Apache-Based Web Server 1.0 .06.01
Apache Software Foundation Apache 2.0.46
+ Red Hat Enterprise Linux AS 3
+ RedHat Desktop 3.0
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 3
+ Trustix Secure Linux 2.0

- 不受影响的程序版本

HP HP-UX Apache-Based Web Server 1.0 .07.01
HP HP-UX Apache-Based Web Server 1.0 .06.01
Apache Software Foundation Apache 2.0.46
+ Red Hat Enterprise Linux AS 3
+ RedHat Desktop 3.0
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 3
+ Trustix Secure Linux 2.0

- 漏洞讨论

It has been reported that Apache 2.0 does not properly use specific thread-safe functions. Because of this, an attacker may be able to create a circumstance that prevents users from logging into restricted areas with valid user credentials.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

This issue has been addressed in Apache 2.0.46. Users are advised to upgrade.

Red Hat has released an advisory (RHSA-2003:186-01) which addresses this issue. Please see the attached advisory for details on obtaining and applying fixes.

Gentoo Linux users who are running net-www/apache-2.x may upgrade to apache-2.0.46 with the following commands:

emerge sync
emerge apache
emerge clean

Yellow Dog Linux has released an advisory containing fixes to address this issue. Users are advised to upgrade as soon as possible.

HP has released advisory HPSBUX0307-269 (rev.1) and fixes to address this issue.

Fixes are available:


RedHat httpd-manual-2.0.40-21.i386.rpm

RedHat httpd-2.0.40-8.i386.rpm

RedHat httpd-2.0.40-21.i386.rpm

RedHat httpd-manual-2.0.40-8.i386.rpm

RedHat httpd-devel-2.0.40-21.i386.rpm

RedHat httpd-devel-2.0.40-8.i386.rpm

RedHat mod_ssl-2.0.40-8.i386.rpm

RedHat mod_ssl-2.0.40-21.i386.rpm

HP HP-UX Apache-Based Web Server 1.0 .04.01

HP HP-UX Apache-Based Web Server 1.0 .05.01

HP HP-UX Apache-Based Web Server 1.0 .01

HP HP-UX Apache-Based Web Server 1.0 .03.01

HP HP-UX Apache-Based Web Server 1.0 .02.01

HP HP-UX Apache-Based Web Server 1.0.1 .01

Apache Software Foundation Apache 2.0.40

Apache Software Foundation Apache 2.0.41

Apache Software Foundation Apache 2.0.42

Apache Software Foundation Apache 2.0.43

Apache Software Foundation Apache 2.0.44

Apache Software Foundation Apache 2.0.45

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站