CVE-2003-0188
CVSS7.2
发布时间 :2003-06-09 00:00:00
修订时间 :2008-09-10 15:18:11
NMCOS    

[原文]lv reads a .lv file from the current working directory, which allows local users to execute arbitrary commands as other lv users by placing malicious .lv files into other directories.


[CNNVD]lv处理配置文件权不当导致限提升漏洞(CNNVD-200306-038)

        
        lv是一款强大的文件查看程序,类似less,可以通过编码系统如ISO-8859、ISO-2022、EUC、SJIS Big5、HZ和Unicode对多语言流进行编码和解码。
        lv在读取配置文件时缺少正确检查,本地攻击者可以利用这个漏洞构建恶意配置文件,以其他用户权限执行任意命令。
        lv可以从当前目录的配置文件中读取选项,并可以lv配置选项可以用于执行命令,本地攻击者可以使用这个文件放置到任意他们具有写权限的目录中,任何用户在那个包含恶意配置文件的目录中执行lv,并使用v(edit)命令时可以迫使执行任意命令(可能是root用户权限)。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:redhat:lv:4.49.4-7::i386
cpe:/a:redhat:lv:4.49.4-3::i386
cpe:/o:redhat:linux:9.0::i386
cpe:/o:redhat:linux:7.3Red Hat Linux 7.3
cpe:/a:redhat:lv:4.49.4-1::i386
cpe:/a:lv:lv:4.49.3
cpe:/o:redhat:linux:8.0Red Hat Linux 8.0
cpe:/o:redhat:linux:7.1Red Hat Linux 7.1
cpe:/a:lv:lv:4.49.1
cpe:/o:redhat:linux:7.2Red Hat Linux 7.2
cpe:/a:redhat:lv:4.49.4-9::i386
cpe:/a:lv:lv:4.49.4
cpe:/a:lv:lv:4.49.2

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:430Multilingual File Viewer .lv File Sneak Attack Vulnerability
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0188
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0188
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200306-038
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2003-169.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:169
http://www.debian.org/security/2003/dsa-304
(VENDOR_ADVISORY)  DEBIAN  DSA-304
http://www.turbolinux.com/security/TLSA-2003-35.txt
(UNKNOWN)  TURBO  TLSA-2003-35
http://www.redhat.com/support/errata/RHSA-2003-167.html
(UNKNOWN)  REDHAT  RHSA-2003:167

- 漏洞信息

lv处理配置文件权不当导致限提升漏洞
高危 设计错误
2003-06-09 00:00:00 2005-10-20 00:00:00
本地  
        
        lv是一款强大的文件查看程序,类似less,可以通过编码系统如ISO-8859、ISO-2022、EUC、SJIS Big5、HZ和Unicode对多语言流进行编码和解码。
        lv在读取配置文件时缺少正确检查,本地攻击者可以利用这个漏洞构建恶意配置文件,以其他用户权限执行任意命令。
        lv可以从当前目录的配置文件中读取选项,并可以lv配置选项可以用于执行命令,本地攻击者可以使用这个文件放置到任意他们具有写权限的目录中,任何用户在那个包含恶意配置文件的目录中执行lv,并使用v(edit)命令时可以迫使执行任意命令(可能是root用户权限)。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-304

- 漏洞信息

13400
lv Working Directory .lv File Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-05-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

lv Configuration File Privilege Escalation Vulnerability
Design Error 7613
No Yes
2003-05-16 12:00:00 2009-07-11 10:06:00
Discovery is credited to Leonard Stiles.

- 受影响的程序版本

RedHat lv-4.49.4-9.i386.rpm
+ RedHat Linux 9.0 i386
RedHat lv-4.49.4-7.i386.rpm
+ RedHat Linux 8.0
RedHat lv-4.49.4-3.i386.rpm
+ RedHat Linux 7.3
+ RedHat Linux 7.2
RedHat lv-4.49.4-1.i386.rpm
+ RedHat Linux 7.1
lv lv 4.49.4
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Terra Soft Solutions Yellow Dog Linux 3.0
lv lv 4.49.3
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
lv lv 4.49.2
lv lv 4.49.1
lv lv 4.49.5

- 不受影响的程序版本

lv lv 4.49.5

- 漏洞讨论

The lv multilingual file viewer reads various options from a configuration file located in the current directory. Since this file is accessible by all users, it could be replaced by any unprivileged user. lv options may be used to execute commands, which would be run in the security context of the current user.

- 漏洞利用

There is no exploit code required.

- 解决方案

Debian has released fixed packages for this issue. Download links can be found in the attached advisory (DSA 304-1).

The vendor has fixed this issue in lv 4.49.5. Users are advised to upgrade.


RedHat lv-4.49.4-9.i386.rpm

RedHat lv-4.49.4-1.i386.rpm

RedHat lv-4.49.4-3.i386.rpm

RedHat lv-4.49.4-7.i386.rpm

lv lv 4.49.1

lv lv 4.49.2

lv lv 4.49.3

lv lv 4.49.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站