CVE-2003-0162
CVSS7.5
发布时间 :2003-04-02 00:00:00
修订时间 :2016-10-17 22:30:16
NMCOS    

[原文]Ecartis 1.0.0 (formerly listar) before snapshot 20030227 allows remote attackers to reset passwords of other users and gain privileges by modifying hidden form fields in the HTML page.


[CNNVD]Ecartis隐藏表单字段密码修改漏洞(CNNVD-200304-053)

        
        Ecartis是一款基于WEB的电子商务程序。
        Ecartis不正确处理隐藏的表单内容,远程攻击者可以利用这个漏洞以高权限用户身份登录和修改任意用户密码。
        在以非特权用户登录系统后,Ecartis会让用户更改密码,但是没有要求输入旧的密码,HTML页面把用户名包含在"hidden"字段中,在保存到硬盘后,以其他用户名代替所有"hidden"字段,再次重载页面可以更改其他用户密码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0162
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0162
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-053
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=104636153214262&w=2
(UNKNOWN)  BUGTRAQ  20030227 Ecardis Password Reseting Vulnerability
http://marc.info/?l=bugtraq&m=104673407728323&w=2
(UNKNOWN)  BUGTRAQ  20030303 Re: Ecardis Password Reseting Vulnerability
http://www.debian.org/security/2003/dsa-271
(UNKNOWN)  DEBIAN  DSA-271
http://www.securityfocus.com/bid/6971
(VENDOR_ADVISORY)  BID  6971
http://xforce.iss.net/xforce/xfdb/11431
(VENDOR_ADVISORY)  XF  ecartis-password-reset(11431)

- 漏洞信息

Ecartis隐藏表单字段密码修改漏洞
高危 输入验证
2003-04-02 00:00:00 2005-10-20 00:00:00
远程  
        
        Ecartis是一款基于WEB的电子商务程序。
        Ecartis不正确处理隐藏的表单内容,远程攻击者可以利用这个漏洞以高权限用户身份登录和修改任意用户密码。
        在以非特权用户登录系统后,Ecartis会让用户更改密码,但是没有要求输入旧的密码,HTML页面把用户名包含在"hidden"字段中,在保存到硬盘后,以其他用户名代替所有"hidden"字段,再次重载页面可以更改其他用户密码。
        

- 公告与补丁

        厂商补丁:
        Ecartis
        -------
        建议用户升级到Ecartis Ecartis 1.0 .0 snapshot 20021013版本:
        
        http://www.ecartis.org/

- 漏洞信息

9796
Ecartis HTML Field Manipulation Arbitrary User Password Reset
Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-02-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.0 snapshot 20030227 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Ecartis Hidden Form Field Password Modification Vulnerability
Input Validation Error 6971
Yes No
2003-02-27 12:00:00 2009-07-11 08:06:00
Discovery of this vulnerability credited to Haluk AYDIN <haydin@biznet.com.tr>.

- 受影响的程序版本

Ecartis Ecartis 1.0 .0 snapshot 20021013
Ecartis Ecartis 1.0 .0 snapshot 20030227

- 不受影响的程序版本

Ecartis Ecartis 1.0 .0 snapshot 20030227

- 漏洞讨论

A vulnerability has been reported for Ecartis that may allow attackers to modify passwords.

An attacker can exploit this vulnerability by modifying hidden fields in HTML pages and submitting them. This will allow an attacker to authenticate as a privileged user of Ecartis and modify passwords.

- 漏洞利用

There is no exploit code required.

- 解决方案

The vendor has stated that Ecartis 1.0.0 snapshot dated 20030227 and later are not vulnerable to this issue.

Affected users are advised to upgrade vulnerable versions of Ecartis.

Debian has released fixes for this issue. See the advisory in the References section for links to fixes.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站