CVE-2003-0135
CVSS7.5
发布时间 :2003-04-11 00:00:00
修订时间 :2008-09-10 15:18:02
NMCOS    

[原文]vsftpd FTP daemon in Red Hat Linux 9 is not compiled against TCP wrappers (tcp_wrappers) but is installed as a standalone service, which inadvertently prevents vsftpd from restricting access as intended.


[CNNVD]RedHat Linux 9 vsftpd编译错误漏洞(CNNVD-200304-080)

        
        RedHat是一款免费开放源代码的Linux操作系统。
        RedHat Linux 9中的vsftpd编译不正确,导致vsftpd不能结合tcp_wrappers使用。
        当vsftpd中xinetd运行方式转换为独立服务时,没有针对tcp_wrappers进行正确编译。此漏洞只影响发行在美国的Red Hat Linux 9版本。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:634vsftpd Fails to Integrate with TCP Wrappers
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0135
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0135
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200304-080
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7253
(VENDOR_ADVISORY)  BID  7253
http://www.redhat.com/support/errata/RHSA-2003-084.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:084

- 漏洞信息

RedHat Linux 9 vsftpd编译错误漏洞
高危 配置错误
2003-04-11 00:00:00 2005-10-20 00:00:00
远程  
        
        RedHat是一款免费开放源代码的Linux操作系统。
        RedHat Linux 9中的vsftpd编译不正确,导致vsftpd不能结合tcp_wrappers使用。
        当vsftpd中xinetd运行方式转换为独立服务时,没有针对tcp_wrappers进行正确编译。此漏洞只影响发行在美国的Red Hat Linux 9版本。
        

- 公告与补丁

        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2003:084-01)以及相应补丁:
        RHSA-2003:084-01:Updated vsftpd packages re-enable tcp_wrappers support
        链接:https://www.redhat.com/support/errata/RHSA-2003-084.html
        补丁下载:
        RedHat Linux 9.0 i386:
        Red Hat Upgrade vsftpd-1.1.3-8.i386.rpm
        ftp://updates.redhat.com/9/en/os/i386/vsftpd-1.1.3-8.i386.rpm

- 漏洞信息

4564
vsftpd on Red Hat Linux Restricted Access Failure

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-04-01 Unknow
2003-04-01 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Red Hat Linux 9 vsftpd Compiling Error Weakness
Configuration Error 7253
Yes No
2003-04-01 12:00:00 2009-07-11 09:06:00
This issue was announced by the vendor.

- 受影响的程序版本

RedHat Linux 9.0 i386

- 漏洞讨论

Red Hat Linux 9 contains a version of vsftpd that was improperly compiled. When vsftpd was switched to being a standalone service, it was not compiled against tcp_wrappers.

This issue only affects Red Hat Linux 9 boxed sets that were manufactured for sale in the United States.

- 漏洞利用

There is no exploit code required.

- 解决方案

Red Hat has released a fix:


RedHat Linux 9.0 i386

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站