CVE-2003-0133
CVSS5.0
发布时间 :2003-05-05 00:00:00
修订时间 :2008-09-10 15:18:02
NMCOS    

[原文]GtkHTML, as included in Evolution before 1.2.4, allows remote attackers to cause a denial of service (crash) via certain malformed messages.


[CNNVD]GTKHTML Malformed HTML文件服务拒绝漏洞(CNNVD-200305-010)

        包含在Evolution 1.2.4之前版本的GtkHTML存在漏洞。远程攻击者可以借助某个畸形消息导致服务拒绝(崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnome:gtkhtml:1.1.10
cpe:/a:gnome:gtkhtml:1.1.9

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:138Evolution GtkHTML DoS via Malformed Message
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0133
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0133
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200305-010
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2003-126.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:126
http://www.mandriva.com/security/advisories?name=MDKSA-2003:046
(UNKNOWN)  MANDRAKE  MDKSA-2003:046
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000737
(UNKNOWN)  CONECTIVA  CLA-2003:737

- 漏洞信息

GTKHTML Malformed HTML文件服务拒绝漏洞
中危 其他
2003-05-05 00:00:00 2005-10-20 00:00:00
远程  
        包含在Evolution 1.2.4之前版本的GtkHTML存在漏洞。远程攻击者可以借助某个畸形消息导致服务拒绝(崩溃)。

- 公告与补丁

        This issue has been addressed in the GtkHTML component that is included in Evolution 1.2.4. Evolution users are advised to upgrade.
        Red Hat has released a security advisory (RHSA-2003:264-01) that states the previous security advisory (RHSA-2003:126-06) as obsolete. New fixes have been made available in this advisory and users are advised to upgrade as soon as possible.
        Conectiva has released a security advisory (CLSA-2003:737) containing fixes to address this issue.
        Mandrake has released a security advisory (MDKSA-2003:093) containing updated fixes to address this issue.
        Debian Linux has released advisory DSA 710-1 addressing this issue. Please see the referenced advisory for details on obtaining and applying fixes.
        Fixes are available:
        GNOME GtkHTML 1.0.1
        
        GNOME GtkHTML 1.0.2
        

- 漏洞信息

12648
Evolution GtkHtml Malformed Mail Message DoS
Denial of Service
Loss of Availability

- 漏洞描述

- 时间线

2003-03-13 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GTKHTML Malformed HTML Document Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 7350
Yes No
2003-04-14 12:00:00 2009-07-11 09:06:00
Discovery of this issue is credited to Alan Cox.

- 受影响的程序版本

GNOME GtkHTML 1.1.10
+ Ximian Evolution 1.2.3
+ Ximian Evolution 1.2.2
+ Ximian Evolution 1.2.1
+ Ximian Evolution 1.2
+ Ximian Evolution 1.1.1
GNOME GtkHTML 1.1.9
+ Conectiva Linux 9.0
+ Ximian Evolution 1.2.3
+ Ximian Evolution 1.2.2
+ Ximian Evolution 1.2.1
+ Ximian Evolution 1.2
+ Ximian Evolution 1.1.1
GNOME GtkHTML 1.0.4
+ RedHat Linux 8.0
GNOME GtkHTML 1.0.2
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ RedHat Linux 7.3
GNOME GtkHTML 1.0.1
+ Conectiva Linux 8.0
+ Conectiva Linux 7.0

- 漏洞讨论

It has been reported that GtkHTML is prone to a vulnerability which may be exploited to cause a denial of service. This issue is present in GtkHTML with Evolution. It is possible to crash Evolution with a malformed message due to this flaw in GtkHTML.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

This issue has been addressed in the GtkHTML component that is included in Evolution 1.2.4. Evolution users are advised to upgrade.

Red Hat has released a security advisory (RHSA-2003:264-01) that states the previous security advisory (RHSA-2003:126-06) as obsolete. New fixes have been made available in this advisory and users are advised to upgrade as soon as possible.

Conectiva has released a security advisory (CLSA-2003:737) containing fixes to address this issue.

Mandrake has released a security advisory (MDKSA-2003:093) containing updated fixes to address this issue.

Debian Linux has released advisory DSA 710-1 addressing this issue. Please see the referenced advisory for details on obtaining and applying fixes.

Fixes are available:


GNOME GtkHTML 1.0.1

GNOME GtkHTML 1.0.2

GNOME GtkHTML 1.0.4

GNOME GtkHTML 1.1.10

GNOME GtkHTML 1.1.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站