CVE-2003-0104
CVSS5.0
发布时间 :2003-03-18 00:00:00
修订时间 :2008-09-05 16:33:29
NMCOS    

[原文]Directory traversal vulnerability in PeopleTools 8.10 through 8.18, 8.40, and 8.41 allows remote attackers to overwrite arbitrary files via the SchedulerTransfer servlet.


[CNNVD]PeopleSoft PeopleTools SchedulerTransfer远程命令执行漏洞(CNNVD-200303-063)

        
        PeopleSoft企业软件集成多个商务功能,包括人事、客户关系、供求关系、财务等管理。PeopleSoft应用程序架构包括一个基于WEB服务器的报告库,"SchedulerTransfer" Java Servlet用于使用HTTP或者HTTPS传输协议把报告移到报告库中。
        "SchedulerTransfer" Java Servlet没有充分检查外部提供的数据,远程攻击者利用这个漏洞以WEB服务进程权限在系统上写恶意文件或覆盖已知文件并执行。
        "SchedulerTransfer" Servlet在PeopleSoft web服务器上默认配置运行,其中包含文件上传代码可处理通过HTTP POST请求提交的文件,默认没有任何验证措施来限制用户对Servlet的访问或限制用这个方法来上传文件。虽然程序对路径分隔字符有一定的安全检查,但是由于检查不完整,攻击者可以利用这个目录遍历检查不完整漏洞,来在指定上传目录之外建立或覆盖任意文件,覆盖知名Java程序就可以通过直接访问来执行。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:peoplesoft:peopletools:8.40
cpe:/a:peoplesoft:peopletools:8.13
cpe:/a:peoplesoft:peopletools:8.16
cpe:/a:peoplesoft:peopletools:8.12
cpe:/a:peoplesoft:peopletools:8.18
cpe:/a:peoplesoft:peopletools:8.17
cpe:/a:peoplesoft:peopletools:8.10
cpe:/a:peoplesoft:peopletools:8.14
cpe:/a:peoplesoft:peopletools:8.15
cpe:/a:peoplesoft:peopletools:8.11
cpe:/a:peoplesoft:peopletools:8.41

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0104
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0104
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-063
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7053
(VENDOR_ADVISORY)  BID  7053
http://www.iss.net/security_center/static/10962.php
(VENDOR_ADVISORY)  XF  peoplesoft-schedulertransfer-create-files(10962)
http://www.iss.net/issEn/delivery/xforce/alertdetail.jsp?oid=21999
(VENDOR_ADVISORY)  ISS  20030310 PeopleSoft PeopleTools Remote Command Execution Vulnerability

- 漏洞信息

PeopleSoft PeopleTools SchedulerTransfer远程命令执行漏洞
中危 输入验证
2003-03-18 00:00:00 2005-05-13 00:00:00
远程  
        
        PeopleSoft企业软件集成多个商务功能,包括人事、客户关系、供求关系、财务等管理。PeopleSoft应用程序架构包括一个基于WEB服务器的报告库,"SchedulerTransfer" Java Servlet用于使用HTTP或者HTTPS传输协议把报告移到报告库中。
        "SchedulerTransfer" Java Servlet没有充分检查外部提供的数据,远程攻击者利用这个漏洞以WEB服务进程权限在系统上写恶意文件或覆盖已知文件并执行。
        "SchedulerTransfer" Servlet在PeopleSoft web服务器上默认配置运行,其中包含文件上传代码可处理通过HTTP POST请求提交的文件,默认没有任何验证措施来限制用户对Servlet的访问或限制用这个方法来上传文件。虽然程序对路径分隔字符有一定的安全检查,但是由于检查不完整,攻击者可以利用这个目录遍历检查不完整漏洞,来在指定上传目录之外建立或覆盖任意文件,覆盖知名Java程序就可以通过直接访问来执行。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 如果WEB服务器不使用报告库,SchedulerTransfer servlet将被关闭使用。
        * BEA WebLogic可以通过如下的配置来限制对servlet的访问,在'weblogic.properties'文件中增加如下条目:
        weblogic.httpd.register.servlets/SchedulerTransfer=SchedulerTransfer
        weblogic.allow.execute.weblogic.servlet.servlets/SchedulerTransfer=system
        * IBM WebSpher可以通过在"Configure Application Security"菜单中限制对SchedulerTransfer的访问来暂时修补此漏洞。
        厂商补丁:
        PeopleSoft
        ----------
        PeopleSoft已经发布了PeopleTools 8.19和8.42修正了此漏洞,PeopleTools 8.18.06和8.41.05版本的补丁也已经提供,用户可以联系供应商获得这些补丁:
        
        http://www.peoplesoft.com/corp/en/products/technology/ptools/index.asp

- 漏洞信息

6196
PeopleTools SchedulerTransfer Servlet Arbitrary File Overwrite
Input Manipulation
Loss of Integrity Patch / RCS, Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-03-10 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PeopleSoft PeopleTools SchedulerTransfer Remote Command Execution Vulnerability
Input Validation Error 7053
Yes No
2003-03-10 12:00:00 2009-07-11 09:06:00
Discovery of this issue is credited to Neel Mehta of ISS X-Force.

- 受影响的程序版本

PeopleSoft PeopleTools 8.41
PeopleSoft PeopleTools 8.40
PeopleSoft PeopleTools 8.18
PeopleSoft PeopleTools 8.17
PeopleSoft PeopleTools 8.16
PeopleSoft PeopleTools 8.15
PeopleSoft PeopleTools 8.14
PeopleSoft PeopleTools 8.13
PeopleSoft PeopleTools 8.12
PeopleSoft PeopleTools 8.11
PeopleSoft PeopleTools 8.10
PeopleSoft PeopleTools 8.42
PeopleSoft PeopleTools 8.19

- 不受影响的程序版本

PeopleSoft PeopleTools 8.42
PeopleSoft PeopleTools 8.19

- 漏洞讨论

A remote command execution vulnerability exists in the PeopleSoft PeopleTools "SchedulerTransfer" servlet. This issue occurs because the servlet does not sufficiently validate externally supplied data. Exploitation may allow malicious files to be written to the system hosting the software and executed with the privileges of the web server.

- 漏洞利用

There is no exploit required.

- 解决方案

PeopleSoft has addressed this issue in PeopleTools 8.19 and 8.42. Patches have also been released for PeopleTools 8.18.06 and 8.41.05. Users should contact the vendor for further details on obtaining fixes.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站