CVE-2003-0098
CVSS10.0
发布时间 :2003-03-03 00:00:00
修订时间 :2008-09-10 15:17:55
NMCOS    

[原文]Unknown vulnerability in apcupsd before 3.8.6, and 3.10.x before 3.10.5, allows remote attackers to gain root privileges, possibly via format strings in a request to a slave server.


[CNNVD]APC apcupsd客户端syslog格式化串溢出漏洞(CNNVD-200303-025)

        
        apcupsd是一款不间断电源相关守护进程。
        apcupsd客户端存在格式化串漏洞,本地攻击者可以利用这个漏洞以apcupsd进程权限在系统上执行任意指令。
        由于apcupsd客户端中的'log_event'程序设计错误,攻击者可以提交恶意格式串而破坏堆栈内容,精心提交格式串数据可能以apcupsd进程权限在系统上执行任意指令。
        目前详细漏洞细节没有提供。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:apc:apcupsd:3.8.5
cpe:/a:apc:apcupsd:3.10.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0098
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0098
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-025
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-277
(VENDOR_ADVISORY)  DEBIAN  DSA-277
http://www.securityfocus.com/bid/7200
(UNKNOWN)  BID  7200
http://www.novell.com/linux/security/advisories/2003_022_apcupsd.html
(UNKNOWN)  SUSE  SuSE-SA:2003:022
http://www.iss.net/security_center/static/11334.php
(UNKNOWN)  XF  apcupsd-logevent-format-string(11334)
http://sourceforge.net/project/shownotes.php?release_id=137900
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=137900
http://securitytracker.com/id?1006108
(UNKNOWN)  SECTRACK  1006108
http://hsj.shadowpenguin.org/misc/apcupsd_exp.txt
(UNKNOWN)  MISC  http://hsj.shadowpenguin.org/misc/apcupsd_exp.txt
http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/apcupsd/apcupsd/src/apcnisd.c.diff?r1=1.5&r2=1.6
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/apcupsd/apcupsd/src/apcnisd.c.diff?r1=1.5&r2=1.6
ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2003-015.0.txt
(UNKNOWN)  CALDERA  CSSA-2003-015.0
http://www.securityfocus.com/bid/6828
(UNKNOWN)  BID  6828
http://www.mandriva.com/security/advisories?name=MDKSA-2003:018
(UNKNOWN)  MANDRAKE  MDKSA-2003:018

- 漏洞信息

APC apcupsd客户端syslog格式化串溢出漏洞
危急 边界条件错误
2003-03-03 00:00:00 2005-10-20 00:00:00
远程  
        
        apcupsd是一款不间断电源相关守护进程。
        apcupsd客户端存在格式化串漏洞,本地攻击者可以利用这个漏洞以apcupsd进程权限在系统上执行任意指令。
        由于apcupsd客户端中的'log_event'程序设计错误,攻击者可以提交恶意格式串而破坏堆栈内容,精心提交格式串数据可能以apcupsd进程权限在系统上执行任意指令。
        目前详细漏洞细节没有提供。
        

- 公告与补丁

        厂商补丁:
        APC
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        APC Upgrade apcupsd-3.8.6.tar.gz
        
        http://prdownloads.sourceforge.net/apcupsd/apcupsd-3.8.6.tar.gz?download

- 漏洞信息

10748
APC apcupsd Slave Server Request Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-02-15 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

APC apcupsd Multiple Buffer Overflow Vulnerabilities
Boundary Condition Error 7200
Yes No
2003-02-04 12:00:00 2009-07-11 09:06:00
These vulnerabilities were announced by the vendor.

- 受影响的程序版本

APC apcupsd 3.8.6
APC apcupsd 3.8.5
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1
+ Caldera OpenLinux Workstation 3.1.1
+ Caldera OpenLinux Workstation 3.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Mandriva Linux Mandrake 9.0
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ Mandriva Linux Mandrake 8.1 ia64
+ Mandriva Linux Mandrake 8.1
+ S.u.S.E. Linux 8.1
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
APC apcupsd 3.8.2
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3 i386
+ S.u.S.E. Linux 7.3
APC apcupsd 3.10.5
APC apcupsd 3.8.6

- 不受影响的程序版本

APC apcupsd 3.10.5
APC apcupsd 3.8.6

- 漏洞讨论

Apcupsd provides UPS power management under Linux and BSD systems for APC Products.

Several buffer overflow vulnerabilities have been reported for apcupsd client. Exploitation of these vulnerabilities may result in an attacker obtaining elevated privileges on the vulnerable system or code execution.

Further details are currently unknown. This BID will be updated as more information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Gentoo Linux has released an advisory. Users who have installed sys-apps/apcupsd are advised to upgrade to apcupsd-3.10.5 by issuing the following commands:

emerge sync
emerge -u apcupsd
emerge clean

SCO has released Linux advisory CSSA-2003-015.0 to address this issue.

The vendor has addressed this issue in the latest version of apcupsd.

Fixes available:


APC apcupsd 3.8.2

APC apcupsd 3.8.5

APC apcupsd 3.8.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站