CVE-2003-0097
CVSS7.5
发布时间 :2003-03-03 00:00:00
修订时间 :2016-10-17 22:29:28
NMCO    

[原文]Unknown vulnerability in CGI module for PHP 4.3.0 allows attackers to access arbitrary files as the PHP user, and possibly execute PHP code, by bypassing the CGI force redirect settings (cgi.force_redirect or --enable-force-cgi-redirect).


[CNNVD]PHP CGI SAPI代码执行漏洞(CNNVD-200303-030)

        PHP 4.3.0的CGI模块存在未知漏洞。攻击者可以通过绕过CGI强制重定向设置(cgi.force_redirect或--enable-force-cgi-redirect),以PHP用户的身份访问任意文件,并且可能执行PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0097
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0097
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-030
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=104550977011668&w=2
(UNKNOWN)  BUGTRAQ  20030217 PHP Security Advisory: CGI vulnerability in PHP version 4.3.0
http://marc.info/?l=bugtraq&m=104567042700840&w=2
(UNKNOWN)  GENTOO  GLSA-200302-09
http://marc.info/?l=bugtraq&m=104567137502557&w=2
(UNKNOWN)  GENTOO  GLSA-200302-09.1
http://www.iss.net/security_center/static/11343.php
(VENDOR_ADVISORY)  XF  php-cgi-sapi-access(11343)
http://www.securityfocus.com/bid/6875
(UNKNOWN)  BID  6875
http://www.slackware.com/changelog/current.php?cpu=i386
(UNKNOWN)  CONFIRM  http://www.slackware.com/changelog/current.php?cpu=i386

- 漏洞信息

PHP CGI SAPI代码执行漏洞
高危 未知
2003-03-03 00:00:00 2005-05-13 00:00:00
远程  
        PHP 4.3.0的CGI模块存在未知漏洞。攻击者可以通过绕过CGI强制重定向设置(cgi.force_redirect或--enable-force-cgi-redirect),以PHP用户的身份访问任意文件,并且可能执行PHP代码。

- 公告与补丁

        Gentoo Linux users who are running 'dev-php/mod_php' have been recommended to upgrade to 'mod_php-4.3.1' as follows:
        emerge sync
        emerge -u mod_php
        emerge clean
        OpenPKG has made fixes available. See referenced advisory for additional details.
        This issue has been fixed in PHP version 4.3.1:
        PHP PHP 4.3
        

- 漏洞信息

13492
PHP CGI Module Force Redirect Settings Bypass Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-02-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站