发布时间 :2003-03-31 00:00:00
修订时间 :2008-09-05 16:33:25

[原文]The iptables ruleset in Gnome-lokkit in Red Hat Linux 8.0 does not include any rules in the FORWARD chain, which could allow attackers to bypass intended access restrictions if packet forwarding is enabled.

[CNNVD]Gnome-lokkit Iptables未设置转发链规则漏洞(CNNVD-200303-097)

        Redhat的Gnome-lokkit在配置转发链(FORWARD chain)上存在问题,根据系统配置情况会产生多个不同漏洞。
        Red Hat修改了Gnome-lokkit支持基于iptables防火墙,在Red Hat Linux 8.0中,由Gnome-lokkit建立的iptables规则没有对FORWARD链进行规则设置,如果管理员使用了包转发功能就可能导致一些安全问题。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  gnomelokkit-forward-bypass-firewall(11552)

- 漏洞信息

Gnome-lokkit Iptables未设置转发链规则漏洞
高危 设计错误
2003-03-31 00:00:00 2005-10-20 00:00:00
        Redhat的Gnome-lokkit在配置转发链(FORWARD chain)上存在问题,根据系统配置情况会产生多个不同漏洞。
        Red Hat修改了Gnome-lokkit支持基于iptables防火墙,在Red Hat Linux 8.0中,由Gnome-lokkit建立的iptables规则没有对FORWARD链进行规则设置,如果管理员使用了包转发功能就可能导致一些安全问题。

- 公告与补丁

        RHSA-2003:072-08:Updated Gnome-lokkit packages fix vulnerability
        Red Hat Linux 8.0:
        rpm -Fvh [文件名]

- 漏洞信息

Gnome-Lokkit Firewall FORWARD chain bypass
Remote / Network Access Other
Loss of Integrity
Exploit Unknown

- 漏洞描述

Gnome-Lokkit Firewall contains a flaw that may allow a remote attacker to bypass the firewall rules. The issue is due to no rules being set for the FORWARD chain. If paket forwarding is enabled, a remote attacker may be able to send specially crafted traffic that bypasses configured rules.

- 时间线

2003-03-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.50-21.8.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gnome-lokkit Iptables No Forward Chain Rule Vulnerability
Design Error 7128
Yes No
2003-03-17 12:00:00 2009-07-11 09:06:00
This vulnerability was disclosed by the vendor.

- 受影响的程序版本

GNOME Gnome-lokkit 0.50 -21
+ RedHat Linux 8.0 i386
+ RedHat Linux 8.0

- 漏洞讨论

Gnome-lokkit has been reported prone to a condition where FORWARD chains in iptables rulesets are not configured by default. This situation may result in a variety of security vulnerabilities depending on system configuration.

This vulnerability was reported to affect a modified version of Gnome-lokkit for Red Hat Linux 8.0. Previous versions of Gnome-lokkit are not reported to be affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

Red Hat Linux has released an advisory (RHSA-2003:072-00) and fixes that address this issue.

Fixes available:

GNOME Gnome-lokkit 0.50 -21

- 相关参考