CVE-2003-0053
CVSS4.3
发布时间 :2003-03-07 00:00:00
修订时间 :2016-10-17 22:28:51
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in parse_xml.cgi in Apple Darwin Streaming Administration Server 4.1.2 and QuickTime Streaming Server 4.1.1 allows remote attackers to insert arbitrary script via the filename parameter, which is inserted into an error message.


[CNNVD]Apple Quicktime/Darwin流服务器parse_xml.cgi跨站脚本执行漏洞(CNNVD-200303-042)

        
        Apple Darwin和QuickTime流管理服务器是基于WEB的服务,允许管理员管理Darwin和QuickTime流服务器,默认情况下,这些服务以ROOT权限监听1220/TCP端口。
        Darwin/QuickTime流服务器的parse_xml.cgi对不存在文件名参数过滤不充分,远程攻击者可以利用这个漏洞进行跨站脚本执行攻击,可能获得目标用户敏感信息。
        攻击者如果传递不存在的文件名参数提交给parse_xml.cgi脚本,可导致脚本产生错误消息并记录,如果攻击者提供的参数包含恶意脚本代码,当管理员通过WEB浏览器查看日志的时候可使脚本代码在浏览器上执行。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:apple:quicktime_streaming_server:4.1.1Apple Quicktime Streaming Server 4.1.1
cpe:/a:apple:darwin_streaming_server:4.1.2Apple Darwin Streaming Server 4.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0053
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0053
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-042
(官方数据源) CNNVD

- 其它链接及资源

http://lists.apple.com/archives/security-announce/2003/Feb/25/applesa20030225macosx102.txt
(UNKNOWN)  CONFIRM  http://lists.apple.com/archives/security-announce/2003/Feb/25/applesa20030225macosx102.txt
http://marc.info/?l=bugtraq&m=104618904330226&w=2
(UNKNOWN)  BUGTRAQ  20030224 QuickTime/Darwin Streaming Administration Server Multiple vulnerabilities
http://www.iss.net/security_center/static/11404.php
(VENDOR_ADVISORY)  XF  quicktime-darwin-parsexml-xss(11404)
http://www.securityfocus.com/bid/6958
(UNKNOWN)  BID  6958

- 漏洞信息

Apple Quicktime/Darwin流服务器parse_xml.cgi跨站脚本执行漏洞
中危 输入验证
2003-03-07 00:00:00 2005-05-13 00:00:00
远程  
        
        Apple Darwin和QuickTime流管理服务器是基于WEB的服务,允许管理员管理Darwin和QuickTime流服务器,默认情况下,这些服务以ROOT权限监听1220/TCP端口。
        Darwin/QuickTime流服务器的parse_xml.cgi对不存在文件名参数过滤不充分,远程攻击者可以利用这个漏洞进行跨站脚本执行攻击,可能获得目标用户敏感信息。
        攻击者如果传递不存在的文件名参数提交给parse_xml.cgi脚本,可导致脚本产生错误消息并记录,如果攻击者提供的参数包含恶意脚本代码,当管理员通过WEB浏览器查看日志的时候可使脚本代码在浏览器上执行。
        

- 公告与补丁

        厂商补丁:
        Apple
        -----
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Apple Quicktime Streaming Server 4.1.1:
        Apple Upgrade MacOSXServerUpdate10.2.4.dmg
        
        http://docs.info.apple.com/article.html?artnum=70171#English

        Apple Darwin Streaming Server 4.1.2:
        Apple Upgrade MacOSXServerUpdate10.2.4.dmg
        
        http://docs.info.apple.com/article.html?artnum=70171#English

- 漏洞信息

9198
Apple Streaming Servers parse_xml.cgi filename Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Darwin Streaming Server and Quicktime Streaming Server contain a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the filename variable upon submission to the parse_xml.cgi script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-02-24 Unknow
2003-02-24 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Apple QuickTime/Darwin Streaming Server Parse_XML.CGI Cross-Site Scripting Vulnerability
Input Validation Error 6958
Yes No
2003-02-24 12:00:00 2009-07-11 08:06:00
The discovery of this vulnerability has been credited to Ollie Whitehouse from @stake.

- 受影响的程序版本

Apple Quicktime Streaming Server 4.1.1
Apple Darwin Streaming Server 4.1.2

- 漏洞讨论

The Apple QuickTime/Darwin Streaming Server is prone to cross-site scripting attacks. When an invalid filename is specified from this page, it is output to an error page without sufficient sanitization of HTML and script code. This may permit cross-site scripting attacks to occur if an attacker constructs a malicious link to the page and can entice web users to visit it.

- 漏洞利用

There is no exploit required.

- 解决方案

Apple has released an update which addresses this issue:


Apple Quicktime Streaming Server 4.1.1

Apple Darwin Streaming Server 4.1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站