CVE-2003-0038
CVSS4.3
发布时间 :2003-02-07 00:00:00
修订时间 :2016-10-17 22:28:39
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.


[CNNVD]Mailman options.py跨站脚本(XSS)漏洞(CNNVD-200302-011)

        Mailman 2.1中options.py存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1) email或者(2) language参数向网页中注入脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0038
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0038
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200302-011
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=104342745916111
(UNKNOWN)  BUGTRAQ  20030124 Mailman: cross-site scripting bug
http://telia.dl.sourceforge.net/sourceforge/mailman/xss-2.1.0-patch.txt
(PATCH)  CONFIRM  http://telia.dl.sourceforge.net/sourceforge/mailman/xss-2.1.0-patch.txt
http://www.debian.org/security/2004/dsa-436
(VENDOR_ADVISORY)  DEBIAN  DSA-436
http://www.securityfocus.com/bid/6677
(UNKNOWN)  BID  6677
http://www.securitytracker.com/id?1005987
(UNKNOWN)  SECTRACK  1005987
http://xforce.iss.net/xforce/xfdb/11152
(UNKNOWN)  XF  mailman-email-variable-xss(11152)

- 漏洞信息

Mailman options.py跨站脚本(XSS)漏洞
中危 跨站脚本
2003-02-07 00:00:00 2005-10-20 00:00:00
远程  
        Mailman 2.1中options.py存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1) email或者(2) language参数向网页中注入脚本或者HTML。

- 公告与补丁

        

- 漏洞信息 (22198)

GNU Mailman 2.1 'email' Cross Site Scripting Vulnerability (EDBID:22198)
cgi webapps
2003-01-24 Verified
0 webmaster@procheckup.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/6677/info

A vulnerability has been discovered in GNU Mailman. It has been reported that Mailman is prone to cross site scripting attacks. This is due to insufficient santization of URI parameters.


As a result, attackers may embed malicious script code or HTML into a link to a site running the vulnerable software. If such a link is followed, the attacker-supplied code will be interpreted in the web browser of the victim of the attack. It may be possible to steal the unsuspecting user's cookie-based authentication credentials, as well as other sensitive information. Other attacks are also possible.

https://www.yourserver.com:443/mailman/options/yourlist?
language=en&email=<SCRIPT>alert('Can%20Cross%20Site%20Attack')</SCRIPT>		

- 漏洞信息 (22199)

GNU Mailman 2.1 Error Page Cross Site Scripting Vulnerability (EDBID:22199)
cgi webapps
2003-01-24 Verified
0 webmaster@procheckup.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/6678/info

A vulnerability has been discovered in GNU Mailman. The issue occurs to insufficient sanitization of user-supplied data which is output when generating error pages.

As a result, attackers may embed malicious script code or HTML into a link to a site running the vulnerable software. If such a link is followed, the attacker-supplied code will be interpreted in the web browser of the victim of the attack. It may be possible to steal the unsuspecting user's cookie-based authentication credentials, as well as other sensitive information. Other attacks are also possible.

It has been reported that GNU Mailman 2.0.11 is not affected by this issue.

https://www.yourserver.com:443//mailman/options/yourlist?
language=<SCRIPT>alert('Can%20Cross%20Site%20Attack')</SCRIPT>		

- 漏洞信息

9205
Mailman options.py email Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Mailman contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the email variable upon submission to the options.py script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-01-24 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站