CVE-2003-0037
CVSS7.5
发布时间 :2003-02-07 00:00:00
修订时间 :2008-09-10 20:05:25
NMCOS    

[原文]Buffer overflows in noffle news server 1.0.1 and earlier allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code.


[CNNVD]Noffle远程内存破坏漏洞(CNNVD-200302-005)

        
        noffle是一款开放源代码离线新闻服务程序。
        noffle存在不明漏洞,远程攻击者可以利用这个漏洞以服务进程权限在系统上执行任意代码或进行拒绝服务攻击。
        目前没有详细漏洞细节描述。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0037
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0037
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200302-005
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2003/dsa-244
(VENDOR_ADVISORY)  DEBIAN  DSA-244
http://xforce.iss.net/xforce/xfdb/11181
(UNKNOWN)  XF  noffle-multiple-bo(11181)
http://www.securityfocus.com/bid/6695
(UNKNOWN)  BID  6695
http://secunia.com/advisories/7955
(UNKNOWN)  SECUNIA  7955

- 漏洞信息

Noffle远程内存破坏漏洞
高危 边界条件错误
2003-02-07 00:00:00 2005-10-20 00:00:00
远程  
        
        noffle是一款开放源代码离线新闻服务程序。
        noffle存在不明漏洞,远程攻击者可以利用这个漏洞以服务进程权限在系统上执行任意代码或进行拒绝服务攻击。
        目前没有详细漏洞细节描述。
        

- 公告与补丁

        厂商补丁:
        Noffle
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Noffle Noffle 1.0.1:
        Debian Upgrade noffle_1.0.1-1.1_alpha.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_alpha.deb

        Debian Upgrade noffle_1.0.1-1.1_arm.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_arm.deb

        Debian Upgrade noffle_1.0.1-1.1_i386.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_i386.deb

        Debian Upgrade noffle_1.0.1-1.1_ia64.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_ia64.deb

        Debian Upgrade noffle_1.0.1-1.1_hppa.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_hppa.deb

        Debian Upgrade noffle_1.0.1-1.1_m68k.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_m68k.deb

        Debian Upgrade noffle_1.0.1-1.1_mips.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_mips.deb

        Debian Upgrade noffle_1.0.1-1.1_mipsel.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_mipsel.deb

        Debian Upgrade noffle_1.0.1-1.1_powerpc.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_powerpc.deb

        Debian Upgrade noffle_1.0.1-1.1_s390.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_s390.deb

        Debian Upgrade noffle_1.0.1-1.1_sparc.deb
        
        http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_sparc.deb

        补丁安装方法:
        1. 手工安装补丁包:
         首先,使用下面的命令来下载补丁软件:
         # wget url (url是补丁下载链接地址)
         然后,使用下面的命令来安装补丁:
         # dpkg -i file.deb (file是相应的补丁名)
        2. 使用apt-get自动安装补丁包:
         首先,使用下面的命令更新内部数据库:
         # apt-get update
        
         然后,使用下面的命令安装更新软件包:
         # apt-get upgrade

- 漏洞信息

13487
Noffle News Server Multiple Unspecified Overflows
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-01-27 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Noffle Remote Memory Corruption Vulnerability
Boundary Condition Error 6695
Yes No
2003-01-27 12:00:00 2009-07-11 08:06:00
The discovery of this issue has been credited to Dan Jacobson.

- 受影响的程序版本

Noffle Noffle 1.0.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

A memory corruption bug has been discovered in Noffle. The issue can be triggered remotely and may cause a segmentation violation in the affected server.

Although unconfirmed, this issue may be exploitable by a remote attacker to trigger a denial of service or possibly execute arbitrary code.

The technical details regarding this issue are currently unknown. This BID will be updated when further information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released a security advisory (DSA 244-1) containing fixes. Users are advised to upgrade as soon as possible.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


Noffle Noffle 1.0.1

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站