CVE-2003-0031
CVSS7.5
发布时间 :2003-01-17 00:00:00
修订时间 :2016-10-17 22:28:36
NMCOS    

[原文]Multiple buffer overflows in libmcrypt before 2.5.5 allow attackers to cause a denial of service (crash).


[CNNVD]Libmcrypt多个远程缓冲区溢出漏洞(CNNVD-200301-031)

        
        limbcrypt是一款可代替标准UNIX crypt()的加密相关模块,可动态装载。
        limbcrypt由于缺少正确的输入检查,远程攻击者可以利用这个漏洞向多个不同函数提交超长参数,可使libmcrypt崩溃,可能以目标进程权限在系统上执行任意指令。
        目前没有提供详细漏洞细节。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:mcrypt:libmcrypt:2.5.1_r4
cpe:/a:mcrypt:libmcrypt:2.5.3
cpe:/a:mcrypt:libmcrypt:2.5_.0
cpe:/a:mcrypt:libmcrypt:2.5.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0031
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0031
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200301-031
(官方数据源) CNNVD

- 其它链接及资源

http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000567
(UNKNOWN)  CONECTIVA  CLA-2003:567
http://marc.info/?l=bugtraq&m=104162752401212&w=2
(UNKNOWN)  BUGTRAQ  20030103 Multiple libmcrypt vulnerabilities
http://marc.info/?l=bugtraq&m=104188513728573&w=2
(UNKNOWN)  BUGTRAQ  20030105 GLSA: libmcrypt
http://www.debian.org/security/2003/dsa-228
(VENDOR_ADVISORY)  DEBIAN  DSA-228
http://www.securityfocus.com/bid/6510
(UNKNOWN)  BID  6510
http://www.securitytracker.com/id?1006181
(UNKNOWN)  SECTRACK  1006181

- 漏洞信息

Libmcrypt多个远程缓冲区溢出漏洞
高危 边界条件错误
2003-01-17 00:00:00 2005-10-20 00:00:00
远程  
        
        limbcrypt是一款可代替标准UNIX crypt()的加密相关模块,可动态装载。
        limbcrypt由于缺少正确的输入检查,远程攻击者可以利用这个漏洞向多个不同函数提交超长参数,可使libmcrypt崩溃,可能以目标进程权限在系统上执行任意指令。
        目前没有提供详细漏洞细节。
        

- 公告与补丁

        厂商补丁:
        Mcrypt
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Mcrypt Upgrade libmcrypt 2.5.5
        
        http://mcrypt.hellug.gr/lib/index.html

- 漏洞信息

9684
libmcrypt Multiple Unspecified Overflow DoS
Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-01-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Libmcrypt Multiple Buffer Overrun Vulnerabilities
Boundary Condition Error 6510
Yes No
2003-01-03 12:00:00 2009-07-11 07:17:00
The discovery of this vulnerability is credited to "Ilia A." <ilia@prohost.org>.

- 受影响的程序版本

Mcrypt libmcrypt 2.5.3
Mcrypt libmcrypt 2.5.2
+ S.u.S.E. Linux 8.1
Mcrypt libmcrypt 2.5.1 -r4
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
Mcrypt libmcrypt 2.5 .0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
Mcrypt libmcrypt 2.4.20
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
Mcrypt libmcrypt 2.4.18
+ Conectiva Linux 8.0
Mcrypt libmcrypt 2.4.15
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3 i386
+ S.u.S.E. Linux 7.3
Mcrypt libmcrypt 2.4.10
+ S.u.S.E. Linux 7.2 i386
+ S.u.S.E. Linux 7.2
Mcrypt libmcrypt 2.4.9
+ Conectiva Linux 7.0
Mcrypt libmcrypt 2.4.7
+ S.u.S.E. Linux 7.1 x86
+ S.u.S.E. Linux 7.1 ppc
+ S.u.S.E. Linux 7.1 alpha
+ S.u.S.E. Linux 7.1
Mcrypt libmcrypt 2.5.5

- 不受影响的程序版本

Mcrypt libmcrypt 2.5.5

- 漏洞讨论

Multiple vulnerabilities have been discovered in libmcrypt. Various functions used to process user-supplied input are prone to buffer overrun conditions. This is due to insufficient bounds checking of user-supplied input. By exploiting this issue to overwrite sensitive locations in memory it may be possible to execute arbitrary commands with the privileges of the target process.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has identified the issues and has released an updated version which addresses the vulnerabilities. Users are advised to upgrade their library as soon as possible.

Gentoo Linux has released an advisory. Users who have installed dev-libs/libmcrypt-2.5.1-r4 or earlier are advised to update their systems by issuing the following commands:

emerge rsync
emerge libmcrypt
emerge clean

Conectiva has released a security advisory (CLA-2003:567) containing fixes. Users are advised to upgrade their mcrypt package as soon as possible.

Fix:


Mcrypt libmcrypt 2.4.10

Mcrypt libmcrypt 2.4.15

Mcrypt libmcrypt 2.4.18

Mcrypt libmcrypt 2.4.20

Mcrypt libmcrypt 2.4.7

Mcrypt libmcrypt 2.4.9

Mcrypt libmcrypt 2.5 .0

Mcrypt libmcrypt 2.5.2

Mcrypt libmcrypt 2.5.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站