CVE-2003-0021
CVSS5.0
发布时间 :2003-03-03 00:00:00
修订时间 :2016-10-17 22:28:25
NMCOS    

[原文]The "screen dump" feature in Eterm 0.9.1 and earlier allows attackers to overwrite arbitrary files via a certain character escape sequence when it is echoed to a user's terminal, e.g. when the user views a file containing the malicious sequence.


[CNNVD]Eterm Screen Dump 转义序列本地文件损坏漏洞(CNNVD-200303-023)

        Eterm 0.9.1及其更早版本的“screen dump”功能存在漏洞。攻击者可以借助用户批处理某个字符转义序列时覆盖任意文件,例如在用户浏览包含恶意序列的文件时。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:michael_jennings:eterm:0.9.1
cpe:/a:michael_jennings:eterm:0.8.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0021
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0021
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-023
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2003-q1/0093.html
(VENDOR_ADVISORY)  VULNWATCH  20030224 Terminal Emulator Security Issues
http://marc.info/?l=bugtraq&m=104612710031920&w=2
(UNKNOWN)  BUGTRAQ  20030224 Terminal Emulator Security Issues
http://www.iss.net/security_center/static/11413.php
(VENDOR_ADVISORY)  XF  terminal-emulator-screen-dump(11413)
http://www.mandrakesoft.com/security/advisories?name=MDKSA-2003:040
(UNKNOWN)  MANDRAKE  MDKSA-2003:040
http://www.securityfocus.com/bid/6936
(UNKNOWN)  BID  6936

- 漏洞信息

Eterm Screen Dump 转义序列本地文件损坏漏洞
中危 设计错误
2003-03-03 00:00:00 2005-10-12 00:00:00
远程  
        Eterm 0.9.1及其更早版本的“screen dump”功能存在漏洞。攻击者可以借助用户批处理某个字符转义序列时覆盖任意文件,例如在用户浏览包含恶意序列的文件时。

- 公告与补丁

        Gentoo Linux has released an advisory. Users who have installed x11-terms/eterm are advised to upgrade to eterm-0.9.2-r3 by issuing the following commands:
        emerge sync
        emerge -u eterm
        emerge clean
        This issue has been addressed in Eterm 0.9.2. Users are advised to upgrade.
        Michael Jennings Eterm 0.8.10
        
        Michael Jennings Eterm 0.9.1
        

- 漏洞信息

4590
Eterm Screen Dump Function Escape Sequence Arbitrary File Overwrite
Local Access Required, Context Dependent Input Manipulation
Loss of Integrity, Loss of Availability

- 漏洞描述

- 时间线

2003-03-03 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Eterm Screen Dump Escape Sequence Local File Corruption Vulnerability
Design Error 6936
Yes No
2003-02-24 12:00:00 2009-07-11 08:06:00
Discovery of these issues is credited to H D Moore and Digital Defense.

- 受影响的程序版本

Michael Jennings Eterm 0.9.1
+ Gentoo Linux 1.4 _rc2
+ Gentoo Linux 1.4 _rc1
+ Mandriva Linux Mandrake 9.0
Michael Jennings Eterm 0.8.10
Michael Jennings Eterm 0.9.2

- 不受影响的程序版本

Michael Jennings Eterm 0.9.2

- 漏洞讨论

Eterm's screen dump feature may be abused to corrupt local files which are writeable by the terminal user. This may result in remote compromise or local privilege escalation.

It is possible to exploit this issue if an attacker can cause malicious escape sequences to be displayed in a terminal window of a vulnerable terminal emulator.

- 漏洞利用

There is no exploit code required.

- 解决方案

Gentoo Linux has released an advisory. Users who have installed x11-terms/eterm are advised to upgrade to eterm-0.9.2-r3 by issuing the following commands:

emerge sync
emerge -u eterm
emerge clean

This issue has been addressed in Eterm 0.9.2. Users are advised to upgrade.


Michael Jennings Eterm 0.8.10

Michael Jennings Eterm 0.9.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站