CVE-2002-2427
CVSS5.0
发布时间 :2009-02-06 14:30:00
修订时间 :2009-07-23 00:00:00
NMCOS    

[原文]The security handler in GoAhead WebServer before 2.1.1 allows remote attackers to bypass authentication and obtain access to protected web content via "an extra slash in a URL," a different vulnerability than CVE-2002-1603.


[CNNVD]GoAhead WebServer 身份认证漏洞(CNNVD-200902-118)

        GoAhead WebServer是一款WEB发布服务系统软件。
        GoAhead WebServer 2.1.1之前版本中的安全处理程序允许远程攻击者借助"URL中一个额外的短斜线",绕过身份认证和获得对受保护的web内容的访问权限。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-287 [认证机制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:goahead:goahead_webserver:2.0GoAhead Software GoAhead WebServer 2.0
cpe:/a:goahead:goahead_webserver:2.1GoAhead Software GoAhead WebServer 2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-2427
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-2427
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200902-118
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/124059
(UNKNOWN)  CERT-VN  VU#124059
http://data.goahead.com/Software/Webserver/2.1.8/release.htm#security-features-can-be-bypassed-by-adding-an-extra-slash-in-the-url-bug01518
(VENDOR_ADVISORY)  CONFIRM  http://data.goahead.com/Software/Webserver/2.1.8/release.htm#security-features-can-be-bypassed-by-adding-an-extra-slash-in-the-url-bug01518

- 漏洞信息

GoAhead WebServer 身份认证漏洞
中危 授权问题
2009-02-06 00:00:00 2009-02-06 00:00:00
远程  
        GoAhead WebServer是一款WEB发布服务系统软件。
        GoAhead WebServer 2.1.1之前版本中的安全处理程序允许远程攻击者借助"URL中一个额外的短斜线",绕过身份认证和获得对受保护的web内容的访问权限。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.goahead.com/products/webserver/Download.aspx

- 漏洞信息

56425
GoAhead WebServer Extra Slash Request Authentication Bypass
Remote / Network Access Authentication Management
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

GoAhead WebServer contains a flaw in the authentication management when processing requests with extra slashes. With a specially crafted request, a remote attacker can bypass authentication.

- 时间线

2001-12-06 Unknow
Unknow 2001-12-05

- 解决方案

It has been reported that this issue has been fixed. Upgrade to version 2.1.1, or higher, to address this vulnerability. Rockwell Automation has released 1756-ENBT Version 4.008 and 1756-EWEB Version 4.009 to address the vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GoAhead WebServer Authentication Bypass and Multiple Denial of Service Vulnerabilities
Unknown 33838
Yes No
2002-10-17 12:00:00 2009-02-19 10:10:00
Richard Cullen, Luigi Auriemma, and the vendor.

- 受影响的程序版本

GoAhead Software GoAhead Webserver (Windows) 2.1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows ME
GoAhead Software GoAhead WebServer 2.1.5
GoAhead Software GoAhead WebServer 2.1.4
GoAhead Software GoAhead WebServer 2.1.3
GoAhead Software GoAhead WebServer 2.1.2
GoAhead Software GoAhead WebServer 2.1.1
GoAhead Software GoAhead WebServer 2.1
- Linux kernel 2.3
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows CE 3.0
- Microsoft Windows CE 2.0
- Microsoft Windows NT 4.0
GoAhead Software GoAhead WebServer 2.0
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows CE 3.0
- Microsoft Windows CE 2.0
- Microsoft Windows NT 4.0
GoAhead Software GoAhead WebServer 2.1.6

- 不受影响的程序版本

GoAhead Software GoAhead WebServer 2.1.6

- 漏洞讨论

GoAhead WebServer is prone to an authentication-bypass vulnerability and multiple denial-of-service vulnerabilities.

A remote attacker may exploit these issues to gain access to protected documents or to create a denial-of-service condition.

Versions prior to GoAhead WebServer 2.1.6 are vulnerable.

- 漏洞利用

An attacker can exploit these issues using readily available tools.

- 解决方案

The vendor has released updates. Please contact the vendor for details.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站